aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/bluez
diff options
context:
space:
mode:
authorStanislav Brabec <utx@penguin.cz>2009-09-16 19:40:17 +0000
committerutx@penguin.cz <utx@penguin.cz>2009-09-16 19:40:17 +0000
commit9298697cbf536b2d1db9b6c720dfab34758adbf6 (patch)
tree48db30a3aaa02841d22f69d3923e5205cc0ec82f /recipes/bluez
parent70bd2a139ac0d278ed71a390c59e6e25d4848214 (diff)
downloadopenembedded-9298697cbf536b2d1db9b6c720dfab34758adbf6.tar.gz
bluez-gnome: Fix crash on pairing configured rfcomm device. Typo fix.
Diffstat (limited to 'recipes/bluez')
-rw-r--r--recipes/bluez/bluez-gnome-1.8/add-device-from-rfcomm-crash.patch15
-rw-r--r--recipes/bluez/bluez-gnome-1.8/cs-typo.patch23
-rw-r--r--recipes/bluez/bluez-gnome_1.8.bb5
3 files changed, 42 insertions, 1 deletions
diff --git a/recipes/bluez/bluez-gnome-1.8/add-device-from-rfcomm-crash.patch b/recipes/bluez/bluez-gnome-1.8/add-device-from-rfcomm-crash.patch
new file mode 100644
index 0000000000..825b84f0dc
--- /dev/null
+++ b/recipes/bluez/bluez-gnome-1.8/add-device-from-rfcomm-crash.patch
@@ -0,0 +1,15 @@
+Fix for crash after access to the configured, but not yet paired RFCOMM device.
+http://www.spinics.net/lists/linux-bluetooth/msg03299.html
+Index: bluez-gnome-1.8/common/bluetooth-client.c
+===================================================================
+--- bluez-gnome-1.8.orig/common/bluetooth-client.c
++++ bluez-gnome-1.8/common/bluetooth-client.c
+@@ -330,7 +330,7 @@ static void add_device(DBusGProxy *adapt
+ name = value ? g_value_get_string(value) : NULL;
+
+ value = g_hash_table_lookup(hash, "Class");
+- type = class_to_type(g_value_get_uint(value));
++ type = value ? class_to_type(g_value_get_uint(value)) : BLUETOOTH_TYPE_ANY;
+
+ value = g_hash_table_lookup(hash, "Icon");
+ icon = value ? g_value_get_string(value) : "bluetooth";
diff --git a/recipes/bluez/bluez-gnome-1.8/cs-typo.patch b/recipes/bluez/bluez-gnome-1.8/cs-typo.patch
new file mode 100644
index 0000000000..0bb28ea7b4
--- /dev/null
+++ b/recipes/bluez/bluez-gnome-1.8/cs-typo.patch
@@ -0,0 +1,23 @@
+https://bugs.launchpad.net/bugs/427412
+Index: bluez-gnome-1.8/po/cs.po
+===================================================================
+--- bluez-gnome-1.8.orig/po/cs.po
++++ bluez-gnome-1.8/po/cs.po
+@@ -262,7 +262,7 @@
+ #: ../applet/main.c:110 ../applet/main.c:141 ../applet/main.c:204
+ #: ../applet/agent.c:685 ../applet/agent.c:726 ../applet/agent.c:871
+ msgid "Bluetooth device"
+-msgstr "Bluetooth zářízení"
++msgstr "Bluetooth zařízení"
+
+ #: ../applet/main.c:137
+ #, c-format
+@@ -295,7 +295,7 @@
+
+ #: ../applet/main.c:529
+ msgid "A Bluetooth manager for the GNOME desktop"
+-msgstr "Správce bluetooth pro GNOME"
++msgstr "Správce Bluetooth pro GNOME"
+
+ #: ../applet/main.c:532 ../analyzer/dialog.c:128
+ msgid "translator-credits"
diff --git a/recipes/bluez/bluez-gnome_1.8.bb b/recipes/bluez/bluez-gnome_1.8.bb
index 4756cf199f..43568e4939 100644
--- a/recipes/bluez/bluez-gnome_1.8.bb
+++ b/recipes/bluez/bluez-gnome_1.8.bb
@@ -1,10 +1,13 @@
DESCRIPTION = "Bluetooth configuration applet"
LICENSE = "GPL+LGPL"
+PR = "r1"
DEPENDS = "dbus-glib gconf libnotify gtk+"
RRECOMMENDS = "gnome-icon-theme"
-SRC_URI = "http://www.kernel.org/pub/linux/bluetooth/${P}.tar.gz"
+SRC_URI = "http://www.kernel.org/pub/linux/bluetooth/${P}.tar.gz \
+ file://add-device-from-rfcomm-crash.patch;patch=1 \
+ file://cs-typo.patch;patch=1"
inherit autotools pkgconfig gconf mime