aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/bluez
diff options
context:
space:
mode:
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>2009-06-23 14:31:22 +0200
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>2009-06-23 14:33:08 +0200
commit007c2e2b948edc3a8896e1e93844c1211d03ac61 (patch)
tree79bb3a2dc81795542addcc3526ec5b185e259228 /recipes/bluez
parent78ca80197a7acfed9f2259b053262a563b34b96b (diff)
downloadopenembedded-007c2e2b948edc3a8896e1e93844c1211d03ac61.tar.gz
bluez4: rebase 4.39 and 4.41 on new .inc file
Diffstat (limited to 'recipes/bluez')
-rw-r--r--recipes/bluez/bluez4_4.39.bb69
-rw-r--r--recipes/bluez/bluez4_4.41.bb67
2 files changed, 4 insertions, 132 deletions
diff --git a/recipes/bluez/bluez4_4.39.bb b/recipes/bluez/bluez4_4.39.bb
index 531eedf6da..7a2968bda7 100644
--- a/recipes/bluez/bluez4_4.39.bb
+++ b/recipes/bluez/bluez4_4.39.bb
@@ -1,69 +1,4 @@
-DESCRIPTION = "Linux Bluetooth Stack Userland V4"
-SECTION = "libs"
-PRIORITY = "optional"
-DEPENDS = "gst-plugins-base alsa-lib libusb-compat dbus-glib"
-HOMEPAGE = "http://www.bluez.org"
-LICENSE = "GPL"
+require bluez4.inc
-PR = "r1"
+PR = "${INC_PR}.1"
-# For angstrom we want this to replace at least bluez-libs
-PROVIDES_append_angstrom = " bluez-utils bluez-libs"
-
-SRC_URI = "\
- http://www.kernel.org/pub/linux/bluetooth/bluez-${PV}.tar.gz \
- file://fix-dfutool-usb-declaration-mismatch.patch;patch=1 \
- file://sbc-thumb.patch;patch=1 \
- file://bluetooth.conf \
-"
-S = "${WORKDIR}/bluez-${PV}"
-
-inherit autotools_stage update-rc.d
-AUTOTOOLS_STAGE_PKGCONFIG = "1"
-
-EXTRA_OECONF = "\
- --enable-gstreamer \
- --enable-alsa \
- --enable-usb \
- --enable-netlink \
- --enable-tools \
- --enable-bccmd \
- --enable-hid2hci \
- --enable-dfutool \
- --enable-hidd \
- --enable-pandd \
- --enable-dund \
- --disable-cups \
- --enable-test \
- --enable-manpages \
- --enable-configfiles \
- --enable-initscripts \
- --disable-pcmciarules \
-"
-
-do_install_append() {
- install -m 0644 ${S}/audio/audio.conf ${D}/${sysconfdir}/bluetooth/
- install -m 0644 ${S}/network/network.conf ${D}/${sysconfdir}/bluetooth/
- install -m 0644 ${S}/input/input.conf ${D}/${sysconfdir}/bluetooth/
- # at_console doesn't really work with the current state of OE, so punch some more holes so people can actually use BT
- install -m 0644 ${WORKDIR}/bluetooth.conf ${D}/${sysconfdir}/dbus-1/system.d/
-}
-
-INITSCRIPT_NAME = "bluetooth"
-INITSCRIPT_PARAMS = "defaults 23 19"
-
-PACKAGES =+ "gst-plugin-bluez libasound-module-bluez"
-
-FILES_gst-plugin-bluez = "${libdir}/gstreamer-0.10/lib*.so"
-FILES_libasound-module-bluez = "${libdir}/alsa-lib/lib*.so"
-FILES_${PN} += "${libdir}/bluetooth/plugins/*.so"
-FILES_${PN}-dev += "\
- ${libdir}/bluetooth/plugins/*.la \
- ${libdir}/alsa-lib/*.la \
- ${libdir}/gstreamer-0.10/*.la \
-"
-
-FILES_${PN}-dbg += "\
- ${libdir}/bluetooth/plugins/.debug \
- ${libdir}/*/.debug \
-"
diff --git a/recipes/bluez/bluez4_4.41.bb b/recipes/bluez/bluez4_4.41.bb
index 74dc9bcddc..7a2968bda7 100644
--- a/recipes/bluez/bluez4_4.41.bb
+++ b/recipes/bluez/bluez4_4.41.bb
@@ -1,67 +1,4 @@
-DESCRIPTION = "Linux Bluetooth Stack Userland V4"
-SECTION = "libs"
-PRIORITY = "optional"
-DEPENDS = "gst-plugins-base alsa-lib libusb-compat dbus-glib"
-HOMEPAGE = "http://www.bluez.org"
-LICENSE = "GPL"
+require bluez4.inc
-# For angstrom we want this to replace at least bluez-libs
-PROVIDES_append_angstrom = " bluez-utils bluez-libs"
+PR = "${INC_PR}.1"
-SRC_URI = "\
- http://www.kernel.org/pub/linux/bluetooth/bluez-${PV}.tar.gz \
- file://fix-dfutool-usb-declaration-mismatch.patch;patch=1 \
- file://sbc-thumb.patch;patch=1 \
- file://bluetooth.conf \
-"
-S = "${WORKDIR}/bluez-${PV}"
-
-inherit autotools_stage update-rc.d
-AUTOTOOLS_STAGE_PKGCONFIG = "1"
-
-EXTRA_OECONF = "\
- --enable-gstreamer \
- --enable-alsa \
- --enable-usb \
- --enable-netlink \
- --enable-tools \
- --enable-bccmd \
- --enable-hid2hci \
- --enable-dfutool \
- --enable-hidd \
- --enable-pandd \
- --enable-dund \
- --disable-cups \
- --enable-test \
- --enable-manpages \
- --enable-configfiles \
- --enable-initscripts \
- --disable-pcmciarules \
-"
-
-do_install_append() {
- install -m 0644 ${S}/audio/audio.conf ${D}/${sysconfdir}/bluetooth/
- install -m 0644 ${S}/network/network.conf ${D}/${sysconfdir}/bluetooth/
- install -m 0644 ${S}/input/input.conf ${D}/${sysconfdir}/bluetooth/
- # at_console doesn't really work with the current state of OE, so punch some more holes so people can actually use BT
- install -m 0644 ${WORKDIR}/bluetooth.conf ${D}/${sysconfdir}/dbus-1/system.d/
-}
-
-INITSCRIPT_NAME = "bluetooth"
-INITSCRIPT_PARAMS = "defaults 23 19"
-
-PACKAGES =+ "gst-plugin-bluez libasound-module-bluez"
-
-FILES_gst-plugin-bluez = "${libdir}/gstreamer-0.10/lib*.so"
-FILES_libasound-module-bluez = "${libdir}/alsa-lib/lib*.so"
-FILES_${PN} += "${libdir}/bluetooth/plugins/*.so"
-FILES_${PN}-dev += "\
- ${libdir}/bluetooth/plugins/*.la \
- ${libdir}/alsa-lib/*.la \
- ${libdir}/gstreamer-0.10/*.la \
-"
-
-FILES_${PN}-dbg += "\
- ${libdir}/bluetooth/plugins/.debug \
- ${libdir}/*/.debug \
-"