aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/bmon
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/bmon
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/bmon')
-rw-r--r--recipes/bmon/bmon_2.1.0.bb15
-rw-r--r--recipes/bmon/files/no-strip.patch13
2 files changed, 28 insertions, 0 deletions
diff --git a/recipes/bmon/bmon_2.1.0.bb b/recipes/bmon/bmon_2.1.0.bb
new file mode 100644
index 0000000000..d6cd03f614
--- /dev/null
+++ b/recipes/bmon/bmon_2.1.0.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Portable Bandwidth Monitor and rate estimator"
+HOMEPAGE = "http://people.suug.ch/~tgr/bmon/"
+SECTION = "console/utils"
+LICENSE = "MIT"
+# only works with libnl-0.5.0
+DEPENDS = "libnl"
+
+SRC_URI = "http://people.suug.ch/~tgr/bmon/files/bmon-2.1.0.tar.gz \
+ file://no-strip.patch;patch=1"
+
+inherit autotools
+
+do_compile() {
+ oe_runmake
+}
diff --git a/recipes/bmon/files/no-strip.patch b/recipes/bmon/files/no-strip.patch
new file mode 100644
index 0000000000..f09e816857
--- /dev/null
+++ b/recipes/bmon/files/no-strip.patch
@@ -0,0 +1,13 @@
+Index: bmon-2.1.0/GNUmakefile
+===================================================================
+--- bmon-2.1.0.orig/GNUmakefile
++++ bmon-2.1.0/GNUmakefile
+@@ -50,7 +50,7 @@ distclean: clean
+ install:
+ ./install-sh -d -m 0755 $(DESTDIR)$(prefix)/bin
+ ./install-sh -d -m 0755 $(DESTDIR)$(mandir)/man1
+- ./install-sh -c -s -m 0755 src/bmon $(DESTDIR)$(prefix)/bin
++ ./install-sh -c -m 0755 src/bmon $(DESTDIR)$(prefix)/bin
+ ./install-sh -c -m 0644 man/bmon.1 $(DESTDIR)$(mandir)/man1
+
+ show: Makefile.opts