aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/bochs/bochs_2.1.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/bochs/bochs_2.1.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/bochs/bochs_2.1.bb')
-rw-r--r--recipes/bochs/bochs_2.1.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes/bochs/bochs_2.1.bb b/recipes/bochs/bochs_2.1.bb
new file mode 100644
index 0000000000..1ae3a23314
--- /dev/null
+++ b/recipes/bochs/bochs_2.1.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "An x86 Emulator based on SDL."
+HOMEPAGE = "http://bochs.sf.net"
+LICENSE = "GPL"
+PR = "r1"
+
+# needs a patch for recent g++
+BROKEN = "1"
+
+APPIMAGE = "doc/docbook/images/dlxlinux-in-linux.png"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/bochs/bochs-${PV}.tar.gz \
+ file://compile.patch;patch=1"
+
+inherit autotools sdl
+
+EXTRA_OECONF = "--without-x \
+ --without-x11 \
+ --without-beos \
+ --without-win32 \
+ --without-macos \
+ --without-carbon \
+ --without-nogui \
+ --without-term \
+ --without-rfb \
+ --without-amigaos \
+ --with-sdl \
+ --without-svga \
+ --without-wx"
+
+do_compile() {
+ oe_runmake bochs bximage bxcommit
+}
+
+do_install() {
+ oe_runmake -i install # yes, ugly i know... but i can't get rid of that bailing out docbook crap atm.
+}