aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/bonjour/bonjour_107.6.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/bonjour/bonjour_107.6.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/bonjour/bonjour_107.6.bb')
-rw-r--r--recipes/bonjour/bonjour_107.6.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes/bonjour/bonjour_107.6.bb b/recipes/bonjour/bonjour_107.6.bb
new file mode 100644
index 0000000000..3c176c017a
--- /dev/null
+++ b/recipes/bonjour/bonjour_107.6.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "Bonjour is a networking technology that lets you create an instant network of computers and devices without any configuration."
+SECTION = "network"
+LICENSE = "Apache-2.0"
+
+RDEPENDS_bonjour = "update-rc.d"
+
+PR = "r3"
+
+SRC_URI = "http://www.opensource.apple.com/darwinsource/tarballs/other/mDNSResponder-${PV}.tar.gz \
+ file://bonjour.conf \
+ file://bonjour.init \
+ "
+
+S = "${WORKDIR}/mDNSResponder-${PV}"
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "bonjour"
+INITSCRIPT_PARAMS = "defaults 50"
+
+EXTRA_OEMAKE = 'CC="${CC} ${LDFLAGS}" os=linux -C ${S}/mDNSPosix SAResponder'
+PARALLEL_MAKE = ""
+
+do_install() {
+
+ install -d ${D}${sbindir}
+ install -m 0755 mDNSPosix/build/prod/mDNSResponderPosix ${D}${sbindir}/mdnsd
+
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/bonjour.init ${D}${sysconfdir}/init.d/bonjour
+ install -m 0640 ${WORKDIR}/bonjour.conf ${D}${sysconfdir}/
+
+}