summaryrefslogtreecommitdiffstats
path: root/recipes/boost
diff options
context:
space:
mode:
authorDenis 'Gnutoo' Carikli <GNUtoo@no-log.org>2009-12-06 23:59:11 +0100
committerDenis 'Gnutoo' Carikli <GNUtoo@no-log.org>2009-12-07 00:16:39 +0100
commit8bd570aa038b899cacaf6768945db691009ac884 (patch)
treefa0723855e445ed58d4c677d2a558b24998bb590 /recipes/boost
parentb3312705e639262b3b83017897cd3056b22e8912 (diff)
downloadopenembedded-8bd570aa038b899cacaf6768945db691009ac884.tar.gz
boost: add version 1.41.0 and modified boost-14x.inc
*1.41.0 fixes a bug with MPI: in 1.40.0 if you don't have the mpi libraries installed in your host it fails *added the dependency on icu because of things like that: unicode/utypes.h: No such file or directory *made it install in ${libdir} instead of ${libdir}/boost-${PV}: thanks woglinde for pointing me that a variable existed for that that is achieved with -DINSTALL_VERSIONED:BOOL=OFF *removed an useless like that were here because the recipe was copied from the split function was copied from an old boost recipe that used bjam
Diffstat (limited to 'recipes/boost')
-rw-r--r--recipes/boost/boost-14x.inc3
-rw-r--r--recipes/boost/boost_1.41.0.bb16
-rw-r--r--recipes/boost/files/1.41.0_uclibc.patch13
3 files changed, 31 insertions, 1 deletions
diff --git a/recipes/boost/boost-14x.inc b/recipes/boost/boost-14x.inc
index b1a5f6bb65..0a530013e2 100644
--- a/recipes/boost/boost-14x.inc
+++ b/recipes/boost/boost-14x.inc
@@ -22,6 +22,8 @@ EXTRA_OECMAKE = "-DBUILD_SHARED=ON \
-DBUILD_MULTI_THREADED=ON \
-DBUILD_RELEASE=ON \
-DBUILD_DEBUG=OFF \
+ -DWITH_MPI:BOOL=OFF \
+ -DINSTALL_VERSIONED:BOOL=OFF \
"
BOOST_LIBS = "\
@@ -64,7 +66,6 @@ python __anonymous () {
if not bb.data.getVar("FILES_%s" % pkg, d, 1):
bb.data.setVar("FILES_%s" % pkg, "${libdir}/libboost_%s*.so*" % lib, d)
bb.data.setVar("BOOST_PACKAGES", " ".join(packages), d)
- bb.data.setVar("BJAM_EXTRA", " ".join(extras), d)
}
# Override the contents of specific packages
diff --git a/recipes/boost/boost_1.41.0.bb b/recipes/boost/boost_1.41.0.bb
new file mode 100644
index 0000000000..a4c9287f79
--- /dev/null
+++ b/recipes/boost/boost_1.41.0.bb
@@ -0,0 +1,16 @@
+require boost-14x.inc
+
+PR = "r0"
+
+SRC_URI = "http://sodium.resophonic.com/boost-cmake/1.41.0.cmake0/boost-1.41.0.cmake0.tar.gz;name=tarball \
+ file://1.41.0_uclibc.patch;patch=1 \
+ "
+S = "${WORKDIR}/boost-1.41.0.cmake0"
+
+SRC_URI[tarball.md5sum] = "351747d991e3e391fea5623d4b5c038a"
+SRC_URI[tarball.sha256sum] = "78b7e72d34b057847ff99b291719d5bf1b76ed080bebfa3122549c231cc8fbed"
+
+DEPENDS += " icu "
+
+DEFAULT_PREFERENCE = "-1"
+
diff --git a/recipes/boost/files/1.41.0_uclibc.patch b/recipes/boost/files/1.41.0_uclibc.patch
new file mode 100644
index 0000000000..21d12da095
--- /dev/null
+++ b/recipes/boost/files/1.41.0_uclibc.patch
@@ -0,0 +1,13 @@
+Index: boost-1.41.0.cmake0/libs/thread/src/pthread/thread.cpp
+===================================================================
+--- boost-1.41.0.cmake0.orig/libs/thread/src/pthread/thread.cpp
++++ boost-1.41.0.cmake0/libs/thread/src/pthread/thread.cpp
+@@ -380,7 +380,7 @@ namespace boost
+ {
+ #if defined(PTW32_VERSION) || defined(__hpux)
+ return pthread_num_processors_np();
+-#elif defined(_GNU_SOURCE)
++#elif defined(_GNU_SOURCE) && !defined(__UCLIBC__)
+ return get_nprocs();
+ #elif defined(__APPLE__) || defined(__FreeBSD__)
+ int count;