aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/bootsplash
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/bootsplash
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/bootsplash')
-rw-r--r--recipes/bootsplash/bootsplash-native_3.0.7.bb19
-rw-r--r--recipes/bootsplash/bootsplash_3.0.7.bb28
-rw-r--r--recipes/bootsplash/files/freetype2.patch15
-rw-r--r--recipes/bootsplash/files/gcc-issues.patch22
4 files changed, 84 insertions, 0 deletions
diff --git a/recipes/bootsplash/bootsplash-native_3.0.7.bb b/recipes/bootsplash/bootsplash-native_3.0.7.bb
new file mode 100644
index 0000000000..bc5956d2c4
--- /dev/null
+++ b/recipes/bootsplash/bootsplash-native_3.0.7.bb
@@ -0,0 +1,19 @@
+# bootsplash-native OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+require bootsplash_${PV}.bb
+
+DEPENDS += "jpeg-native"
+
+inherit native
+S="${WORKDIR}/bootsplash-${PV}"
+
+do_compile() {
+ oe_runmake splash
+}
+
+do_stage() {
+ install -d ${STAGING_BINDIR}
+ install -m 0755 Utilities/splash ${STAGING_BINDIR}/splash
+}
diff --git a/recipes/bootsplash/bootsplash_3.0.7.bb b/recipes/bootsplash/bootsplash_3.0.7.bb
new file mode 100644
index 0000000000..da6f75b4d3
--- /dev/null
+++ b/recipes/bootsplash/bootsplash_3.0.7.bb
@@ -0,0 +1,28 @@
+# bootsplash OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION="Bootsplash shows pretty pictures during boot"
+HOMEPAGE="http://www.bootsplash.org"
+SECTION = "media-gfx"
+LICENSE = "GPL"
+SRC_URI="ftp://ftp.openbios.org/pub/bootsplash/rpm-sources/bootsplash/bootsplash-${PV}.tar.bz2 \
+ file://freetype2.patch;patch=1 \
+ file://gcc-issues.patch;patch=1"
+
+DEPENDS="freetype libmng"
+PR = "r1"
+
+EXTRA_OEMAKE += "-C Utilities \
+ CFLAGS='${CFLAGS} -I${STAGING_INCDIR}/freetype2/ -I${STAGING_INCDIR}' \
+ LDFLAGS='${LDFLAGS} -L${STAGING_LIBDIR} -ljpeg'"
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}${bindir}/
+ install -m 0755 ${S}/Utilities/fbtruetype ${D}${bindir}
+ install -m 0755 ${S}/Utilities/splash ${D}${bindir}
+}
diff --git a/recipes/bootsplash/files/freetype2.patch b/recipes/bootsplash/files/freetype2.patch
new file mode 100644
index 0000000000..3683c628f8
--- /dev/null
+++ b/recipes/bootsplash/files/freetype2.patch
@@ -0,0 +1,15 @@
+Index: bootsplash-3.0.7/Utilities/ttf.c
+===================================================================
+--- bootsplash-3.0.7.orig/Utilities/ttf.c 2003-08-09 11:58:44.000000000 +0200
++++ bootsplash-3.0.7/Utilities/ttf.c 2006-04-04 11:26:54.210699456 +0200
+@@ -9,8 +9,9 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <assert.h>
++#include <ft2build.h>
++#include FT_FREETYPE_H
+
+-#include <freetype/freetype.h>
+ #include <freetype/ftoutln.h>
+ #include <freetype/ttnameid.h>
+
diff --git a/recipes/bootsplash/files/gcc-issues.patch b/recipes/bootsplash/files/gcc-issues.patch
new file mode 100644
index 0000000000..c667fde329
--- /dev/null
+++ b/recipes/bootsplash/files/gcc-issues.patch
@@ -0,0 +1,22 @@
+--- bootsplash-3.0.7/Utilities/mng.c_orig 2006-06-07 15:03:47.000000000 +0000
++++ bootsplash-3.0.7/Utilities/mng.c 2006-06-07 15:04:46.000000000 +0000
+@@ -228,7 +228,8 @@
+ a = a * mymng->alpha / 100;
+ switch (mymng->fbbpp) {
+ case 16:
+- input = *((unsigned short *) background)++;
++ input = *((unsigned short *) background);
++ input = input++;
+
+ br = (input >> mng->fbredo) << (8 - mng->fbredl);
+ bg = (input >> mng->fbgreeno) << (8 -
+@@ -279,7 +280,8 @@
+ fbgreeno) | (b << mng->
+ fbblueo);
+
+- *((unsigned short *) dest)++ = output;
++ output = *((unsigned short *) dest);
++ output = output++;
+ break;
+ case 24:
+ *dest++ = b;