aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/bt-gps
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2009-11-18 09:24:44 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2009-11-18 09:57:39 +0100
commitc24888cefd27937b582594328537afdcfcc15fc5 (patch)
treef96d51f60fa32489b85ae86f149c68c60dd943f9 /recipes/bt-gps
parent13a6584623d13fd0365ea6dc88e0c67d24901b0c (diff)
downloadopenembedded-c24888cefd27937b582594328537afdcfcc15fc5.tar.gz
bt-gps: new recipe from SHR
Diffstat (limited to 'recipes/bt-gps')
-rw-r--r--recipes/bt-gps/bt-gps.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/bt-gps/bt-gps.bb b/recipes/bt-gps/bt-gps.bb
new file mode 100644
index 0000000000..414c37fb80
--- /dev/null
+++ b/recipes/bt-gps/bt-gps.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Turns your Neo Freerunner into a bluetooth GPS"
+SECTION = "console/network"
+PRIORITY = "optional"
+LICENSE = "GPL"
+RDEPENDS = "python python-pygtk gps-utils"
+
+SRC_URI = "http://handheldshell.com/software/fso/btgps.tgz \
+ "
+
+#inherit autotools
+
+S = ${WORKDIR}/bluetooth
+
+do_install() {
+ install -d ${D}/usr/share/applications
+ install -d ${D}/usr/bin
+ install -m 0755 ${S}/BtGPS.py ${D}/usr/bin
+ install -m 0755 ${S}/btgps.desktop ${D}/usr/share/applications
+}
+
+do_configure() {
+ exit 0
+}
+
+do_compile() {
+ exit 0
+}