aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/btscanner/btscanner-1.0/configure.patch
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/btscanner/btscanner-1.0/configure.patch
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/btscanner/btscanner-1.0/configure.patch')
-rw-r--r--recipes/btscanner/btscanner-1.0/configure.patch45
1 files changed, 45 insertions, 0 deletions
diff --git a/recipes/btscanner/btscanner-1.0/configure.patch b/recipes/btscanner/btscanner-1.0/configure.patch
new file mode 100644
index 0000000000..a69d4df9e4
--- /dev/null
+++ b/recipes/btscanner/btscanner-1.0/configure.patch
@@ -0,0 +1,45 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- btscanner-1.0/configure.in~configure.patch 2003-10-14 13:01:20.000000000 +0200
++++ btscanner-1.0/configure.in 2004-07-16 11:55:24.000000000 +0200
+@@ -10,9 +10,8 @@
+ AC_PROG_CC
+
+ # Checks for libraries.
+-AC_HAVE_LIBRARY(curses,,[AC_MSG_ERROR([Curses not found])])
++AC_HAVE_LIBRARY(ncurses,,[AC_MSG_ERROR([Curses not found])])
+ AC_HAVE_LIBRARY(bluetooth,,[AC_MSG_ERROR([Bluetooth not found])])
+-AC_HAVE_LIBRARY(sdp,,[AC_MSG_ERROR([SDP not found])])
+ AC_HAVE_LIBRARY(pthread,,[AC_MSG_ERROR([Pthreads not found])])
+ AC_HAVE_LIBRARY(gdbm,,[AC_MSG_ERROR([GDBM not found])])
+
+--- btscanner-1.0/Makefile.in~configure.patch 2003-10-14 14:16:23.000000000 +0200
++++ btscanner-1.0/Makefile.in 2004-07-16 11:54:45.000000000 +0200
+@@ -6,9 +6,12 @@
+ CP = cp
+ MV = mv
+ RM = rm
++INSTALL = install
+ GZIP = gzip
+ MKDIR = mkdir
+
++DESTDIR =
++
+ all: $(EXECS)
+
+ btscanner.o: btscanner.c btscanner.h
+@@ -34,7 +37,7 @@
+ $(CC) $(CFLAGS) -c $*.c
+
+ install: all
+- $(MKDIR) -p @prefix@/bin
+- $(CP) $(EXECS) @prefix@/bin/
+- $(MKDIR) -p @prefix@/etc
+- $(CP) oui.txt @prefix@/etc/oui.txt
++ $(INSTALL) -d $(DESTDIR)/@prefix@/bin
++ $(INSTALL) -m 0755 $(EXECS) $(DESTDIR)/@prefix@/bin/
++ $(INSTALL) -d $(DESTDIR)/@prefix@/etc
++ $(INSTALL) -m 0444 oui.txt $(DESTDIR)/@prefix@/etc/oui.txt