aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/btscanner
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/btscanner
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/btscanner')
-rw-r--r--recipes/btscanner/btscanner-1.0/0909132213173.patch25
-rw-r--r--recipes/btscanner/btscanner-1.0/configure.patch45
-rw-r--r--recipes/btscanner/btscanner_1.0.bb16
-rw-r--r--recipes/btscanner/btscanner_2.0.bb16
-rw-r--r--recipes/btscanner/files/configurable-paths.patch183
-rw-r--r--recipes/btscanner/files/gcc-4.patch12
6 files changed, 297 insertions, 0 deletions
diff --git a/recipes/btscanner/btscanner-1.0/0909132213173.patch b/recipes/btscanner/btscanner-1.0/0909132213173.patch
new file mode 100644
index 0000000000..1c4db165a5
--- /dev/null
+++ b/recipes/btscanner/btscanner-1.0/0909132213173.patch
@@ -0,0 +1,25 @@
+--- /tmp/bs_info.c 2005-10-07 16:04:20.842924176 +0200
++++ btscanner-1.0/bs_info.c 2005-10-07 16:08:26.368598600 +0200
+@@ -160,7 +160,7 @@
+ struct hci_conn_info_req *cr;
+ struct hci_request rq;
+ read_rssi_rp rp_rssi;
+- get_link_quality_rp rp_lq;
++ read_link_quality_rp rp_lq;
+ int err = 0;
+ int leave = 0;;
+
+@@ -292,11 +292,11 @@
+ memset(&rq, 0, sizeof(rq));
+ memset(&rp_lq, 0, sizeof(rp_lq));
+ rq.ogf = OGF_STATUS_PARAM;
+- rq.ocf = OCF_GET_LINK_QUALITY;
++ rq.ocf = OCF_READ_LINK_QUALITY;
+ rq.cparam = &handle;
+ rq.clen = 2;
+ rq.rparam = &rp_lq;
+- rq.rlen = GET_LINK_QUALITY_RP_SIZE;
++ rq.rlen = READ_LINK_QUALITY_RP_SIZE;
+
+ if (hci_send_req(dd, &rq, 100) < 0) {
+ p->lq_status = (uint8_t)-1;
diff --git a/recipes/btscanner/btscanner-1.0/configure.patch b/recipes/btscanner/btscanner-1.0/configure.patch
new file mode 100644
index 0000000000..a69d4df9e4
--- /dev/null
+++ b/recipes/btscanner/btscanner-1.0/configure.patch
@@ -0,0 +1,45 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- btscanner-1.0/configure.in~configure.patch 2003-10-14 13:01:20.000000000 +0200
++++ btscanner-1.0/configure.in 2004-07-16 11:55:24.000000000 +0200
+@@ -10,9 +10,8 @@
+ AC_PROG_CC
+
+ # Checks for libraries.
+-AC_HAVE_LIBRARY(curses,,[AC_MSG_ERROR([Curses not found])])
++AC_HAVE_LIBRARY(ncurses,,[AC_MSG_ERROR([Curses not found])])
+ AC_HAVE_LIBRARY(bluetooth,,[AC_MSG_ERROR([Bluetooth not found])])
+-AC_HAVE_LIBRARY(sdp,,[AC_MSG_ERROR([SDP not found])])
+ AC_HAVE_LIBRARY(pthread,,[AC_MSG_ERROR([Pthreads not found])])
+ AC_HAVE_LIBRARY(gdbm,,[AC_MSG_ERROR([GDBM not found])])
+
+--- btscanner-1.0/Makefile.in~configure.patch 2003-10-14 14:16:23.000000000 +0200
++++ btscanner-1.0/Makefile.in 2004-07-16 11:54:45.000000000 +0200
+@@ -6,9 +6,12 @@
+ CP = cp
+ MV = mv
+ RM = rm
++INSTALL = install
+ GZIP = gzip
+ MKDIR = mkdir
+
++DESTDIR =
++
+ all: $(EXECS)
+
+ btscanner.o: btscanner.c btscanner.h
+@@ -34,7 +37,7 @@
+ $(CC) $(CFLAGS) -c $*.c
+
+ install: all
+- $(MKDIR) -p @prefix@/bin
+- $(CP) $(EXECS) @prefix@/bin/
+- $(MKDIR) -p @prefix@/etc
+- $(CP) oui.txt @prefix@/etc/oui.txt
++ $(INSTALL) -d $(DESTDIR)/@prefix@/bin
++ $(INSTALL) -m 0755 $(EXECS) $(DESTDIR)/@prefix@/bin/
++ $(INSTALL) -d $(DESTDIR)/@prefix@/etc
++ $(INSTALL) -m 0444 oui.txt $(DESTDIR)/@prefix@/etc/oui.txt
diff --git a/recipes/btscanner/btscanner_1.0.bb b/recipes/btscanner/btscanner_1.0.bb
new file mode 100644
index 0000000000..d08e3e1ae8
--- /dev/null
+++ b/recipes/btscanner/btscanner_1.0.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Extract information from Bluetooth devices in range."
+SECTION = "libs"
+PRIORITY = "optional"
+HOMEPAGE = "http://www.pentest.co.uk/cgi-bin/viewcat.cgi?cat=downloads&section=01_bluetooth"
+DEPENDS = "bluez-libs gdbm ncurses"
+PR = "r3"
+LICENSE = "GPLv2"
+
+SRC_URI = "http://www.pentest.co.uk/src/btscanner-${PV}.tar.gz \
+ file://0909132213173.patch;patch=1 \
+ file://configure.patch;patch=1"
+
+#Yes, the packages uses this ugly hardcoded path instead of ${sysconfdir}
+FILES_${PN} += "/usr/etc/oui.txt"
+
+inherit autotools
diff --git a/recipes/btscanner/btscanner_2.0.bb b/recipes/btscanner/btscanner_2.0.bb
new file mode 100644
index 0000000000..4063a98b8e
--- /dev/null
+++ b/recipes/btscanner/btscanner_2.0.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Extract information from Bluetooth devices in range."
+SECTION = "libs"
+PRIORITY = "optional"
+HOMEPAGE = "http://www.pentest.co.uk/cgi-bin/viewcat.cgi?cat=downloads&section=01_bluetooth"
+DEPENDS = "bluez-libs gdbm ncurses libxml2"
+PR = "r2"
+LICENSE = "GPLv2"
+
+SRC_URI = "http://www.pentest.co.uk/src/btscanner-${PV}.tar.bz2 \
+ file://gcc-4.patch;patch=1 \
+ file://configurable-paths.patch;patch=1 \
+ "
+
+FILES_${PN} += "${datadir}/oui.txt"
+
+inherit autotools
diff --git a/recipes/btscanner/files/configurable-paths.patch b/recipes/btscanner/files/configurable-paths.patch
new file mode 100644
index 0000000000..b8afbf4059
--- /dev/null
+++ b/recipes/btscanner/files/configurable-paths.patch
@@ -0,0 +1,183 @@
+Index: btscanner-2.0/btscanner.xml
+===================================================================
+--- btscanner-2.0.orig/btscanner.xml 2007-08-11 18:51:51.000000000 +0200
++++ /dev/null 1970-01-01 00:00:00.000000000 +0000
+@@ -1,81 +0,0 @@
+-<?xml version="1.0" encoding="UTF-8"?>
+-<!DOCTYPE btscanner SYSTEM "file:///usr/local/etc/btscanner.dtd">
+-<btscanner>
+-<files>
+- <log>btscanner.log</log>
+- <oui>/usr/local/share/oui.txt</oui>
+- <store>~/bts</store>
+-</files>
+-
+-<!-- Global range -->
+-<rangedef start="00:00:00:00:00:00" end="FF:FF:FF:FF:FF:FF">
+- <vulnerabilities/>
+- <name/>
+- <hci/>
+-</rangedef>
+-
+-<!-- Nokia 6310i range 1 -->
+-<rangedef start="00:60:57:00:00:00" end="00:60:57:FF:FF:FF">
+- <vulnerabilities>Snarf</vulnerabilities>
+- <name/>
+- <hci/>
+- <rssi/>
+- <lq/>
+- <txpwr/>
+- <sdp/>
+-</rangedef>
+-<!-- Nokia 6310i range 2 -->
+-<rangedef start="00:0E:6D:00:00:00" end="00:0E:6D:FF:FF:FF">
+- <vulnerabilities>Snarf</vulnerabilities>
+- <name/>
+- <hci/>
+- <rssi/>
+- <lq/>
+- <txpwr/>
+- <sdp/>
+-</rangedef>
+-<!-- Nokia 6310i range 3 -->
+-<rangedef start="00:02:EE:00:00:00" end="00:02:EE:FF:FF:FF">
+- <vulnerabilities>Snarf</vulnerabilities>
+- <name/>
+- <hci/>
+- <rssi/>
+- <lq/>
+- <txpwr/>
+- <sdp/>
+-</rangedef>
+-
+-<!-- Nokia 6230 range 1 -->
+-<rangedef start="00:E0:03:00:00:00" end="00:E0:03:FF:FF:FF">
+- <vulnerabilities>Snarf</vulnerabilities>
+- <name/>
+- <hci/>
+- <rssi/>
+- <lq/>
+- <txpwr/>
+- <sdp/>
+-</rangedef>
+-
+-<!-- Sony Ericsson T610 range 1 -->
+-<rangedef start="00:0E:07:00:00:00" end="00:0E:07:FF:FF:FF">
+- <vulnerabilities>Snarf</vulnerabilities>
+- <name/>
+- <hci/>
+- <rssi/>
+- <lq/>
+- <txpwr/>
+- <sdp/>
+-</rangedef>
+-<!-- Sony Ericsson T610 (also others) range 2 -->
+-<rangedef start="00:0A:D9:00:00:00" end="00:0A:D9:FF:FF:FF">
+- <vulnerabilities>Snarf</vulnerabilities>
+- <name/>
+- <hci/>
+- <rssi/>
+- <lq/>
+- <txpwr/>
+- <sdp/>
+-</rangedef>
+-
+-</btscanner>
+-
+Index: btscanner-2.0/btscanner.xml.in
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ btscanner-2.0/btscanner.xml.in 2007-08-11 18:52:27.000000000 +0200
+@@ -0,0 +1,81 @@
++<?xml version="1.0" encoding="UTF-8"?>
++<!DOCTYPE btscanner SYSTEM "file://@sysconfdir@/btscanner.dtd">
++<btscanner>
++<files>
++ <log>btscanner.log</log>
++ <oui>@datadir@/oui.txt</oui>
++ <store>~/bts</store>
++</files>
++
++<!-- Global range -->
++<rangedef start="00:00:00:00:00:00" end="FF:FF:FF:FF:FF:FF">
++ <vulnerabilities/>
++ <name/>
++ <hci/>
++</rangedef>
++
++<!-- Nokia 6310i range 1 -->
++<rangedef start="00:60:57:00:00:00" end="00:60:57:FF:FF:FF">
++ <vulnerabilities>Snarf</vulnerabilities>
++ <name/>
++ <hci/>
++ <rssi/>
++ <lq/>
++ <txpwr/>
++ <sdp/>
++</rangedef>
++<!-- Nokia 6310i range 2 -->
++<rangedef start="00:0E:6D:00:00:00" end="00:0E:6D:FF:FF:FF">
++ <vulnerabilities>Snarf</vulnerabilities>
++ <name/>
++ <hci/>
++ <rssi/>
++ <lq/>
++ <txpwr/>
++ <sdp/>
++</rangedef>
++<!-- Nokia 6310i range 3 -->
++<rangedef start="00:02:EE:00:00:00" end="00:02:EE:FF:FF:FF">
++ <vulnerabilities>Snarf</vulnerabilities>
++ <name/>
++ <hci/>
++ <rssi/>
++ <lq/>
++ <txpwr/>
++ <sdp/>
++</rangedef>
++
++<!-- Nokia 6230 range 1 -->
++<rangedef start="00:E0:03:00:00:00" end="00:E0:03:FF:FF:FF">
++ <vulnerabilities>Snarf</vulnerabilities>
++ <name/>
++ <hci/>
++ <rssi/>
++ <lq/>
++ <txpwr/>
++ <sdp/>
++</rangedef>
++
++<!-- Sony Ericsson T610 range 1 -->
++<rangedef start="00:0E:07:00:00:00" end="00:0E:07:FF:FF:FF">
++ <vulnerabilities>Snarf</vulnerabilities>
++ <name/>
++ <hci/>
++ <rssi/>
++ <lq/>
++ <txpwr/>
++ <sdp/>
++</rangedef>
++<!-- Sony Ericsson T610 (also others) range 2 -->
++<rangedef start="00:0A:D9:00:00:00" end="00:0A:D9:FF:FF:FF">
++ <vulnerabilities>Snarf</vulnerabilities>
++ <name/>
++ <hci/>
++ <rssi/>
++ <lq/>
++ <txpwr/>
++ <sdp/>
++</rangedef>
++
++</btscanner>
++
+Index: btscanner-2.0/configure.in
+===================================================================
+--- btscanner-2.0.orig/configure.in 2007-08-11 18:51:35.000000000 +0200
++++ btscanner-2.0/configure.in 2007-08-11 18:55:44.000000000 +0200
+@@ -89,5 +89,5 @@
+ CFLAGS="$CFLAGS -DCFG_FILE=\\\"$cfgfile\\\" -DCFG_DTD=\\\"$cfgdtd\\\""
+
+ # output
+-AC_CONFIG_FILES([Makefile])
++AC_CONFIG_FILES([Makefile btscanner.xml])
+ AC_OUTPUT
diff --git a/recipes/btscanner/files/gcc-4.patch b/recipes/btscanner/files/gcc-4.patch
new file mode 100644
index 0000000000..dab2bfa2ff
--- /dev/null
+++ b/recipes/btscanner/files/gcc-4.patch
@@ -0,0 +1,12 @@
+diff -Naur btscanner-2.0.orig/configure.in btscanner-2.0/configure.in
+--- btscanner-2.0.orig/configure.in 2004-11-01 12:56:02.000000000 +0100
++++ btscanner-2.0/configure.in 2007-03-11 14:58:09.000000000 +0100
+@@ -64,7 +64,7 @@
+
+ # CFLAGS
+ CFLAGS="$CFLAGS -Wall -pthread -Wshadow -Wbad-function-cast \
+- -Wformat -Wimplicit-function-dec -Wparentheses -Wsign-compare \
++ -Wformat -Wparentheses -Wsign-compare \
+ -Wstrict-prototypes -Wtrigraphs -Wundef -Wuninitialized \
+ -W -Wunused -Wformat-security -Wmissing-braces -Wbad-function-cast \
+ -Wcast-qual -falign-functions -falign-labels -falign-loops\