aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/buglabs-apps/com.buglabs.app.com.buglabs.common.regexp.bb
diff options
context:
space:
mode:
authorStefan Schmidt <stefan@buglabs.net>2010-12-02 16:00:50 +0100
committerStefan Schmidt <stefan@buglabs.net>2011-02-03 11:39:20 +0100
commita32e9b20267f506bbbab64cf2d8a45b374df6081 (patch)
tree0be3564e97f98d34dfb9b412ecc6f27a49fb08d5 /recipes/buglabs-apps/com.buglabs.app.com.buglabs.common.regexp.bb
parent0a509aeb50214b93eff979f6080bced5efe5ca04 (diff)
downloadopenembedded-a32e9b20267f506bbbab64cf2d8a45b374df6081.tar.gz
buglabs-apps: BugLabs java applications.
Tons of small apps that live on buglabs.net and are mostly arch independent. These recipes make them available for images and feeds.
Diffstat (limited to 'recipes/buglabs-apps/com.buglabs.app.com.buglabs.common.regexp.bb')
-rw-r--r--recipes/buglabs-apps/com.buglabs.app.com.buglabs.common.regexp.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/buglabs-apps/com.buglabs.app.com.buglabs.common.regexp.bb b/recipes/buglabs-apps/com.buglabs.app.com.buglabs.common.regexp.bb
new file mode 100644
index 0000000000..ceb2195224
--- /dev/null
+++ b/recipes/buglabs-apps/com.buglabs.app.com.buglabs.common.regexp.bb
@@ -0,0 +1,27 @@
+require bug-app.inc
+
+DESCRIPTION = "After I took a couple of courses in Theoretical Computer Science, I started to like regular expression. When I realized that the package was not available on the bug platform, I loved the idea of creating my own regexp bundle. \
+This bundle uses 'dk.brics.automaton(c)':http://www.brics.dk/~amoeller/automaton/index.html developed by Anders Moeller. \
+To uses the package just export _*com.buglabs.common.regexp.pub*_ in your manifest file. Also Take a look at 'RegExpSample':http://buglabs.net/applications/RegExpSample to see how to use this package. Download both this application and RegExpSample to Dragonfly or your BUG.\
+Regular expressions basic syntax:\
+UNION\
+unionexp ::= interexp | unionexp (union) \
+interexp ::= concatexp & interexp (intersection) [OPTIONAL]\
+CONCAT\
+concatexp ::= repeatexp concatexp (concatenation) \
+REPEAT\
+repeatexp ::= repeatexp ? (zero or one occurrence) \
+ | repeatexp * (zero or more occurrences) \
+ | repeatexp + (one or more occurrences) \
+ | repeatexp {n} (n occurrences) \
+ | repeatexp {n,} (n or more occurrences) \
+ | repeatexp {n,m} (n to m occurrences, including both) \
+ | complexp \
+"
+HOMEPAGE = "http://buglabs.net/applications/com.buglabs.common.regexp"
+
+PV = "2"
+
+SRC_LINK = "http://buglabs.net/program_version/download/850"
+
+APIVERSION = ""