aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/buglabs
diff options
context:
space:
mode:
authorStefan Schmidt <stefan@buglabs.net>2010-11-11 15:01:08 +0100
committerStefan Schmidt <stefan@buglabs.net>2011-01-20 14:27:58 +0100
commit904e9ad41631dfbb7fb9819a11568d99e5c386e2 (patch)
treeb7c643e58ccd0769d1a1567194626508230cc8e8 /recipes/buglabs
parentb203a051cc48b63cfca2411b03e36199905e8e82 (diff)
downloadopenembedded-904e9ad41631dfbb7fb9819a11568d99e5c386e2.tar.gz
matchbox-theme-bug: Add matchbox themes for buglabs
Diffstat (limited to 'recipes/buglabs')
-rw-r--r--recipes/buglabs/matchbox-theme-bug-dark.bb6
-rwxr-xr-xrecipes/buglabs/matchbox-theme-bug-dark/session9
-rw-r--r--recipes/buglabs/matchbox-theme-bug.inc42
-rwxr-xr-xrecipes/buglabs/matchbox-theme-bug/session9
-rw-r--r--recipes/buglabs/matchbox-theme-bug_0.1.bb6
5 files changed, 72 insertions, 0 deletions
diff --git a/recipes/buglabs/matchbox-theme-bug-dark.bb b/recipes/buglabs/matchbox-theme-bug-dark.bb
new file mode 100644
index 0000000000..1377cc52d1
--- /dev/null
+++ b/recipes/buglabs/matchbox-theme-bug-dark.bb
@@ -0,0 +1,6 @@
+DESCRIPTION = "Matchbox window manager dark BUG theme"
+
+THEME_NAME="Bug-Dark"
+PR="r18"
+
+include matchbox-theme-bug.inc
diff --git a/recipes/buglabs/matchbox-theme-bug-dark/session b/recipes/buglabs/matchbox-theme-bug-dark/session
new file mode 100755
index 0000000000..82cbf6f645
--- /dev/null
+++ b/recipes/buglabs/matchbox-theme-bug-dark/session
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+SHOWCURSOR="no"
+
+matchbox-desktop-2 &
+
+matchbox-panel-2 --titlebar --start-applets showdesktop,windowselector --end-applets clock,battery,systray,startup-notify,notify &
+
+exec matchbox-window-manager -theme Bug-Dark -use_desktop_mode decorated -use_cursor $SHOWCURSOR $@
diff --git a/recipes/buglabs/matchbox-theme-bug.inc b/recipes/buglabs/matchbox-theme-bug.inc
new file mode 100644
index 0000000000..28e0d63265
--- /dev/null
+++ b/recipes/buglabs/matchbox-theme-bug.inc
@@ -0,0 +1,42 @@
+LICENSE = "CC-BY-SA3"
+DEPENDS = "matchbox-wm"
+SECTION = "x11/wm"
+
+SRCREV=${AUTOREV}
+
+SRC_URI += "svn://bugcamp.net/bug/trunk/;module=com.buglabs.bug.theme/matchbox/${THEME_NAME} \
+ file://session"
+
+FILES_${PN} = "${datadir}/themes/${THEME_NAME} \
+ ${sysconfdir}/matchbox/session"
+
+S = ${WORKDIR}/com.buglabs.bug.theme/matchbox/${THEME_NAME}
+
+REQUIRES = "matchbox-sato"
+
+do_install() {
+ install -m 0755 -d ${D}${datadir}/themes/${THEME_NAME}/matchbox
+ install -m 0755 -d ${D}${datadir}/themes/${THEME_NAME}/gtk-2.0
+
+ install -m 0644 ${S}/index.theme ${D}${datadir}/themes/${THEME_NAME}/
+ install -m 0644 ${S}/gtk-2.0/*.png ${D}${datadir}/themes/${THEME_NAME}/gtk-2.0/
+ install -m 0644 ${S}/gtk-2.0/gtkrc ${D}${datadir}/themes/${THEME_NAME}/gtk-2.0/
+ install -m 0644 ${S}/matchbox/*.png ${D}${datadir}/themes/${THEME_NAME}/matchbox/
+ install -m 0644 ${S}/matchbox/theme.xml ${D}${datadir}/themes/${THEME_NAME}/matchbox/
+ install -m 0755 -d ${D}${sysconfdir}/matchbox
+ install -m 0744 ${WORKDIR}/session ${D}${sysconfdir}/matchbox/session
+}
+
+pkg_postinst_${PN} () {
+ if [ "x$D" != "x" ]; then
+ exit 1
+ fi
+
+ . ${sysconfdir}/init.d/functions
+
+ gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/theme ${THEME_NAME}
+ gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/icon_theme Bug
+ gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type bool --set /desktop/poky/interface/touchscreen true
+ gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/font_name "Sans 9"
+}
+
diff --git a/recipes/buglabs/matchbox-theme-bug/session b/recipes/buglabs/matchbox-theme-bug/session
new file mode 100755
index 0000000000..82cbf6f645
--- /dev/null
+++ b/recipes/buglabs/matchbox-theme-bug/session
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+SHOWCURSOR="no"
+
+matchbox-desktop-2 &
+
+matchbox-panel-2 --titlebar --start-applets showdesktop,windowselector --end-applets clock,battery,systray,startup-notify,notify &
+
+exec matchbox-window-manager -theme Bug-Dark -use_desktop_mode decorated -use_cursor $SHOWCURSOR $@
diff --git a/recipes/buglabs/matchbox-theme-bug_0.1.bb b/recipes/buglabs/matchbox-theme-bug_0.1.bb
new file mode 100644
index 0000000000..f37e858b33
--- /dev/null
+++ b/recipes/buglabs/matchbox-theme-bug_0.1.bb
@@ -0,0 +1,6 @@
+DESCRIPTION = "Matchbox window manager red BUG theme"
+
+THEME_NAME="Bug"
+PR = "r2"
+
+include matchbox-theme-bug.inc