summaryrefslogtreecommitdiffstats
path: root/recipes/buglabs
diff options
context:
space:
mode:
authorStefan Schmidt <stefan@buglabs.net>2010-12-08 12:59:51 +0100
committerStefan Schmidt <stefan@buglabs.net>2011-02-09 10:33:57 +0100
commit343b243cf2e30d11ab3538cbf286d0c6adba2422 (patch)
tree3e89642dd46d4380b92dff20d45f08641e292aee /recipes/buglabs
parent0e9b38a840f219edf39b3ed1c6b493e1519fbfbf (diff)
downloadopenembedded-343b243cf2e30d11ab3538cbf286d0c6adba2422.tar.gz
buglabs/dauber-feeds: Feed config for internal repos
Diffstat (limited to 'recipes/buglabs')
-rw-r--r--recipes/buglabs/dauber-feed-configs.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/buglabs/dauber-feed-configs.bb b/recipes/buglabs/dauber-feed-configs.bb
new file mode 100644
index 0000000000..b4333d1c46
--- /dev/null
+++ b/recipes/buglabs/dauber-feed-configs.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Configuration files for online package repositories aka feeds"
+
+PR = "r1"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+FEED_BASEPATH = "buildbot/trunk/incremental/feeds/"
+
+do_compile() {
+ mkdir -p ${S}/${sysconfdir}/opkg
+
+ for feed in all armv7a bug20 ; do
+ echo "src/gz dauber-${feed} http://dauber/${FEED_BASEPATH}${feed}" > ${S}/${sysconfdir}/opkg/dauber-${feed}-feed.conf
+ done
+}
+
+
+do_install () {
+ install -d ${D}${sysconfdir}/opkg
+ install -m 0644 ${S}/${sysconfdir}/opkg/* ${D}${sysconfdir}/opkg/
+}
+
+FILES_${PN} = "${sysconfdir}/opkg/"
+
+CONFFILES_${PN} += "${sysconfdir}/opkg/*.conf"