summaryrefslogtreecommitdiffstats
path: root/recipes/buglabs
diff options
context:
space:
mode:
authorStefan Schmidt <stefan@buglabs.net>2011-02-09 12:40:25 +0100
committerStefan Schmidt <stefan@buglabs.net>2011-02-09 14:19:02 +0100
commita25c44e70f3ece85b41e6c4e49c1a6867dc36a12 (patch)
tree980242e76c74e52a214a359c592ebf58f2275bf5 /recipes/buglabs
parent235a67532cc6dc3994bb96f71a3edeed32ce05c0 (diff)
downloadopenembedded-a25c44e70f3ece85b41e6c4e49c1a6867dc36a12.tar.gz
bug2v4l2: Fix recipe to atcually work.
The first commit of this one was not intended. Sorry for that. The recipe is now cleaned up and working.
Diffstat (limited to 'recipes/buglabs')
-rw-r--r--recipes/buglabs/bug2v4l2_0.01.bb39
-rw-r--r--recipes/buglabs/bug2v4l2_git.bb37
2 files changed, 37 insertions, 39 deletions
diff --git a/recipes/buglabs/bug2v4l2_0.01.bb b/recipes/buglabs/bug2v4l2_0.01.bb
deleted file mode 100644
index 991bb94d9f..0000000000
--- a/recipes/buglabs/bug2v4l2_0.01.bb
+++ /dev/null
@@ -1,39 +0,0 @@
-DESCRIPTION = "Video 4 Linux 2 Tools for Bug 2.0"
-LICENSE = "BSD"
-HOMEPAGE = "http://bugcommunity.com/wiki"
-MAINTAINER = "Bug Labs, Inc."
-DEPENDS += "virtual/kernel python"
-AUTHOR = "Lane Brooks <lane@brooksee.org>"
-inherit distutils-base
-
-PV = "0.01"
-PR = "r1"
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-COMPATIBLE_MACHINE = "bug20"
-
-SRCREV="8321b5766b464a4cf80ff5f1c03276ee7f136d81"
-SRC_URI = git://gitorious.org/bl-camera2-test-app/bl-camera2-test-app.git;protocol=git"
-
-EXTRA_OEMAKE += "KDIR=${STAGING_KERNEL_DIR} OE_PATH=${STAGING_INCDIR}"
-
-S = "${WORKDIR}/git"
-do_install () {
-install -d ${D}${bindir}/
-install -m 0755 ${S}/bug2v4l2 ${D}${bindir}/
-
-install -d ${D}${libdir}/${PYTHON_DIR}/site-packages/bug2v4l2
-install -m 0755 -t ${D}${libdir}/${PYTHON_DIR}/site-packages/bug2v4l2
-{S}/python/build/bug2v4l2/*
-
-install -d ${D}${datadir}/bug2v4l2/examples
-install -m 0755 -t ${D}${datadir}/bug2v4l2/examples ${S}/python/examples/*
-install -m 0755 -t ${D}${datadir}/bug2v4l2/examples ${S}/examples/*
-}
-
-FILES_${PN} += "${bindir}/bug2v4l2"
-FILES_${PN} += "${libdir}/${PYTHON_DIR}/site-packages/bug2v4l2"
-FILES_${PN}-debug += "${bindir}/.debug/bug2v4l2"
-
-PACKAGES =+ "${PN}-examples"
-FILES_${PN}-examples = "${datadir}/bug2v4l2/examples"
diff --git a/recipes/buglabs/bug2v4l2_git.bb b/recipes/buglabs/bug2v4l2_git.bb
new file mode 100644
index 0000000000..924607e1fa
--- /dev/null
+++ b/recipes/buglabs/bug2v4l2_git.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "Video 4 Linux 2 Tools for Bug 2.0"
+LICENSE = "BSD"
+DEPENDS = "virtual/kernel python"
+
+inherit distutils-base
+
+PV = "0.01"
+PR = "r2"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+COMPATIBLE_MACHINE = "bug20"
+
+SRCREV = "8321b5766b464a4cf80ff5f1c03276ee7f136d81"
+SRC_URI = "git://gitorious.org/bl-camera2-test-app/bl-camera2-test-app.git;protocol=git"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE += " KDIR=${STAGING_KERNEL_DIR} OE_PATH=${STAGING_INCDIR} "
+
+do_install () {
+ install -d ${D}${bindir}/
+ install -m 0755 ${S}/bug2v4l2 ${D}${bindir}/
+
+ install -d ${D}${libdir}/${PYTHON_DIR}/site-packages/bug2v4l2
+ install -m 0755 ${S}/python/build/bug2v4l2/* ${D}${libdir}/${PYTHON_DIR}/site-packages/bug2v4l2
+
+ install -d ${D}${datadir}/bug2v4l2/examples
+ install -m 0755 ${S}/python/examples/* ${D}${datadir}/bug2v4l2/examples
+ install -m 0755 ${S}/examples/* ${D}${datadir}/bug2v4l2/examples
+}
+
+FILES_${PN} += "${bindir}/bug2v4l2"
+FILES_${PN} += "${libdir}/${PYTHON_DIR}/site-packages/bug2v4l2"
+FILES_${PN}-debug += "${bindir}/.debug/bug2v4l2"
+
+PACKAGES =+ "${PN}-examples"
+FILES_${PN}-examples = "${datadir}/bug2v4l2/examples"