aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/bustle
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-04-22 17:18:25 +0200
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-04-22 17:19:18 +0200
commit82ede6b24b408cdeabde96dd0023919867ada753 (patch)
treeae0de27a9278da621425852ea459d84b27a20c02 /recipes/bustle
parent71f70d7be487035d59d9bc0f04bcb621ef615b15 (diff)
downloadopenembedded-82ede6b24b408cdeabde96dd0023919867ada753.tar.gz
bustle-dbus-monitor: new recipe; monitoring utility for the Bustle D-Bus suite
TODO: add eavesdropping magic in postinstall/prerm
Diffstat (limited to 'recipes/bustle')
-rw-r--r--recipes/bustle/bustle-dbus-monitor_0.2.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/bustle/bustle-dbus-monitor_0.2.0.bb b/recipes/bustle/bustle-dbus-monitor_0.2.0.bb
new file mode 100644
index 0000000000..4d4768f4de
--- /dev/null
+++ b/recipes/bustle/bustle-dbus-monitor_0.2.0.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "The monitoring utilitiy for the Bustle D-Bus diagram application."
+HOMEPAGE = "http://www.willthompson.co.uk/bustle"
+DEPENDS = "dbus glib-2.0"
+LICENSE = "LGPL"
+SECTION = "console/network"
+
+SRC_URI = "http://www.willthompson.co.uk/bustle/releases/bustle-${PV}.tar.gz"
+S = "${WORKDIR}/bustle-${PV}"
+
+do_compile() {
+ ${CC} ${CFLAGS} ${LDFLAGS} `pkg-config --cflags --libs dbus-1 glib-2.0` -o bustle-dbus-monitor bustle-dbus-monitor.c
+}
+
+do_install() {
+ install -d ${D}${sbindir}
+ install -m 0755 bustle-dbus-monitor ${D}${sbindir}
+}
+
+FILES_${PN} += "${sbindir}"