summaryrefslogtreecommitdiffstats
path: root/recipes/busybox/busybox_1.14.3.bb
diff options
context:
space:
mode:
authorDirk Opfer <dirk@do13.de>2009-08-06 21:42:56 +0200
committerDirk Opfer <dirk@do13.de>2009-08-06 21:55:31 +0200
commit1e4fc3556b84654a11a460484988abfc80b5d1ae (patch)
treedabc999a667053bd8f3a6aee94b8e7294efba1c2 /recipes/busybox/busybox_1.14.3.bb
parentc04bac092910c7abb3ff328597c57cc204ba51a6 (diff)
downloadopenembedded-1e4fc3556b84654a11a460484988abfc80b5d1ae.tar.gz
busybox: add new version 1.14.3
DEFAULT_PREFERENCE is set to "-1".
Diffstat (limited to 'recipes/busybox/busybox_1.14.3.bb')
-rw-r--r--recipes/busybox/busybox_1.14.3.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/recipes/busybox/busybox_1.14.3.bb b/recipes/busybox/busybox_1.14.3.bb
new file mode 100644
index 0000000000..1634727854
--- /dev/null
+++ b/recipes/busybox/busybox_1.14.3.bb
@@ -0,0 +1,44 @@
+require busybox.inc
+PR = "${INC_PR}.0"
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "\
+ http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
+\
+ file://udhcpscript.patch;patch=1 \
+ file://udhcpc-fix-nfsroot.patch;patch=1 \
+ file://B921600.patch;patch=1 \
+ file://get_header_tar.patch;patch=1 \
+ file://busybox-appletlib-dependency.patch;patch=1 \
+ file://find-touchscreen.sh \
+ file://busybox-cron \
+ file://busybox-httpd \
+ file://busybox-udhcpd \
+ file://default.script file://simple.script \
+ file://hwclock.sh \
+ file://mount.busybox \
+ file://mountall \
+ file://syslog \
+ file://syslog.conf \
+ file://umount.busybox \
+ file://defconfig \
+ file://mdev \
+ file://mdev.conf \
+"
+
+EXTRA_OEMAKE += "V=1 ARCH=${TARGET_ARCH} CROSS_COMPILE=${TARGET_PREFIX}"
+
+do_configure_prepend () {
+ if [ "${TARGET_ARCH}" = "avr32" ] ; then
+ sed -i s:CONFIG_FEATURE_OSF_LABEL=y:CONFIG_FEATURE_OSF_LABEL=n: ${WORKDIR}/defconfig
+ fi
+}
+
+do_install_append() {
+ install -m 0644 ${WORKDIR}/mdev.conf ${D}${sysconfdir}/
+ install -d ${D}${sysconfdir}/init.d/
+ install -d ${D}${sysconfdir}/mdev
+ install -m 0755 ${WORKDIR}/find-touchscreen.sh ${D}${sysconfdir}/mdev/
+ install -m 0755 ${WORKDIR}/mdev ${D}${sysconfdir}/init.d/
+}