aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/busybox/slingbox_1.3.1.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/busybox/slingbox_1.3.1.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/busybox/slingbox_1.3.1.bb')
-rw-r--r--recipes/busybox/slingbox_1.3.1.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/recipes/busybox/slingbox_1.3.1.bb b/recipes/busybox/slingbox_1.3.1.bb
new file mode 100644
index 0000000000..0a9051d447
--- /dev/null
+++ b/recipes/busybox/slingbox_1.3.1.bb
@@ -0,0 +1,52 @@
+DESCRIPTION = "SlingBox is a minimal version of BusyBox with just enough functionality \
+to enable ipkg to run on an Unslung NSLU2 device."
+HOMEPAGE = "http://www.busybox.net"
+LICENSE = "GPL"
+SECTION = "base"
+PRIORITY = "required"
+PR = "r4"
+COMPATIBLE_MACHINE = "nslu2"
+
+SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
+ file://defconfig \
+ file://mountall \
+ file://shadow_h_is_required.patch;patch=1 \
+ file://df_rootfs.patch;patch=1 \
+ file://lazy_umount.patch;patch=1 \
+ file://halt.patch;patch=1 \
+ file://fdisk-readhex.patch;patch=1 \
+ file://trylink-bash.patch;patch=1 \
+ file://slingbox_name.patch;patch=1 \
+ file://slingbox.patch;patch=1"
+
+S = "${WORKDIR}/busybox-${PV}"
+
+export EXTRA_CFLAGS = "${CFLAGS}"
+EXTRA_OEMAKE_append = " V=1 ARCH=arm CROSS_COMPILE=${TARGET_PREFIX}"
+
+FILES_${PN} = "/"
+FILES_${PN}-doc = ""
+FILES_${PN}-dev = ""
+FILES_${PN}-locale = ""
+
+inherit cml1
+
+do_configure () {
+ install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+ cml1_do_configure
+}
+
+do_compile () {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+ base_do_compile
+}
+
+do_install () {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+ oe_runmake "PREFIX=${D}" install
+
+ # Just in case fdisk is compiled in, do not overwrite the Linksys one
+ rm -f ${S}/_install/sbin/fdisk
+
+ cp -pPR ${S}/_install/* ${D}/
+}