aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/busybox
diff options
context:
space:
mode:
authorMichael Smith <msmith@cbnco.com>2009-06-03 16:31:03 -0400
committerPhil Blundell <philb@gnu.org>2009-06-05 12:00:43 +0100
commit559b91e22f1548eca55642ffbcd113928ed0e655 (patch)
treea5b0b89e0c2376f72f289126bb21e971821968a2 /recipes/busybox
parent97529cf8b745a9f6c5587df193b823bd0b85481b (diff)
downloadopenembedded-559b91e22f1548eca55642ffbcd113928ed0e655.tar.gz
busybox: let update-alternatives create all symlinks, and use INC_PR
Back in 2005, commit 5e01906b set this up; in f7f1ac27 the recipe was changed to keep all the links in the package. This changes it back, and also removes special treatment of the links for crond, httpd, udhcpd, hwclock, and udhcpc. Signed-off-by: Michael Smith <msmith@cbnco.com>
Diffstat (limited to 'recipes/busybox')
-rw-r--r--recipes/busybox/busybox-static_1.11.3.bb2
-rw-r--r--recipes/busybox/busybox.inc44
-rw-r--r--recipes/busybox/busybox_1.11.3.bb2
-rw-r--r--recipes/busybox/busybox_1.13.2.bb2
-rw-r--r--recipes/busybox/busybox_1.2.1.bb2
-rw-r--r--recipes/busybox/busybox_1.2.2.bb2
-rw-r--r--recipes/busybox/busybox_1.3.1.bb2
-rw-r--r--recipes/busybox/busybox_1.7.2.bb2
-rw-r--r--recipes/busybox/busybox_1.9.2.bb2
9 files changed, 14 insertions, 46 deletions
diff --git a/recipes/busybox/busybox-static_1.11.3.bb b/recipes/busybox/busybox-static_1.11.3.bb
index 9529ab7b4b..6523fa90fe 100644
--- a/recipes/busybox/busybox-static_1.11.3.bb
+++ b/recipes/busybox/busybox-static_1.11.3.bb
@@ -1,5 +1,5 @@
require busybox_${PV}.bb
-PR = "r4"
+PR = "${INC_PR}.1"
FILESPATH = "${FILE_DIRNAME}/busybox-${PV}:${FILE_DIRNAME}/files:${FILE_DIRNAME}"
S = "${WORKDIR}/busybox-${PV}"
diff --git a/recipes/busybox/busybox.inc b/recipes/busybox/busybox.inc
index 04f2cf40e6..e3121476fa 100644
--- a/recipes/busybox/busybox.inc
+++ b/recipes/busybox/busybox.inc
@@ -11,6 +11,8 @@ LICENSE = "GPL"
SECTION = "base"
PRIORITY = "required"
+INC_PR = "r20"
+
SRC_URI = "\
http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
file://busybox-cron \
@@ -71,64 +73,30 @@ do_install () {
mv busybox.links.new busybox.links
fi
- unset CFLAGS CPPFLAGS CXXFLAGS
install -d ${D}${sysconfdir}/init.d
- oe_runmake "PREFIX=${D}" install
- cp -pPR ${S}/_install/* ${D}/
-
- # Move everything to /busybox (not supposed to end up in any package)
- install -d ${D}/busybox
- ls ${D} -R
- # Copy /bin and /sbin -- and /usr, if prefix is not "".
- for i in ${D}${base_bindir} ${D}${base_sbindir} ${prefix:+${D}${prefix}}
- do
- if [ -d $i ]; then
- cp -pPR $i ${D}/busybox/
- fi
- done
- # Move the busybox binary back to /bin
+ # Install /bin/busybox, and the /bin/sh link so the postinst script
+ # can run. Let update-alternatives handle the rest.
install -d ${D}${base_bindir}
- mv ${D}/busybox${base_bindir}/busybox ${D}${base_bindir}/
- # Move back the sh symlink
- test -h ${D}/busybox${base_bindir}/sh && mv ${D}/busybox${base_bindir}/sh ${D}${base_bindir}/
+ install -m 0755 ${S}/busybox ${D}${base_bindir}
+ ln -sf busybox ${D}${base_bindir}/sh
install -m 0755 ${WORKDIR}/syslog ${D}${sysconfdir}/init.d/
install -m 644 ${WORKDIR}/syslog.conf ${D}${sysconfdir}/
if grep "CONFIG_CROND=y" ${WORKDIR}/defconfig; then
- # Move crond back to /usr/sbin/crond
- install -d ${D}${sbindir}
- mv ${D}/busybox${sbindir}/crond ${D}${sbindir}/
-
install -m 0755 ${WORKDIR}/busybox-cron ${D}${sysconfdir}/init.d/
fi
if grep "CONFIG_HTTPD=y" ${WORKDIR}/defconfig; then
- # Move httpd back to /usr/sbin/httpd
- install -d ${D}${sbindir}
- mv ${D}/busybox${sbindir}/httpd ${D}${sbindir}/
-
install -m 0755 ${WORKDIR}/busybox-httpd ${D}${sysconfdir}/init.d/
install -d ${D}/srv/www
fi
if grep "CONFIG_APP_UDHCPD=y" ${WORKDIR}/defconfig; then
- # Move udhcpd back to /usr/sbin/udhcpd
- install -d ${D}${sbindir}
- mv ${D}/busybox${sbindir}/udhcpd ${D}${sbindir}/
-
install -m 0755 ${WORKDIR}/busybox-udhcpd ${D}${sysconfdir}/init.d/
fi
if grep "CONFIG_HWCLOCK=y" ${WORKDIR}/defconfig; then
- # Move hwclock back to /sbin/hwclock
- install -d ${D}${base_sbindir}
- mv ${D}/busybox${base_sbindir}/hwclock ${D}${base_sbindir}/
-
install -m 0755 ${WORKDIR}/hwclock.sh ${D}${sysconfdir}/init.d/
fi
if grep "CONFIG_APP_UDHCPC=y" ${WORKDIR}/defconfig; then
- # Move dhcpc back to /usr/sbin/udhcpc
- install -d ${D}${base_sbindir}
- mv ${D}/busybox${base_sbindir}/udhcpc ${D}${base_sbindir}/
-
install -d ${D}${sysconfdir}/udhcpc.d
install -d ${D}${datadir}/udhcpc
install -m 0755 ${S}/examples/udhcp/simple.script ${D}${sysconfdir}/udhcpc.d/50default
diff --git a/recipes/busybox/busybox_1.11.3.bb b/recipes/busybox/busybox_1.11.3.bb
index bd03aa8cf6..673fe15ba7 100644
--- a/recipes/busybox/busybox_1.11.3.bb
+++ b/recipes/busybox/busybox_1.11.3.bb
@@ -1,5 +1,5 @@
require busybox.inc
-PR = "r15"
+PR = "${INC_PR}.1"
SRC_URI = "\
http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
diff --git a/recipes/busybox/busybox_1.13.2.bb b/recipes/busybox/busybox_1.13.2.bb
index 96d0f0baca..c1cc51baf1 100644
--- a/recipes/busybox/busybox_1.13.2.bb
+++ b/recipes/busybox/busybox_1.13.2.bb
@@ -1,5 +1,5 @@
require busybox.inc
-PR = "r19"
+PR = "${INC_PR}.1"
SRC_URI = "\
http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
diff --git a/recipes/busybox/busybox_1.2.1.bb b/recipes/busybox/busybox_1.2.1.bb
index 63a93df36f..3630a4662b 100644
--- a/recipes/busybox/busybox_1.2.1.bb
+++ b/recipes/busybox/busybox_1.2.1.bb
@@ -1,6 +1,6 @@
require busybox.inc
-PR = "r19"
+PR = "${INC_PR}.1"
SRC_URI += "file://wget-long-options.patch;patch=1 \
file://df_rootfs.patch;patch=1 \
diff --git a/recipes/busybox/busybox_1.2.2.bb b/recipes/busybox/busybox_1.2.2.bb
index fe9d07e126..43a15d0f57 100644
--- a/recipes/busybox/busybox_1.2.2.bb
+++ b/recipes/busybox/busybox_1.2.2.bb
@@ -1,6 +1,6 @@
require busybox.inc
-PR = "r5"
+PR = "${INC_PR}.1"
DEFAULT_PREFERENCE = "-1"
diff --git a/recipes/busybox/busybox_1.3.1.bb b/recipes/busybox/busybox_1.3.1.bb
index 2cdb81b311..e0fd63bf5f 100644
--- a/recipes/busybox/busybox_1.3.1.bb
+++ b/recipes/busybox/busybox_1.3.1.bb
@@ -1,6 +1,6 @@
require busybox.inc
-PR = "r5"
+PR = "${INC_PR}.1"
DEFAULT_PREFERENCE = "-1"
diff --git a/recipes/busybox/busybox_1.7.2.bb b/recipes/busybox/busybox_1.7.2.bb
index 87d336b7ac..6af073f39c 100644
--- a/recipes/busybox/busybox_1.7.2.bb
+++ b/recipes/busybox/busybox_1.7.2.bb
@@ -1,5 +1,5 @@
require busybox.inc
-PR = "r13"
+PR = "${INC_PR}.1"
SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
file://busybox-cron \
diff --git a/recipes/busybox/busybox_1.9.2.bb b/recipes/busybox/busybox_1.9.2.bb
index e9aa820498..64f9c620e3 100644
--- a/recipes/busybox/busybox_1.9.2.bb
+++ b/recipes/busybox/busybox_1.9.2.bb
@@ -1,5 +1,5 @@
require busybox.inc
-PR = "r6"
+PR = "${INC_PR}.1"
SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
file://udhcpscript.patch;patch=1 \