aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/busybox
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2011-01-03 20:02:01 +0000
committerKhem Raj <raj.khem@gmail.com>2011-01-15 15:57:13 -0800
commitd08a7c06e918052baa7b7130183f0a7c8a180cb2 (patch)
tree9cbaf83f5ed03aea167411d9ce472dd1694c3e6d /recipes/busybox
parent40e1239c13069895046909290c4421b22aa1b891 (diff)
downloadopenembedded-d08a7c06e918052baa7b7130183f0a7c8a180cb2.tar.gz
busybox: simplify handling of busybox-static
Signed-off-by: Bernhard Reutner-Fischer <rep.dot.nop@gmail.com> Acked-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/busybox')
-rw-r--r--recipes/busybox/busybox-static_1.18.1.bb6
-rw-r--r--recipes/busybox/busybox.inc15
2 files changed, 13 insertions, 8 deletions
diff --git a/recipes/busybox/busybox-static_1.18.1.bb b/recipes/busybox/busybox-static_1.18.1.bb
index 27d4121c80..05cca17140 100644
--- a/recipes/busybox/busybox-static_1.18.1.bb
+++ b/recipes/busybox/busybox-static_1.18.1.bb
@@ -2,9 +2,3 @@ require busybox_${PV}.bb
FILESPATHPKG =. "${P}:${BPN}:busybox-${PV}:"
S = "${WORKDIR}/busybox-${PV}"
-
-do_configure_append() {
- sed -i -e '/CONFIG_STATIC/d' .config
- echo "CONFIG_STATIC=y" >>.config
-}
-
diff --git a/recipes/busybox/busybox.inc b/recipes/busybox/busybox.inc
index 13227c9ecf..29893dabb8 100644
--- a/recipes/busybox/busybox.inc
+++ b/recipes/busybox/busybox.inc
@@ -11,7 +11,7 @@ LICENSE = "GPLv2"
SECTION = "base"
PRIORITY = "required"
-INC_PR = "r38"
+INC_PR = "r39"
SRC_URI = "\
file://busybox-cron \
@@ -97,9 +97,11 @@ python () {
d)
}
-do_configure () {
+do_prepare_config () {
sed -e 's#@DATADIR@#${datadir}#g' \
< ${WORKDIR}/defconfig > ${S}/.config
+ sed -i -e '/CONFIG_STATIC/d' .config
+ echo "# CONFIG_STATIC is not set" >> .config
for i in 'CROSS' 'DISTRO FEATURES'; do echo "### $i"; done >> \
${S}/.config
sed -i -e '${configmangle}' ${S}/.config
@@ -112,6 +114,15 @@ do_configure () {
{if(net==2&&$0 !~ /^#/&&$1){print("# "$1" is not set")}else{print}}' \
${S}/.config.oe-tmp > ${S}/.config
fi
+}
+
+do_prepare_config_append_pn-busybox-static() {
+ sed -i -e '/CONFIG_STATIC/d' .config
+ echo "CONFIG_STATIC=y" >>.config
+}
+
+do_configure () {
+ do_prepare_config
cml1_do_configure
}