aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ca-certificates/ca-certificates_20090814+nmu2.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-10-02 00:08:55 -0700
committerKhem Raj <raj.khem@gmail.com>2010-10-02 00:10:14 -0700
commit872d9f9545938cd3b3e28094a23468cb08b61798 (patch)
treebc9a838fc09ace9fea349890125930777a6da911 /recipes/ca-certificates/ca-certificates_20090814+nmu2.bb
parent2384fbbcf7055cd99f9e44d08e66b706fad369aa (diff)
downloadopenembedded-872d9f9545938cd3b3e28094a23468cb08b61798.tar.gz
ca-certificates: Rename which updates SRC_URI to fetchable tar.
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/ca-certificates/ca-certificates_20090814+nmu2.bb')
-rw-r--r--recipes/ca-certificates/ca-certificates_20090814+nmu2.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes/ca-certificates/ca-certificates_20090814+nmu2.bb b/recipes/ca-certificates/ca-certificates_20090814+nmu2.bb
new file mode 100644
index 0000000000..c8e4dbd2c4
--- /dev/null
+++ b/recipes/ca-certificates/ca-certificates_20090814+nmu2.bb
@@ -0,0 +1,39 @@
+DESCRIPTION = "Common CA certificates"
+HOMEPAGE = "http://packages.debian.org/sid/ca-certificates"
+SECTION = "misc"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/c/ca-certificates/ca-certificates_${PV}.tar.gz \
+ file://remove-c-rehash.patch"
+SRC_URI[md5sum] = "76a2b0381b0aa7a6892e2340cd2c159a"
+SRC_URI[sha256sum] = "b1b144a3732df638e25b84ec6414ca9d1da4898cfd06d86b09f671585ce9c747"
+inherit autotools
+
+do_install_prepend() {
+ mkdir -p ${D}/usr/share/ca-certificates
+ mkdir -p ${D}/usr/sbin
+ mkdir -p ${D}/etc/ssl/certs
+ mkdir -p ${D}/etc/ca-certificates/update.d
+}
+
+do_install_append() {
+ cd ${D}/usr/share/ca-certificates
+ echo "# Lines starting with # will be ignored" > ${D}/etc/ca-certificates.conf
+ echo "# Lines starting with ! will remove certificate on next update" >> ${D}/etc/ca-certificates.conf
+ echo "#" >> ${D}/etc/ca-certificates.conf
+ for crt in $(find . -type f -name '*.crt' -print)
+ do
+ crt=$(echo $crt | sed -e 's/\.\///')
+ echo $crt >> ${D}/etc/ca-certificates.conf
+ done
+}
+
+PACKAGE_ARCH = "all"
+PACKAGES = "${PN}"
+
+pkg_postinst_${PN} () {
+ /usr/sbin/update-ca-certificates
+}
+
+CONFFILES_${PN} = "/etc/ca-certificates.conf"