summaryrefslogtreecommitdiffstats
path: root/recipes/cacao
diff options
context:
space:
mode:
authorHenning Heinold <h.heinold@tarent.de>2010-07-07 18:02:19 +0200
committerHenning Heinold <heinold@inf.fu-berlin.de>2010-07-08 15:52:08 +0200
commitecb3cf8e4c3d0a4f26c05b491d3a8025863a60b5 (patch)
tree77fddb481c205058357931c8613f01accd854434 /recipes/cacao
parent22afd95e74d273b228c7aa685a81d14f16ae1e3c (diff)
downloadopenembedded-ecb3cf8e4c3d0a4f26c05b491d3a8025863a60b5.tar.gz
openjdk: move over the recipes from jalimo
Diffstat (limited to 'recipes/cacao')
-rw-r--r--recipes/cacao/cacaoh-openjdk-native.inc31
-rw-r--r--recipes/cacao/cacaoh-openjdk-native_0.99.4.bb8
2 files changed, 39 insertions, 0 deletions
diff --git a/recipes/cacao/cacaoh-openjdk-native.inc b/recipes/cacao/cacaoh-openjdk-native.inc
new file mode 100644
index 0000000000..5070e7e7bc
--- /dev/null
+++ b/recipes/cacao/cacaoh-openjdk-native.inc
@@ -0,0 +1,31 @@
+DESCRIPTION = "Header generator for Cacao JVM - Needed for cross-compilation builds"
+HOMEPAGE = "http://www.cacaojvm.org/"
+LICENSE = "GPL"
+
+DEPENDS = "libtool-native zlib-native virtual/javac-native classpath-native icedtea6-native"
+
+inherit java autotools
+
+S = "${WORKDIR}/cacao-${PV}"
+
+inherit autotools native
+
+EXTRA_OECONF = " \
+ --with-java-runtime-library=openjdk \
+ --with-java-runtime-library-classes=${STAGING_LIBDIR_JVM_NATIVE}/icedtea6-native/jre/lib/rt.jar \
+ --with-jni_md_h=${STAGING_INCDIR}/classpath \
+ --with-jni_h=${STAGING_INCDIR}/classpath \
+ --with-hpi_md_h=${STAGING_LIBDIR_JVM_NATIVE}/icedtea6-native/include/hpi \
+ --with-hpi_h=${STAGING_LIBDIR_JVM_NATIVE}/icedtea6-native/include/hpi \
+ "
+
+do_compile() {
+ # Compile the header generator only (and what is needed for it).
+ oe_runmake -C src/toolbox libtoolbox.la
+ oe_runmake -C src/vmcore libvmcore.la
+ oe_runmake -C src/cacaoh cacaoh
+}
+
+do_install() {
+ install -m 0755 src/cacaoh/.libs/cacaoh ${STAGING_BINDIR}/cacaoh-openjdk-${PV}
+}
diff --git a/recipes/cacao/cacaoh-openjdk-native_0.99.4.bb b/recipes/cacao/cacaoh-openjdk-native_0.99.4.bb
new file mode 100644
index 0000000000..27ab6ab006
--- /dev/null
+++ b/recipes/cacao/cacaoh-openjdk-native_0.99.4.bb
@@ -0,0 +1,8 @@
+require cacaoh-openjdk-native.inc
+
+PR = "r0"
+
+SRC_URI[md5sum] = "63220327925ace13756ae334c55a3baa"
+SRC_URI[sha256sum] = "1dfc4903dc0172286df4f1740fd0f12749ac81d51c602290b47cbe83d51e1d56"
+
+SRC_URI = "http://www.complang.tuwien.ac.at/cacaojvm/download/cacao-${PV}/cacao-${PV}.tar.bz2"