aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/cairo/cairo-1.2.4
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/cairo/cairo-1.2.4
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/cairo/cairo-1.2.4')
-rw-r--r--recipes/cairo/cairo-1.2.4/0001-Add-autoconf-macro-AX_C_FLOAT_WORDS_BIGENDIAN.diff103
-rw-r--r--recipes/cairo/cairo-1.2.4/0002-Change-_cairo_fixed_from_double-to-use-the-magic-number-technique.diff79
-rw-r--r--recipes/cairo/cairo-1.2.4/0003-Add-new-perf-test-pattern_create_radial.diff164
3 files changed, 346 insertions, 0 deletions
diff --git a/recipes/cairo/cairo-1.2.4/0001-Add-autoconf-macro-AX_C_FLOAT_WORDS_BIGENDIAN.diff b/recipes/cairo/cairo-1.2.4/0001-Add-autoconf-macro-AX_C_FLOAT_WORDS_BIGENDIAN.diff
new file mode 100644
index 0000000000..90718d4976
--- /dev/null
+++ b/recipes/cairo/cairo-1.2.4/0001-Add-autoconf-macro-AX_C_FLOAT_WORDS_BIGENDIAN.diff
@@ -0,0 +1,103 @@
+From nobody Mon Sep 17 00:00:00 2001
+From: Dan Amelang <dan@amelang.net>
+Date: Sun Oct 29 21:30:08 2006 -0800
+Subject: [PATCH] Add autoconf macro AX_C_FLOAT_WORDS_BIGENDIAN
+
+The symbol that this macro defines (FLOAT_WORDS_BIGENDIAN) can be used
+to make double arithmetic tricks portable.
+
+---
+
+ acinclude.m4 | 65 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
+ configure.in | 1 +
+ 2 files changed, 66 insertions(+), 0 deletions(-)
+
+3231d91b59a6c2e1c40bbaa8b143694b6c693662
+diff --git a/acinclude.m4 b/acinclude.m4
+index af73800..a0eb13a 100644
+--- a/acinclude.m4
++++ b/acinclude.m4
+@@ -51,3 +51,68 @@ ifelse([$1],[],,
+ AM_CONDITIONAL(ENABLE_GTK_DOC, test x$enable_gtk_doc = xyes)
+ AM_CONDITIONAL(GTK_DOC_USE_LIBTOOL, test -n "$LIBTOOL")
+ ])
++
++# AX_C_FLOAT_WORDS_BIGENDIAN ([ACTION-IF-TRUE], [ACTION-IF-FALSE],
++# [ACTION-IF-UNKNOWN])
++#
++# Checks the ordering of words within a multi-word float. This check
++# is necessary because on some systems (e.g. certain ARM systems), the
++# float word ordering can be different from the byte ordering. In a
++# multi-word float context, "big-endian" implies that the word containing
++# the sign bit is found in the memory location with the lowest address.
++# This implemenation was inspired by the AC_C_BIGENDIAN macro in autoconf.
++# -------------------------------------------------------------------------
++AC_DEFUN([AX_C_FLOAT_WORDS_BIGENDIAN],
++ [AC_CACHE_CHECK(whether float word ordering is bigendian,
++ ax_cv_c_float_words_bigendian, [
++
++# The endianess is detected by first compiling C code that contains a special
++# double float value, then grepping the resulting object file for certain
++# strings of ascii values. The double is specially crafted to have a
++# binary representation that corresponds with a simple string. In this
++# implementation, the string "noonsees" was selected because the individual
++# word values ("noon" and "sees") are palindromes, thus making this test
++# byte-order agnostic. If grep finds the string "noonsees" in the object
++# file, the target platform stores float words in big-endian order. If grep
++# finds "seesnoon", float words are in little-endian order. If neither value
++# is found, the user is instructed to specify the ordering.
++
++ax_cv_c_float_words_bigendian=unknown
++AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
++
++double d = 90904234967036810337470478905505011476211692735615632014797120844053488865816695273723469097858056257517020191247487429516932130503560650002327564517570778480236724525140520121371739201496540132640109977779420565776568942592.0;
++
++]])], [
++
++if grep noonsees conftest.$ac_objext >/dev/null ; then
++ ax_cv_c_float_words_bigendian=yes
++fi
++if grep seesnoon conftest.$ac_objext >/dev/null ; then
++ if test "$ax_cv_c_float_words_bigendian" = unknown; then
++ ax_cv_c_float_words_bigendian=no
++ else
++ ax_cv_c_float_words_bigendian=unknown
++ fi
++fi
++
++])])
++
++case $ax_cv_c_float_words_bigendian in
++ yes)
++ m4_default([$1],
++ [AC_DEFINE([FLOAT_WORDS_BIGENDIAN], 1,
++ [Define to 1 if your system stores words within floats
++ with the most significant word first])]) ;;
++ no)
++ $2 ;;
++ *)
++ m4_default([$3],
++ [AC_MSG_ERROR([
++
++Unknown float word ordering. You need to manually preset
++ax_cv_c_float_words_bigendian=no (or yes) according to your system.
++
++ ])]) ;;
++esac
++
++])# AX_C_FLOAT_WORDS_BIGENDIAN
+diff --git a/configure.in b/configure.in
+index 2d2bf9f..797c7ce 100644
+--- a/configure.in
++++ b/configure.in
+@@ -55,6 +55,7 @@ AC_PROG_CPP
+ AC_PROG_LIBTOOL dnl required version (1.4) DON'T REMOVE!
+ AC_STDC_HEADERS
+ AC_C_BIGENDIAN
++AX_C_FLOAT_WORDS_BIGENDIAN
+
+ dnl ===========================================================================
+ dnl === Local macros
+--
+1.2.6
+
diff --git a/recipes/cairo/cairo-1.2.4/0002-Change-_cairo_fixed_from_double-to-use-the-magic-number-technique.diff b/recipes/cairo/cairo-1.2.4/0002-Change-_cairo_fixed_from_double-to-use-the-magic-number-technique.diff
new file mode 100644
index 0000000000..56d8b7e99a
--- /dev/null
+++ b/recipes/cairo/cairo-1.2.4/0002-Change-_cairo_fixed_from_double-to-use-the-magic-number-technique.diff
@@ -0,0 +1,79 @@
+From nobody Mon Sep 17 00:00:00 2001
+From: Dan Amelang <dan@amelang.net>
+Date: Sun Oct 29 21:31:23 2006 -0800
+Subject: [PATCH] Change _cairo_fixed_from_double to use the "magic number" technique
+
+See long thread here:
+http://lists.freedesktop.org/archives/cairo/2006-October/008285.html
+
+---
+
+ src/cairo-fixed.c | 48 +++++++++++++++++++++++++++++++++++++++++++++++-
+ 1 files changed, 47 insertions(+), 1 deletions(-)
+
+d88acddcabe770e17664b34a2d5f74d3926e1642
+diff --git a/src/cairo-fixed.c b/src/cairo-fixed.c
+index 604c9e7..fe6c2dc 100644
+--- a/src/cairo-fixed.c
++++ b/src/cairo-fixed.c
+@@ -42,10 +42,56 @@ _cairo_fixed_from_int (int i)
+ return i << 16;
+ }
+
++/* This is the "magic number" approach to converting a double into fixed
++ * point as described here:
++ *
++ * http://www.stereopsis.com/sree/fpu2006.html (an overview)
++ * http://www.d6.com/users/checker/pdfs/gdmfp.pdf (in detail)
++ *
++ * The basic idea is to add a large enough number to the double that the
++ * literal floating point is moved up to the extent that it forces the
++ * double's value to be shifted down to the bottom of the mantissa (to make
++ * room for the large number being added in). Since the mantissa is, at a
++ * given moment in time, a fixed point integer itself, one can convert a
++ * float to various fixed point representations by moving around the point
++ * of a floating point number through arithmetic operations. This behavior
++ * is reliable on most modern platforms as it is mandated by the IEEE-754
++ * standard for floating point arithmetic.
++ *
++ * For our purposes, a "magic number" must be carefully selected that is
++ * both large enough to produce the desired point-shifting effect, and also
++ * has no lower bits in its representation that would interfere with our
++ * value at the bottom of the mantissa. The magic number is calculated as
++ * follows:
++ *
++ * (2 ^ (MANTISSA_SIZE - FRACTIONAL_SIZE)) * 1.5
++ *
++ * where in our case:
++ * - MANTISSA_SIZE for 64-bit doubles is 52
++ * - FRACTIONAL_SIZE for 16.16 fixed point is 16
++ *
++ * Although this approach provides a very large speedup of this function
++ * on a wide-array of systems, it does come with two caveats:
++ *
++ * 1) It uses banker's rounding as opposed to arithmetic rounding.
++ * 2) It doesn't function properly if the FPU is in single-precision
++ * mode.
++ */
++#define CAIRO_MAGIC_NUMBER_FIXED_16_16 (103079215104.0)
+ cairo_fixed_t
+ _cairo_fixed_from_double (double d)
+ {
+- return (cairo_fixed_t) floor (d * 65536 + 0.5);
++ union {
++ double d;
++ int32_t i[2];
++ } u;
++
++ u.d = d + CAIRO_MAGIC_NUMBER_FIXED_16_16;
++#ifdef FLOAT_WORDS_BIGENDIAN
++ return u.i[1];
++#else
++ return u.i[0];
++#endif
+ }
+
+ cairo_fixed_t
+--
+1.2.6
+
diff --git a/recipes/cairo/cairo-1.2.4/0003-Add-new-perf-test-pattern_create_radial.diff b/recipes/cairo/cairo-1.2.4/0003-Add-new-perf-test-pattern_create_radial.diff
new file mode 100644
index 0000000000..c2b47deb7f
--- /dev/null
+++ b/recipes/cairo/cairo-1.2.4/0003-Add-new-perf-test-pattern_create_radial.diff
@@ -0,0 +1,164 @@
+From nobody Mon Sep 17 00:00:00 2001
+From: Dan Amelang <dan@amelang.net>
+Date: Tue Oct 31 23:47:35 2006 -0800
+Subject: [PATCH] Add new perf test "pattern_create_radial"
+
+This test is really just for hammering the double to fixed-point conversion
+(in _cairo_fixed_from_double) that happens as doubles from API calls gets
+translated into internal cairo fixed-point numbers.
+
+Because it's not generally useful, I don't recommend that it become part of
+the main cairo performance test. But hey, it might come in handy for someone
+else.
+
+---
+
+ perf/Makefile.am | 1
+ perf/cairo-perf.c | 1
+ perf/cairo-perf.h | 1
+ perf/pattern_create_radial.c | 98 ++++++++++++++++++++++++++++++++++++++++++
+ 4 files changed, 101 insertions(+), 0 deletions(-)
+ create mode 100644 perf/pattern_create_radial.c
+
+977383b86c68d0523c899efcba3cf8d36e94d2a7
+diff --git a/perf/Makefile.am b/perf/Makefile.am
+index 419a998..e1cfdc7 100644
+--- a/perf/Makefile.am
++++ b/perf/Makefile.am
+@@ -21,6 +21,7 @@ cairo_perf_SOURCES = \
+ stroke.c \
+ subimage_copy.c \
+ tessellate.c \
++ pattern_create_radial.c \
+ text.c
+
+ if CAIRO_HAS_WIN32_SURFACE
+diff --git a/perf/cairo-perf.c b/perf/cairo-perf.c
+index d9734c4..0707433 100644
+--- a/perf/cairo-perf.c
++++ b/perf/cairo-perf.c
+@@ -256,5 +256,6 @@ cairo_perf_case_t perf_cases[] = {
+ { text, 64, 256},
+ { tessellate, 100, 100},
+ { subimage_copy, 16, 512},
++ { pattern_create_radial, 16, 16},
+ { NULL }
+ };
+diff --git a/perf/cairo-perf.h b/perf/cairo-perf.h
+index 560ba64..faacff9 100644
+--- a/perf/cairo-perf.h
++++ b/perf/cairo-perf.h
+@@ -88,5 +88,6 @@ CAIRO_PERF_DECL (stroke);
+ CAIRO_PERF_DECL (subimage_copy);
+ CAIRO_PERF_DECL (tessellate);
+ CAIRO_PERF_DECL (text);
++CAIRO_PERF_DECL (pattern_create_radial);
+
+ #endif
+diff --git a/perf/pattern_create_radial.c b/perf/pattern_create_radial.c
+new file mode 100644
+index 0000000..d793b7d
+--- /dev/null
++++ b/perf/pattern_create_radial.c
+@@ -0,0 +1,98 @@
++/*
++ * Copyright © 2006 Dan Amelang
++ *
++ * Permission to use, copy, modify, distribute, and sell this software
++ * and its documentation for any purpose is hereby granted without
++ * fee, provided that the above copyright notice appear in all copies
++ * and that both that copyright notice and this permission notice
++ * appear in supporting documentation, and that the name of
++ * the authors not be used in advertising or publicity pertaining to
++ * distribution of the software without specific, written prior
++ * permission. The authors make no representations about the
++ * suitability of this software for any purpose. It is provided "as
++ * is" without express or implied warranty.
++ *
++ * THE AUTHORS DISCLAIM ALL WARRANTIES WITH REGARD TO THIS
++ * SOFTWARE, INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND
++ * FITNESS, IN NO EVENT SHALL THE AUTHORS BE LIABLE FOR ANY SPECIAL,
++ * INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER
++ * RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION
++ * OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR
++ * IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
++ *
++ * Authors: Dan Amelang <dan@amelang.net>
++ *
++ * This test was originally created to test _cairo_fixed_from_double.
++ * cairo_pattern_create_radial was selected as the entry point into
++ * cairo as it makes several calls to _cairo_fixed_from_double and
++ * presents a somewhat realistic use-case (although the RADIALS_COUNT
++ * isn't very realistic).
++ */
++#include <time.h>
++#include "cairo-perf.h"
++
++#define RADIALS_COUNT (100000)
++
++static struct
++{
++ double cx0;
++ double cy0;
++ double radius0;
++ double cx1;
++ double cy1;
++ double radius1;
++} radials[RADIALS_COUNT];
++
++static double
++generate_double_in_range (double min, double max)
++{
++ double d;
++
++ d = rand () / (double) RAND_MAX;
++ d *= max - min;
++ d += min;
++
++ return d;
++}
++
++static cairo_perf_ticks_t
++do_pattern_create_radial (cairo_t *cr, int width, int height)
++{
++ int i;
++ cairo_pattern_t *pattern;
++
++ cairo_perf_timer_start ();
++
++ for (i = 0; i < RADIALS_COUNT; i++)
++ {
++ pattern = cairo_pattern_create_radial (radials[i].cx0, radials[i].cy0,
++ radials[i].radius0,
++ radials[i].cx1, radials[i].cy1,
++ radials[i].radius1);
++ cairo_pattern_destroy (pattern);
++ }
++
++ cairo_perf_timer_stop ();
++
++ return cairo_perf_timer_elapsed ();
++}
++
++void
++pattern_create_radial (cairo_perf_t *perf, cairo_t *cr, int width, int height)
++{
++ int i;
++
++ srand (time (0));
++ for (i = 0; i < RADIALS_COUNT; i++)
++ {
++ radials[i].cx0 = generate_double_in_range (-50000.0, 50000.0);
++ radials[i].cy0 = generate_double_in_range (-50000.0, 50000.0);
++ radials[i].radius0 = generate_double_in_range (0.0, 1000.0);
++ radials[i].cx1 = generate_double_in_range (-50000.0, 50000.0);
++ radials[i].cy1 = generate_double_in_range (-50000.0, 50000.0);
++ radials[i].radius1 = generate_double_in_range (0.0, 1000.0);
++ }
++
++ cairo_perf_run (perf, "pattern_create_radial",
++ do_pattern_create_radial);
++}
+--
+1.2.6
+