aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ccdv
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/ccdv
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/ccdv')
-rw-r--r--recipes/ccdv/ccdv-native.bb10
-rw-r--r--recipes/ccdv/ccdv.bb14
2 files changed, 24 insertions, 0 deletions
diff --git a/recipes/ccdv/ccdv-native.bb b/recipes/ccdv/ccdv-native.bb
new file mode 100644
index 0000000000..1eaebd0129
--- /dev/null
+++ b/recipes/ccdv/ccdv-native.bb
@@ -0,0 +1,10 @@
+require ccdv.bb
+inherit native
+
+do_stage () {
+ install -m 0755 ccdv ${STAGING_BINDIR}/
+}
+
+do_install () {
+ :
+}
diff --git a/recipes/ccdv/ccdv.bb b/recipes/ccdv/ccdv.bb
new file mode 100644
index 0000000000..0a3753add5
--- /dev/null
+++ b/recipes/ccdv/ccdv.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "ccdv is a tool to reduce the deluge of make output to make \
+finding actual problems easier."
+LICENSE = "GPL"
+SRC_URI = "http://openembedded.org/dl/ccdv.c"
+S = "${WORKDIR}"
+
+do_compile () {
+ ${CC} ${CFLAGS} ${LDFLAGS} ccdv.c -o ccdv
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 ccdv ${D}${bindir}/
+}