summaryrefslogtreecommitdiffstats
path: root/recipes/ccrtp
diff options
context:
space:
mode:
authorThomas Zimmermann <ml@vdm-design.de>2010-04-19 18:45:03 +0200
committerThomas Zimmermann <ml@vdm-design.de>2010-04-19 18:45:03 +0200
commit23f2827bbf852cf9d66afd4e71d990e7d2712e3a (patch)
tree90e418e223946657f5955a1d63cbc3802100f3d6 /recipes/ccrtp
parentbdb5416371fd16ee698f744c33a18ef1a0f83d73 (diff)
downloadopenembedded-23f2827bbf852cf9d66afd4e71d990e7d2712e3a.tar.gz
ccrtp: fix linking against libs in /usr/lib
* it tries to link against libs in /usr/lib if they exist there * run recipe through oe-stylize.py Signed-off-by: Thomas Zimmermann <ml@vdm-design.de>
Diffstat (limited to 'recipes/ccrtp')
-rw-r--r--recipes/ccrtp/ccrtp_1.7.0.bb16
1 files changed, 10 insertions, 6 deletions
diff --git a/recipes/ccrtp/ccrtp_1.7.0.bb b/recipes/ccrtp/ccrtp_1.7.0.bb
index 1ebfddb7c2..608ce3c3b5 100644
--- a/recipes/ccrtp/ccrtp_1.7.0.bb
+++ b/recipes/ccrtp/ccrtp_1.7.0.bb
@@ -1,12 +1,16 @@
DESCRIPTION = "GNU Common C++"
HOMEPAGE = "http://freshmeat.net/projects/ccrtp"
LICENSE = "GPL"
-PR="r0"
DEPENDS = "commoncpp2"
-SRC_URI = "ftp://ftp.gnu.org/gnu/ccrtp/ccrtp-${PV}.tar.gz \
- file://configure.ac.patch;patch=1"
+PR = "r0"
-inherit autotools pkgconfig autotools_stage
+SRC_URI = "ftp://ftp.gnu.org/gnu/ccrtp/ccrtp-${PV}.tar.gz;name=archive \
+ file://configure.ac.patch;patch=1"
+SRC_URI[archive.md5sum] = "eb86cd2ac06af27ea60b1a349122605c"
+SRC_URI[archive.sha256sum] = "923cd26ffc43903ef33704e46fd57f659c3ad01554927fe323635a73082d56ae"
-SRC_URI[md5sum] = "eb86cd2ac06af27ea60b1a349122605c"
-SRC_URI[sha256sum] = "923cd26ffc43903ef33704e46fd57f659c3ad01554927fe323635a73082d56ae"
+inherit pkgconfig autotools_stage
+
+do_configure_prepend () {
+ sed -i -e 's#COMMON_LIBPATH=`pkg-config --variable=libdir libccgnu2`#COMMON_LIBPATH=${STAGING_LIBDIR}#' configure.ac
+}