aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ccxstream/ccxstream-1.0.15
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/ccxstream/ccxstream-1.0.15
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/ccxstream/ccxstream-1.0.15')
-rw-r--r--recipes/ccxstream/ccxstream-1.0.15/ccxstream-termcap.patch11
-rw-r--r--recipes/ccxstream/ccxstream-1.0.15/ccxstream.conf54
-rw-r--r--recipes/ccxstream/ccxstream-1.0.15/ccxstream.init37
3 files changed, 102 insertions, 0 deletions
diff --git a/recipes/ccxstream/ccxstream-1.0.15/ccxstream-termcap.patch b/recipes/ccxstream/ccxstream-1.0.15/ccxstream-termcap.patch
new file mode 100644
index 0000000000..c392a6a0b8
--- /dev/null
+++ b/recipes/ccxstream/ccxstream-1.0.15/ccxstream-termcap.patch
@@ -0,0 +1,11 @@
+--- ccxstream-1.0.15/Makefile.orig 2003-12-27 04:57:23.733355080 +0000
++++ ccxstream-1.0.15/Makefile 2003-12-27 04:57:34.506717280 +0000
+@@ -22,7 +22,7 @@
+ #
+
+ CFLAGS+=-I. -g
+-LDFLAGS+=-lreadline -ltermcap
++LDFLAGS+=-lreadline -lncurses
+
+ all: ccxstream ccxtest
+
diff --git a/recipes/ccxstream/ccxstream-1.0.15/ccxstream.conf b/recipes/ccxstream/ccxstream-1.0.15/ccxstream.conf
new file mode 100644
index 0000000000..29928e69d2
--- /dev/null
+++ b/recipes/ccxstream/ccxstream-1.0.15/ccxstream.conf
@@ -0,0 +1,54 @@
+#!/bin/sh
+
+#Uncomment the line below to begin (mandatory)
+#CHECK=YES
+
+#Below the user to run the service as (mandatory)
+RUNASUSER="root"
+
+#Below the password on the XBOX (optional)
+#REMOTEPASS="xboxpassword"
+
+#Below the interface to listen on (mandatory)
+LISTENINTERFACE="192.168.1.1"
+
+FOLLOWSYMLINKS=YES
+
+#Comment (optional)
+#SERVERCOMMENT="Video and MP3 server powered by Gentoo. Watch and listen and ENJOY."
+
+#Shares to make available (mandatory)
+SHARES="movies=/data/videos audio=/data/mp3"
+
+#Location of binary file. Leave default unless you know what you're doing (mandatory)
+BIN="/usr/sbin/ccxstream"
+
+#-----------------------------------------------------------------------------#
+#-----------------------------------------------------------------------------#
+
+DIR="-"
+
+PIDFILE=/var/run/ccxstream.pid
+
+PARAMS="-f -F $PIDFILE -r $DIR -u $RUNASUSER"
+
+if test "$FOLLOWSYMLINKS" = "YES" ; then
+ PARAMS="$PARAMS -L"
+fi
+
+if test "x$REMOTEPASS" != "x" ; then
+ PARAMS="$PARAMS -P $REMOTEPASS"
+fi
+
+if test "x$LISTENINTERFACE" != "x" ; then
+ PARAMS="$PARAMS -l $LISTENINTERFACE"
+fi
+
+for i in $SHARES ; do
+ PARAMS="$PARAMS -S $i"
+done
+
+if test "x$SERVERCOMMENT" = "x" ; then
+ SERVERCOMMENT="$(hostname -f)"
+fi
+
diff --git a/recipes/ccxstream/ccxstream-1.0.15/ccxstream.init b/recipes/ccxstream/ccxstream-1.0.15/ccxstream.init
new file mode 100644
index 0000000000..f57752825d
--- /dev/null
+++ b/recipes/ccxstream/ccxstream-1.0.15/ccxstream.init
@@ -0,0 +1,37 @@
+#! /bin/sh
+
+start() {
+ . /etc/ccxstream.conf
+ if [ "${CHECK}" = "YES" ] ; then
+
+ echo -n "Starting ccXstream : "
+ start-stop-daemon --start --quiet --exec ${BIN} \
+ -- ${PARAMS} -C ${SERVERCOMMENT}
+ status="$?"
+ test ${status} = "0" && echo OK || echo FAILED
+ return ${status}
+ else
+ echo "Please setup /etc/ccxstream.conf before starting ccXstream"
+ return 1
+ fi
+}
+
+stop() {
+ echo -n "Stopping ccXstream : "
+ start-stop-daemon --stop --quiet --pidfile /var/run/ccxstream.pid
+ return $?
+}
+
+case $1 in
+ start)
+ start
+ ;;
+ stop)
+ stop
+ ;;
+ restart)
+ stop
+ start
+ ;;
+esac
+