aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ccxstream/ccxstream_1.0.15.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/ccxstream/ccxstream_1.0.15.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/ccxstream/ccxstream_1.0.15.bb')
-rw-r--r--recipes/ccxstream/ccxstream_1.0.15.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/ccxstream/ccxstream_1.0.15.bb b/recipes/ccxstream/ccxstream_1.0.15.bb
new file mode 100644
index 0000000000..466a116ec2
--- /dev/null
+++ b/recipes/ccxstream/ccxstream_1.0.15.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "XStream Server"
+DEPENDS = "readline"
+LICENSE = "GPLv2"
+PR = "r2"
+
+SRC_URI = "http://surfnet.dl.sourceforge.net/sourceforge/xbplayer/${P}.tar.gz \
+ file://ccxstream-termcap.patch;patch=1 \
+ file://ccxstream.init \
+ file://ccxstream.conf"
+
+inherit autotools
+
+do_install() {
+ # add startup and sample config
+ install -d ${D}${sysconfdir}/init.d
+ install -d ${D}${sbindir}
+ install -m 0755 ${WORKDIR}/ccxstream.init ${D}${sysconfdir}/init.d/ccxstream
+ install -m 0644 ${WORKDIR}/ccxstream.conf ${D}${sysconfdir}/ccxstream.conf
+ install -m 0755 ccxstream ${D}${sbindir}/ccxstream || exit 1
+}