aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/cdparanoia/cdparanoia_10.2.bb
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2010-09-29 10:36:30 +0000
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-09-30 22:58:55 +0200
commit617ac27e70d6fb6572469f8beef28f8ac4a7f334 (patch)
tree1844b9235fa8464e140c46939a10808015b602f4 /recipes/cdparanoia/cdparanoia_10.2.bb
parent9567a8885b7d5248f6d72e2470238b5752620a4b (diff)
downloadopenembedded-617ac27e70d6fb6572469f8beef28f8ac4a7f334.tar.gz
cdparanoia: create libcdparanoia packages
* Create separate packages for the libraries, which use a different license than the executable: "The cdparanoia command line tool versions 10.1 and later are distributed under the GNU General Public Licence v2.0 or, at your option, any later version of the GPL." "The 10.1 and later release versions of the cdda-interface and cdda-paranoia libraries are distributed the GNU Lesser General Public License v2.1 or, at your option, any later version of the GNU LGPL." Signed-off-by: Andreas Oberritter <obi@opendreambox.org> Signed-off-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/cdparanoia/cdparanoia_10.2.bb')
-rw-r--r--recipes/cdparanoia/cdparanoia_10.2.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/recipes/cdparanoia/cdparanoia_10.2.bb b/recipes/cdparanoia/cdparanoia_10.2.bb
index 7bb60356ae..894c038f65 100644
--- a/recipes/cdparanoia/cdparanoia_10.2.bb
+++ b/recipes/cdparanoia/cdparanoia_10.2.bb
@@ -2,6 +2,7 @@
# Copyright (C) 2005, Advanced Micro Devices, Inc. All Rights Reserved
# Released under the MIT license (see packages/COPYING)
LICENSE = "GPL"
+PR = "r1"
SRC_URI = "http://downloads.xiph.org/releases/cdparanoia/cdparanoia-III-10.2.src.tgz \
file://fixes10.patch \
@@ -17,6 +18,19 @@ S = "${WORKDIR}/cdparanoia-III-10.2"
inherit autotools
+PACKAGES += "libcdparanoia libcdparanoia-dev libcdparanoia-static"
+
+LICENSE_libcdparanoia = "LGPLv2.1"
+LICENSE_libcdparanoia-dev = "LGPLv2.1"
+LICENSE_libcdparanoia-static = "LGPLv2.1"
+
+FILES_${PN} = "${bindir}/*"
+FILES_${PN}-dev = ""
+FILES_${PN}-static = ""
+FILES_libcdparanoia = "${libdir}/lib*${SOLIBS}"
+FILES_libcdparanoia-dev = "${includedir} ${libdir}/lib*${SOLIBSDEV}"
+FILES_libcdparanoia-static = "${libdir}/*.a"
+
do_install() {
oe_runmake BINDIR="${D}/usr/bin" MANDIR="${D}/usr/share/man/" \
INCLUDEDIR="${D}/usr/include/" LIBDIR="${D}/usr/lib" install