aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/cdparanoia/files/fixes.patch
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/cdparanoia/files/fixes.patch
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/cdparanoia/files/fixes.patch')
-rw-r--r--recipes/cdparanoia/files/fixes.patch63
1 files changed, 63 insertions, 0 deletions
diff --git a/recipes/cdparanoia/files/fixes.patch b/recipes/cdparanoia/files/fixes.patch
new file mode 100644
index 0000000000..6ffc8a6af9
--- /dev/null
+++ b/recipes/cdparanoia/files/fixes.patch
@@ -0,0 +1,63 @@
+--- cdparanoia-III-alpha9.8/configure.in 2000-03-26 00:33:22.000000000 -0700
++++ cdparanoia-III-alpha9.8.new/configure.in 2004-12-23 16:34:04.072846728 -0700
+@@ -1,7 +1,7 @@
+ AC_INIT(interface/interface.c)
+
+-cp $srcdir/configure.guess $srcdir/config.guess
+-cp $srcdir/configure.sub $srcdir/config.sub
++#cp $srcdir/configure.guess $srcdir/config.guess
++#cp $srcdir/configure.sub $srcdir/config.sub
+
+ AC_CANONICAL_HOST
+
+--- cdparanoia-III-alpha9.8/interface/utils.h 2000-04-19 15:41:04.000000000 -0700
++++ cdparanoia-III-alpha9.8.new/interface/utils.h 2004-12-23 16:37:11.126410264 -0700
+@@ -111,7 +111,7 @@
+ d->errorbuf=catstring(d->errorbuf,s);
+ break;
+ case CDDA_MESSAGE_FORGETIT:
+- default:
++ default: ;
+ }
+ }
+ }
+@@ -126,7 +126,7 @@
+ d->messagebuf=catstring(d->messagebuf,s);
+ break;
+ case CDDA_MESSAGE_FORGETIT:
+- default:
++ default: ;
+ }
+ }
+ }
+@@ -168,7 +168,7 @@
+ }
+ break;
+ case CDDA_MESSAGE_FORGETIT:
+- default:
++ default: ;
+ }
+ }
+ if(malloced)free(buffer);
+@@ -204,7 +204,7 @@
+ }
+ break;
+ case CDDA_MESSAGE_FORGETIT:
+- default:
++ default: ;
+ }
+ }
+ if(malloced)free(buffer);
+--- cdparanoia-III-alpha9.8/interface/scan_devices.c 2001-03-25 22:44:01.000000000 -0700
++++ cdparanoia-III-alpha9.8.new/interface/scan_devices.c 2004-12-23 16:38:47.128815680 -0700
+@@ -19,6 +19,10 @@
+ #include "common_interface.h"
+ #include "utils.h"
+
++#ifndef PATH_MAX
++#define PATH_MAX 4096
++#endif
++
+ #define MAX_DEV_LEN 20 /* Safe because strings only come from below */
+ /* must be absolute paths! */
+ static char *scsi_cdrom_prefixes[]={