aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/cdtool
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/cdtool
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/cdtool')
-rw-r--r--recipes/cdtool/cdtool_2.1.8.bb13
-rw-r--r--recipes/cdtool/files/install-no-owner.patch33
2 files changed, 46 insertions, 0 deletions
diff --git a/recipes/cdtool/cdtool_2.1.8.bb b/recipes/cdtool/cdtool_2.1.8.bb
new file mode 100644
index 0000000000..ec51290edf
--- /dev/null
+++ b/recipes/cdtool/cdtool_2.1.8.bb
@@ -0,0 +1,13 @@
+# cdtool .bb build file
+# Copyright (C) 2006, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see /COPYING)
+
+HOMEPAGE="http://hinterhof.net/cdtool/"
+DESCRIPTION="cdtool is a free software package to control the audio functions \
+of an attached CDROM drive from the command line in a quick and scriptable way."
+LICENSE = "GPL"
+
+SRC_URI="http://hinterhof.net/${PN}/dist/${PN}-${PV}.tar.gz \
+ file://install-no-owner.patch;patch=1"
+
+inherit autotools
diff --git a/recipes/cdtool/files/install-no-owner.patch b/recipes/cdtool/files/install-no-owner.patch
new file mode 100644
index 0000000000..9519767350
--- /dev/null
+++ b/recipes/cdtool/files/install-no-owner.patch
@@ -0,0 +1,33 @@
+--- cdtool-2.1.8pre4/Makefile.in.orig 2006-06-05 20:38:28.567261984 -0600
++++ cdtool-2.1.8pre4/Makefile.in 2006-06-05 20:38:46.218578576 -0600
+@@ -44,13 +44,13 @@
+ install: install-files install-links
+ install-files:
+ mkdir -p $(DESTDIR)$(bindir)
+- $(INSTALL) cdctrl $(DESTDIR)$(bindir) -o root
+- $(INSTALL) cdloop $(DESTDIR)$(bindir) -o root
+- $(INSTALL) cdadd $(DESTDIR)$(bindir) -o root
+- $(INSTALL) cdown $(DESTDIR)$(bindir) -o root
+- $(INSTALL) cdtool2cddb $(DESTDIR)$(bindir) -o root
++ $(INSTALL) cdctrl $(DESTDIR)$(bindir)
++ $(INSTALL) cdloop $(DESTDIR)$(bindir)
++ $(INSTALL) cdadd $(DESTDIR)$(bindir)
++ $(INSTALL) cdown $(DESTDIR)$(bindir)
++ $(INSTALL) cdtool2cddb $(DESTDIR)$(bindir)
+
+- mkdir -p $(DESTDIR)$(mandir)/man1
++ $(INSTALL) -d $(DESTDIR)$(mandir)/man1
+ $(INSTALL) cdctrl.1 $(DESTDIR)$(mandir)/man1
+ $(INSTALL) cdloop.1 $(DESTDIR)$(mandir)/man1
+ $(INSTALL) cdadd.1 $(DESTDIR)$(mandir)/man1
+@@ -58,8 +58,8 @@
+ $(INSTALL) cdtool.1 $(DESTDIR)$(mandir)/man1
+ $(INSTALL) cdtool2cddb.1 $(DESTDIR)$(mandir)/man1
+
+- mkdir -p $(DESTDIR)$(libdir)/cdtool
+- $(INSTALL) cdtool $(DESTDIR)$(libdir)/cdtool -o root
++ $(INSTALL) -d $(DESTDIR)$(libdir)/cdtool
++ $(INSTALL) cdtool $(DESTDIR)$(libdir)/cdtool
+
+ LINKTARGET = ../lib/cdtool/cdtool
+ LINKS = cdplay cdpause cdstop cdclose cdeject cdir cdinfo cdreset \