aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/cfu1/cfu1-modules_2.6.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/cfu1/cfu1-modules_2.6.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/cfu1/cfu1-modules_2.6.bb')
-rw-r--r--recipes/cfu1/cfu1-modules_2.6.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/cfu1/cfu1-modules_2.6.bb b/recipes/cfu1/cfu1-modules_2.6.bb
new file mode 100644
index 0000000000..b6446c689b
--- /dev/null
+++ b/recipes/cfu1/cfu1-modules_2.6.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "PCMCIA driver for the RATOC REX-CFU1 USB host controller CF card."
+SECTION = "kernel/modules"
+PRIORITY = "optional"
+DEPENDS = "virtual/kernel"
+LICENSE = "GPL"
+RDEPENDS = "kernel-module-usbcore"
+PR = "r2"
+
+SRC_URI = "file://rex-cfu1.conf \
+ file://Makefile \
+ file://sl811_cs.c \
+ file://sl811_hcd.c \
+ file://sl811.h \
+ file://hcd.h \
+ file://hub.h"
+
+S = "${WORKDIR}"
+
+inherit module
+
+EXTRA_OEMAKE = 'EXTRA_CFLAGS="-DCONFIG_USB_SL811_CS -DCONFIG_USB_DEBUG" -C ${STAGING_KERNEL_DIR} SUBDIRS=${WORKDIR}'
+
+do_install() {
+ install -d ${D}/lib/modules/${KERNEL_VERSION}/pcmcia/
+ install -m 0644 sl811_cs.ko ${D}/lib/modules/${KERNEL_VERSION}/pcmcia/
+ install -m 0644 sl811_hcd.ko ${D}/lib/modules/${KERNEL_VERSION}/pcmcia/
+
+ install -d ${D}/${sysconfdir}/pcmcia/
+ install -m 0644 ${WORKDIR}/rex-cfu1.conf ${D}/${sysconfdir}/pcmcia/
+}