aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/changedfiles
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/changedfiles
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/changedfiles')
-rw-r--r--recipes/changedfiles/changedfiles-daemon_1.0-rc1.bb14
-rw-r--r--recipes/changedfiles/changedfiles-modules_1.0-rc1.bb28
-rw-r--r--recipes/changedfiles/changedfiles.inc10
-rw-r--r--recipes/changedfiles/files/autofoo.patch27
4 files changed, 79 insertions, 0 deletions
diff --git a/recipes/changedfiles/changedfiles-daemon_1.0-rc1.bb b/recipes/changedfiles/changedfiles-daemon_1.0-rc1.bb
new file mode 100644
index 0000000000..28cc1bf277
--- /dev/null
+++ b/recipes/changedfiles/changedfiles-daemon_1.0-rc1.bb
@@ -0,0 +1,14 @@
+require changedfiles.inc
+PR = "r1"
+
+SRC_URI += "file://autofoo.patch;patch=1"
+
+inherit autotools
+
+do_compile() {
+ oe_runmake daemon
+}
+
+do_install() {
+ oe_runmake -C daemon install bindir=${D}${bindir} sysconfdir=${D}${sysconfdir}
+}
diff --git a/recipes/changedfiles/changedfiles-modules_1.0-rc1.bb b/recipes/changedfiles/changedfiles-modules_1.0-rc1.bb
new file mode 100644
index 0000000000..c24a473beb
--- /dev/null
+++ b/recipes/changedfiles/changedfiles-modules_1.0-rc1.bb
@@ -0,0 +1,28 @@
+require changedfiles.inc
+
+PR = "r2"
+B = "${WORKDIR}/changedfiles-${PV}/module"
+
+inherit module
+
+do_compile() {
+ ${CC} -Wall -DMODULE -D__KERNEL__ -I${STAGING_KERNEL_DIR}/include -c changedfiles.c
+}
+
+pkg_postinst() {
+#!/bin/sh
+if [ -n $D ]; then exit 1; fi
+/bin/mknod /dev/changedfiles c 40 0; exit 0
+chmod 0600 /dev/changedfiles
+}
+
+pkg_postrm() {
+#!/bin/sh
+if [ -n $D ]; then exit 1; fi
+rm -f /dev/changedfiles
+}
+
+do_install() {
+ install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/fs/changedfiles/
+ install -m 0644 changedfiles.o ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/fs/changedfiles/
+}
diff --git a/recipes/changedfiles/changedfiles.inc b/recipes/changedfiles/changedfiles.inc
new file mode 100644
index 0000000000..3a440d0d02
--- /dev/null
+++ b/recipes/changedfiles/changedfiles.inc
@@ -0,0 +1,10 @@
+DESCRIPTION = "A framework for simple filesystem replication \
+and/or security monitoring and/or automatic file transformations"
+SECTION = "base"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "fget"
+RDEPENDS = "fget"
+
+SRC_URI = "http://www.bangstate.com/changedfiles-${PV}.tar.gz"
+S = "${WORKDIR}/changedfiles-${PV}"
diff --git a/recipes/changedfiles/files/autofoo.patch b/recipes/changedfiles/files/autofoo.patch
new file mode 100644
index 0000000000..d6020c7bf7
--- /dev/null
+++ b/recipes/changedfiles/files/autofoo.patch
@@ -0,0 +1,27 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- changedfiles-1.0-rc1/configure.in~autofoo
++++ changedfiles-1.0-rc1/configure.in
+@@ -9,11 +9,14 @@
+ case "$host" in
+ alpha*-*-linux*-*) AC_DEFINE( IS_ALPHA, 1, [System is DEC alpha based] );;
+ *-linux*)
+- AC_MSG_CHECKING( linux version )
+- case `uname -r` in
+- *2.4*) AC_MSG_RESULT( [ Supported ] );;
+- *) AC_MSG_ERROR( [`uname -r` is an unsupported kernel (only version 2.4 is supported)] );;
+- esac;;
++ if test x"$cross_compiling" = "x"; then
++ AC_MSG_CHECKING( linux version )
++ case `uname -r` in
++ *2.4*) AC_MSG_RESULT( [ Supported ] );;
++ *) AC_MSG_ERROR( [`uname -r` is an unsupported kernel (only version 2.4 is supported)] );;
++ esac
++ fi
++ ;;
+ *-solaris*) AC_MSG_WARN( [Solaris port is still experimental, use at your own risk.] ); LIBS="$VAR -lfget -lsocket -lnsl";;
+ *) AC_MSG_ERROR( [$host is an unsuppored platform.] );;
+ esac