aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/chillispot/chillispot_0.98.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/chillispot/chillispot_0.98.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/chillispot/chillispot_0.98.bb')
-rw-r--r--recipes/chillispot/chillispot_0.98.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/chillispot/chillispot_0.98.bb b/recipes/chillispot/chillispot_0.98.bb
new file mode 100644
index 0000000000..98b123e394
--- /dev/null
+++ b/recipes/chillispot/chillispot_0.98.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "ChilliSpot is an open source captive portal or wireless LAN access point controller. It is used for authenticating users of a wireless LAN."
+HOMEPAGE = "http://www.chillispot.org/"
+LICENSE = "GPL"
+PR = "r1"
+
+SRC_URI = "http://www.chillispot.org/download/chillispot-${PV}.tar.gz \
+ file://no-ansi.patch;patch=1 \
+ file://init"
+RRECOMMENDS = "kernel-module-tun"
+
+inherit autotools
+
+do_install_append() {
+ install -d ${D}${sysconfdir} ${D}${sysconfdir}/init.d
+ install ${S}/doc/chilli.conf ${D}${sysconfdir}
+ install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/chillispot
+}
+
+CONFFILES_${PN}_nylon = "${sysconfdir}/chilli.conf"