aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/clamav
diff options
context:
space:
mode:
authorRoman I Khimov <khimov@altell.ru>2010-03-30 16:42:47 +0400
committerRoman I Khimov <khimov@altell.ru>2010-03-30 21:42:08 +0400
commitc5ffbab676b961ecbc7a9e478ba571a8872185ff (patch)
tree971b14f0f42ce523560ede94a33403ec975b40cc /recipes/clamav
parent1f71e0d0b6f76e74ed848d75f6b50896f2ae160b (diff)
downloadopenembedded-c5ffbab676b961ecbc7a9e478ba571a8872185ff.tar.gz
clamav: add version 0.95.3
Signed-off-by: Roman I Khimov <khimov@altell.ru>
Diffstat (limited to 'recipes/clamav')
-rw-r--r--recipes/clamav/clamav-0.95.3/clamav-fix-_SC_PAGESIZE-missing.patch50
-rw-r--r--recipes/clamav/clamav.inc2
-rw-r--r--recipes/clamav/clamav_0.95.3.bb15
3 files changed, 66 insertions, 1 deletions
diff --git a/recipes/clamav/clamav-0.95.3/clamav-fix-_SC_PAGESIZE-missing.patch b/recipes/clamav/clamav-0.95.3/clamav-fix-_SC_PAGESIZE-missing.patch
new file mode 100644
index 0000000000..5a33125433
--- /dev/null
+++ b/recipes/clamav/clamav-0.95.3/clamav-fix-_SC_PAGESIZE-missing.patch
@@ -0,0 +1,50 @@
+From: Török Edvin <edwin@clamav.net>
+Date: Thu, 1 Oct 2009 13:18:32 +0000 (+0300)
+Subject: Fix build when git is not installed and using BSD make.
+X-Git-Url: http://git.clamav.net/gitweb?p=clamav-devel.git;a=commitdiff_plain;h=6238a5ca06c07931b2f6ace62601ef43807df8e2;hp=55d97736bd289b53c93b652d88e5acd1886ec1bc
+
+Fix build when git is not installed and using BSD make.
+---
+
+diff --git a/libclamav/Makefile.am b/libclamav/Makefile.am
+index 3ced7ff..7a267a0 100644
+--- a/libclamav/Makefile.am
++++ b/libclamav/Makefile.am
+@@ -304,8 +304,8 @@ version.h: version.h.tmp
+ version.h.tmp:
+ @test -f version.h || touch version.h;\
+ rm -f $@;\
+- REVISION="$$(LANG=C cd "$(top_srcdir)"; git describe --always 2>/dev/null)";\
+- if test $$? -ne 0; then\
++ REVISION="$$(LANG=C cd "$(top_srcdir)"; git describe --always 2>/dev/null || echo "exported")";\
++ if test "$$REVISION" = "exported"; then\
+ REVISION="r$$(LANG=C svnversion "$(top_srcdir)" 2>/dev/null || echo exported)";\
+ if test "$$REVISION" = "rexported"; then\
+ REVISION="";\
+diff --git a/libclamav/Makefile.in b/libclamav/Makefile.in
+index 8420601..a031c14 100644
+--- a/libclamav/Makefile.in
++++ b/libclamav/Makefile.in
+@@ -1832,8 +1832,8 @@ version.h: version.h.tmp
+ version.h.tmp:
+ @test -f version.h || touch version.h;\
+ rm -f $@;\
+- REVISION="$$(LANG=C cd "$(top_srcdir)"; git describe --always 2>/dev/null)";\
+- if test $$? -ne 0; then\
++ REVISION="$$(LANG=C cd "$(top_srcdir)"; git describe --always 2>/dev/null || echo "exported")";\
++ if test "$$REVISION" = "exported"; then\
+ REVISION="r$$(LANG=C svnversion "$(top_srcdir)" 2>/dev/null || echo exported)";\
+ if test "$$REVISION" = "rexported"; then\
+ REVISION="";\
+diff --git a/libclamav/others.h b/libclamav/others.h
+index 42ca636..ed313d8 100644
+--- a/libclamav/others.h
++++ b/libclamav/others.h
+@@ -29,6 +29,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <unistd.h>
+ #include "cltypes.h"
+
+ #include "clamav.h"
diff --git a/recipes/clamav/clamav.inc b/recipes/clamav/clamav.inc
index 99ce1a206b..405e3c7c28 100644
--- a/recipes/clamav/clamav.inc
+++ b/recipes/clamav/clamav.inc
@@ -20,7 +20,7 @@ RPROVIDES_${PN}-freshclam = "${PN}-data"
INC_PR = "r2"
-SRC_URI = "${SOURCEFORGE_MIRROR}/clamav/clamav-${PV}.tar.gz \
+SRC_URI = "${SOURCEFORGE_MIRROR}/clamav/clamav-${PV}.tar.gz;name=clamav-${PV} \
file://clamav-daemon.init \
file://clamav-freshclam.init \
file://clamd.conf \
diff --git a/recipes/clamav/clamav_0.95.3.bb b/recipes/clamav/clamav_0.95.3.bb
new file mode 100644
index 0000000000..4e510f5922
--- /dev/null
+++ b/recipes/clamav/clamav_0.95.3.bb
@@ -0,0 +1,15 @@
+require clamav.inc
+
+SRC_URI += "file://clamav-fix-_SC_PAGESIZE-missing.patch;patch=1"
+
+SRC_URI[clamav-0.95.3.md5sum] = "eaf9fccc3cc3567605a9732313652967"
+SRC_URI[clamav-0.95.3.sha256sum] = "003e7a570932fdffbd19fa7a7996274fbfc93f890d26c3066a36eb824c906250"
+
+EXTRA_OECONF += "--program-transform-name=''"
+
+PR = "${INC_PR}.1"
+
+do_install_append() {
+ # Remove deprecated options
+ sed -ri "/Archive(Block)?Max/d" ${D}/${sysconfdir}/clamd.conf
+} \ No newline at end of file