aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/clamsmtp/clamsmtp_1.8.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/clamsmtp/clamsmtp_1.8.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/clamsmtp/clamsmtp_1.8.bb')
-rw-r--r--recipes/clamsmtp/clamsmtp_1.8.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/recipes/clamsmtp/clamsmtp_1.8.bb b/recipes/clamsmtp/clamsmtp_1.8.bb
new file mode 100644
index 0000000000..984d203e36
--- /dev/null
+++ b/recipes/clamsmtp/clamsmtp_1.8.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "ClamSMTP is an SMTP filter that allows you to check for \
+viruses using the ClamAV anti-virus software. It accepts SMTP connections \
+and forwards the SMTP commands and responses to another SMTP server. The \
+'DATA' email body is intercepted and scanned before forwarding. ClamSMTP \
+has an optional transparent proxy mode."
+HOMEPAGE = "http://memberwebs.com/nielsen/software/clamsmtp/"
+SECTION = "network"
+LICENSE = "BSD"
+DEPENDS = "clamav"
+RDEPENDS_${PN} = "clamav-daemon"
+PR = "r2"
+
+SRC_URI = "http://memberwebs.com/nielsen/software/clamsmtp/clamsmtp-${PV}.tar.gz \
+ file://update-config.patch;patch=1 \
+ file://clamsmtp.init \
+ file://doc.configure.txt"
+
+inherit autotools update-rc.d
+
+do_configure () {
+ # no autoreconf please
+ aclocal
+ autoconf
+ libtoolize --force
+ oe_runconf
+}
+do_install_append () {
+ install -m 0755 -d ${D}${sysconfdir}/init.d \
+ ${D}${docdir}/clamsmtp
+ install -m 755 ${WORKDIR}/clamsmtp.init ${D}${sysconfdir}/init.d/clamsmtpd
+ install -m 644 doc/clamsmtpd.conf ${D}${sysconfdir}/clamsmtpd.conf
+ install -m 644 README ${D}${docdir}/clamsmtp
+ install -m 644 ${WORKDIR}/doc.configure.txt ${D}${docdir}/clamsmtp/configure.txt
+ install -m 644 scripts/virus_action.sh ${D}${docdir}/clamsmtp
+}
+
+CONFFILES_${PN} = "${sysconfdir}/clamsmtpd.conf"
+
+INITSCRIPT_NAME = "clamsmtpd"
+INITSCRIPT_PARAMS = "defaults 65 35"