aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/classpath/classpath-native_0.97.2.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/classpath/classpath-native_0.97.2.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/classpath/classpath-native_0.97.2.bb')
-rw-r--r--recipes/classpath/classpath-native_0.97.2.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes/classpath/classpath-native_0.97.2.bb b/recipes/classpath/classpath-native_0.97.2.bb
new file mode 100644
index 0000000000..0024136b97
--- /dev/null
+++ b/recipes/classpath/classpath-native_0.97.2.bb
@@ -0,0 +1,32 @@
+require classpath-native.inc
+
+PR = "r4"
+
+# The code affected by the javanet-local patch
+# is usually not compiled. However if someone changes
+# to --enable-local-sockets it will.
+SRC_URI += "\
+ file://netif_16.patch;patch=1;pnum=0 \
+ file://SimpleName.diff;patch=1;pnum=0 \
+ file://javanet-local.patch;patch=1;pnum=0 \
+ file://sun-security-getproperty_0.96.1.patch;patch=1;pnum=0 \
+ file://ecj_java_dir.patch;patch=1 \
+ file://autotools.patch;patch=1 \
+ file://decimalformat.patch;patch=1 \
+ file://cp-byte-loophelper.patch;patch=1;pnum=0 \
+ file://miscompilation.patch;patch=1 \
+ "
+
+do_unpackpost() {
+ # Kind of patch: Moves package "org.w3c.dom.html2" to "org.w3c.dom.html"
+ mv external/w3c_dom/org/w3c/dom/html2 \
+ external/w3c_dom/org/w3c/dom/html
+
+ find examples/gnu/classpath/examples/html gnu/xml/dom/html2 external/w3c_dom/org/w3c/dom/html -name "*.java" \
+ -exec sed -i -e"s|org.w3c.dom.html2|org.w3c.dom.html|" {} \;
+
+ sed -i -e"s|org/w3c/dom/html2|org/w3c/dom/html|" external/w3c_dom/Makefile.am
+}
+
+addtask unpackpost after do_unpack before do_patch
+