aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/classpath/classpath-native_0.97.2.bb
diff options
context:
space:
mode:
authorStefan Schmidt <stefan@datenfreihafen.org>2009-03-25 18:29:54 +0100
committerStefan Schmidt <stefan@datenfreihafen.org>2009-03-25 18:29:54 +0100
commit95e0882e2dfabe457550a885e0eb24893df31742 (patch)
treea34220ed25168022c53d9cb5697f3666a427b30c /recipes/classpath/classpath-native_0.97.2.bb
parent451b1c687105655a4f2c9c477b05535041e25060 (diff)
parentac41ae95b1dbe54c05adf494c0fa44b3abbfeca3 (diff)
downloadopenembedded-95e0882e2dfabe457550a885e0eb24893df31742.tar.gz
Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into org.openembedded.dev
Diffstat (limited to 'recipes/classpath/classpath-native_0.97.2.bb')
-rw-r--r--recipes/classpath/classpath-native_0.97.2.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes/classpath/classpath-native_0.97.2.bb b/recipes/classpath/classpath-native_0.97.2.bb
new file mode 100644
index 0000000000..0024136b97
--- /dev/null
+++ b/recipes/classpath/classpath-native_0.97.2.bb
@@ -0,0 +1,32 @@
+require classpath-native.inc
+
+PR = "r4"
+
+# The code affected by the javanet-local patch
+# is usually not compiled. However if someone changes
+# to --enable-local-sockets it will.
+SRC_URI += "\
+ file://netif_16.patch;patch=1;pnum=0 \
+ file://SimpleName.diff;patch=1;pnum=0 \
+ file://javanet-local.patch;patch=1;pnum=0 \
+ file://sun-security-getproperty_0.96.1.patch;patch=1;pnum=0 \
+ file://ecj_java_dir.patch;patch=1 \
+ file://autotools.patch;patch=1 \
+ file://decimalformat.patch;patch=1 \
+ file://cp-byte-loophelper.patch;patch=1;pnum=0 \
+ file://miscompilation.patch;patch=1 \
+ "
+
+do_unpackpost() {
+ # Kind of patch: Moves package "org.w3c.dom.html2" to "org.w3c.dom.html"
+ mv external/w3c_dom/org/w3c/dom/html2 \
+ external/w3c_dom/org/w3c/dom/html
+
+ find examples/gnu/classpath/examples/html gnu/xml/dom/html2 external/w3c_dom/org/w3c/dom/html -name "*.java" \
+ -exec sed -i -e"s|org.w3c.dom.html2|org.w3c.dom.html|" {} \;
+
+ sed -i -e"s|org/w3c/dom/html2|org/w3c/dom/html|" external/w3c_dom/Makefile.am
+}
+
+addtask unpackpost after do_unpack before do_patch
+