aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/classpath
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-05-23 20:23:53 -0700
committerChris Larson <chris_larson@mentor.com>2010-05-25 12:53:41 -0700
commitbf7d0467a0788a7fcc1c96e0dc35a25ae09278a0 (patch)
tree96f28e2f5133d68c3e3dadabaa2339340671454f /recipes/classpath
parentfab0af3aefee22b21541e403d3c356a6979bfa63 (diff)
downloadopenembedded-bf7d0467a0788a7fcc1c96e0dc35a25ae09278a0.tar.gz
Rename url params patch=<ignored>/pnum=<n> to apply={yes,no}/striplevel=<n>
I think this makes the behavior rather more clear. Signed-off-by: Chris Larson <chris_larson@mentor.com> Acked-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/classpath')
-rw-r--r--recipes/classpath/classpath-initial_0.93.bb4
-rw-r--r--recipes/classpath/classpath-minimal_0.96.1.bb4
-rw-r--r--recipes/classpath/classpath-minimal_0.97.2.bb14
-rw-r--r--recipes/classpath/classpath-native_0.97.2.bb20
-rw-r--r--recipes/classpath/classpath-native_0.98.bb12
-rw-r--r--recipes/classpath/classpath_0.95.bb6
-rw-r--r--recipes/classpath/classpath_0.96.1.bb6
-rw-r--r--recipes/classpath/classpath_0.97.2.bb20
-rw-r--r--recipes/classpath/classpath_0.98.bb10
-rw-r--r--recipes/classpath/inetlib_1.1.1.bb2
10 files changed, 49 insertions, 49 deletions
diff --git a/recipes/classpath/classpath-initial_0.93.bb b/recipes/classpath/classpath-initial_0.93.bb
index 2837775897..d56ada2d45 100644
--- a/recipes/classpath/classpath-initial_0.93.bb
+++ b/recipes/classpath/classpath-initial_0.93.bb
@@ -10,8 +10,8 @@ PR = "r6"
DEPENDS = "zip-native fastjar-native jikes-native gettext-native"
SRC_URI += "\
- file://autotools.patch;patch=1 \
- file://miscompilation-0.93.patch;patch=1 \
+ file://autotools.patch;apply=yes \
+ file://miscompilation-0.93.patch;apply=yes \
"
EXTRA_OECONF = "\
diff --git a/recipes/classpath/classpath-minimal_0.96.1.bb b/recipes/classpath/classpath-minimal_0.96.1.bb
index 4b886ff5c1..14c193c8c6 100644
--- a/recipes/classpath/classpath-minimal_0.96.1.bb
+++ b/recipes/classpath/classpath-minimal_0.96.1.bb
@@ -3,8 +3,8 @@ require classpath.inc
PR = "r7"
SRC_URI += "\
- file://gjar-prefix-patch.diff;patch=1;pnum=0 \
- file://xmlstream-fix.patch;patch=1;pnum=0 \
+ file://gjar-prefix-patch.diff;apply=yes;striplevel=0 \
+ file://xmlstream-fix.patch;apply=yes;striplevel=0 \
"
PROVIDES = "${PN} classpath"
diff --git a/recipes/classpath/classpath-minimal_0.97.2.bb b/recipes/classpath/classpath-minimal_0.97.2.bb
index 5920109abc..4577987ce0 100644
--- a/recipes/classpath/classpath-minimal_0.97.2.bb
+++ b/recipes/classpath/classpath-minimal_0.97.2.bb
@@ -3,13 +3,13 @@ require classpath.inc
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/${PBN}-${PV}"
SRC_URI += "\
- file://netif_16.patch;patch=1;pnum=0 \
- file://SimpleName.diff;patch=1;pnum=0 \
- file://javanet-local.patch;patch=1;pnum=0 \
- file://ecj_java_dir.patch;patch=1 \
- file://autotools.patch;patch=1 \
- file://decimalformat.patch;patch=1 \
- file://cp-byte-loophelper.patch;patch=1;pnum=0 \
+ file://netif_16.patch;apply=yes;striplevel=0 \
+ file://SimpleName.diff;apply=yes;striplevel=0 \
+ file://javanet-local.patch;apply=yes;striplevel=0 \
+ file://ecj_java_dir.patch;apply=yes \
+ file://autotools.patch;apply=yes \
+ file://decimalformat.patch;apply=yes \
+ file://cp-byte-loophelper.patch;apply=yes;striplevel=0 \
"
PR = "r3"
diff --git a/recipes/classpath/classpath-native_0.97.2.bb b/recipes/classpath/classpath-native_0.97.2.bb
index bea4b7683b..39d951645c 100644
--- a/recipes/classpath/classpath-native_0.97.2.bb
+++ b/recipes/classpath/classpath-native_0.97.2.bb
@@ -6,16 +6,16 @@ PR = "r7"
# is usually not compiled. However if someone changes
# to --enable-local-sockets it will.
SRC_URI += "\
- file://netif_16.patch;patch=1;pnum=0 \
- file://SimpleName.diff;patch=1;pnum=0 \
- file://javanet-local.patch;patch=1;pnum=0 \
- file://sun-security-getproperty_0.96.1.patch;patch=1;pnum=0 \
- file://ecj_java_dir.patch;patch=1 \
- file://autotools.patch;patch=1 \
- file://decimalformat.patch;patch=1 \
- file://cp-byte-loophelper.patch;patch=1;pnum=0 \
- file://miscompilation.patch;patch=1 \
- file://toolwrapper-exithook.patch;patch=1 \
+ file://netif_16.patch;apply=yes;striplevel=0 \
+ file://SimpleName.diff;apply=yes;striplevel=0 \
+ file://javanet-local.patch;apply=yes;striplevel=0 \
+ file://sun-security-getproperty_0.96.1.patch;apply=yes;striplevel=0 \
+ file://ecj_java_dir.patch;apply=yes \
+ file://autotools.patch;apply=yes \
+ file://decimalformat.patch;apply=yes \
+ file://cp-byte-loophelper.patch;apply=yes;striplevel=0 \
+ file://miscompilation.patch;apply=yes \
+ file://toolwrapper-exithook.patch;apply=yes \
"
do_unpackpost() {
diff --git a/recipes/classpath/classpath-native_0.98.bb b/recipes/classpath/classpath-native_0.98.bb
index 44a1530675..dd64856006 100644
--- a/recipes/classpath/classpath-native_0.98.bb
+++ b/recipes/classpath/classpath-native_0.98.bb
@@ -9,12 +9,12 @@ PR = "r3"
# is usually not compiled. However if someone changes
# to --enable-local-sockets it will.
SRC_URI += "\
- file://SimpleName.diff;patch=1;pnum=0 \
- file://sun-security-getproperty.patch;patch=1;pnum=0 \
- file://ecj_java_dir.patch;patch=1 \
- file://autotools.patch;patch=1 \
- file://miscompilation.patch;patch=1 \
- file://toolwrapper-exithook.patch;patch=1 \
+ file://SimpleName.diff;apply=yes;striplevel=0 \
+ file://sun-security-getproperty.patch;apply=yes;striplevel=0 \
+ file://ecj_java_dir.patch;apply=yes \
+ file://autotools.patch;apply=yes \
+ file://miscompilation.patch;apply=yes \
+ file://toolwrapper-exithook.patch;apply=yes \
"
do_unpackpost() {
diff --git a/recipes/classpath/classpath_0.95.bb b/recipes/classpath/classpath_0.95.bb
index 0dfad33444..2514e39ac9 100644
--- a/recipes/classpath/classpath_0.95.bb
+++ b/recipes/classpath/classpath_0.95.bb
@@ -1,9 +1,9 @@
require classpath.inc
SRC_URI += "\
- file://gjar-prefix-patch.diff;patch=1;pnum=0 \
- file://xmlstream-fix.patch;patch=1;pnum=0 \
- file://javanet-local.patch;patch=1;pnum=0 \
+ file://gjar-prefix-patch.diff;apply=yes;striplevel=0 \
+ file://xmlstream-fix.patch;apply=yes;striplevel=0 \
+ file://javanet-local.patch;apply=yes;striplevel=0 \
"
PR = "r7"
diff --git a/recipes/classpath/classpath_0.96.1.bb b/recipes/classpath/classpath_0.96.1.bb
index 19e0059c7f..09734da2e0 100644
--- a/recipes/classpath/classpath_0.96.1.bb
+++ b/recipes/classpath/classpath_0.96.1.bb
@@ -1,9 +1,9 @@
require classpath.inc
SRC_URI += "\
- file://gjar-prefix-patch.diff;patch=1;pnum=0 \
- file://xmlstream-fix.patch;patch=1;pnum=0 \
- file://javanet-local.patch;patch=1;pnum=0 \
+ file://gjar-prefix-patch.diff;apply=yes;striplevel=0 \
+ file://xmlstream-fix.patch;apply=yes;striplevel=0 \
+ file://javanet-local.patch;apply=yes;striplevel=0 \
"
PR = "r9"
diff --git a/recipes/classpath/classpath_0.97.2.bb b/recipes/classpath/classpath_0.97.2.bb
index d8f070c2d3..cccf9cf772 100644
--- a/recipes/classpath/classpath_0.97.2.bb
+++ b/recipes/classpath/classpath_0.97.2.bb
@@ -1,16 +1,16 @@
require classpath.inc
SRC_URI += "\
- file://netif_16.patch;patch=1;pnum=0 \
- file://SimpleName.diff;patch=1;pnum=0 \
- file://javanet-local.patch;patch=1;pnum=0 \
- file://ecj_java_dir.patch;patch=1 \
- file://autotools.patch;patch=1 \
- file://decimalformat.patch;patch=1 \
- file://cp-byte-loophelper.patch;patch=1;pnum=0 \
- file://drawpolyline.patch;patch=1;pnum=0 \
- file://gtk-fix.patch;patch=1;pnum=0 \
- file://toolwrapper-exithook.patch;patch=1 \
+ file://netif_16.patch;apply=yes;striplevel=0 \
+ file://SimpleName.diff;apply=yes;striplevel=0 \
+ file://javanet-local.patch;apply=yes;striplevel=0 \
+ file://ecj_java_dir.patch;apply=yes \
+ file://autotools.patch;apply=yes \
+ file://decimalformat.patch;apply=yes \
+ file://cp-byte-loophelper.patch;apply=yes;striplevel=0 \
+ file://drawpolyline.patch;apply=yes;striplevel=0 \
+ file://gtk-fix.patch;apply=yes;striplevel=0 \
+ file://toolwrapper-exithook.patch;apply=yes \
"
PR = "r10"
diff --git a/recipes/classpath/classpath_0.98.bb b/recipes/classpath/classpath_0.98.bb
index 693ed8b7a3..534ee5c267 100644
--- a/recipes/classpath/classpath_0.98.bb
+++ b/recipes/classpath/classpath_0.98.bb
@@ -1,11 +1,11 @@
require classpath.inc
SRC_URI += "\
- file://SimpleName.diff;patch=1;pnum=0 \
- file://ecj_java_dir.patch;patch=1 \
- file://autotools.patch;patch=1 \
- file://fix-gmp.patch;patch=1 \
- file://toolwrapper-exithook.patch;patch=1 \
+ file://SimpleName.diff;apply=yes;striplevel=0 \
+ file://ecj_java_dir.patch;apply=yes \
+ file://autotools.patch;apply=yes \
+ file://fix-gmp.patch;apply=yes \
+ file://toolwrapper-exithook.patch;apply=yes \
"
PR = "r3"
diff --git a/recipes/classpath/inetlib_1.1.1.bb b/recipes/classpath/inetlib_1.1.1.bb
index e4b782406c..a82ce44be3 100644
--- a/recipes/classpath/inetlib_1.1.1.bb
+++ b/recipes/classpath/inetlib_1.1.1.bb
@@ -5,7 +5,7 @@ HOMEPAGE = "http://gnu.org/software/classpath/inetlib.html"
SRC_URI = "\
http://ftp.gnu.org/gnu/classpath/${BP}.tar.gz \
- file://datadir_java.patch;patch=1 \
+ file://datadir_java.patch;apply=yes \
"
inherit java-library autotools