aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/classpath
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-08-15 17:32:08 +0200
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-08-15 17:32:08 +0200
commitf5ac776ae3a868931fbf844d01d00dbf1106f229 (patch)
tree27355117b0891b93645c3925743c8cbe296fc3f8 /recipes/classpath
parenta80dae92c90be07ca2c8765b1690d68153dce707 (diff)
downloadopenembedded-f5ac776ae3a868931fbf844d01d00dbf1106f229.tar.gz
classpath: remove old versions
Signed-off-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/classpath')
-rw-r--r--recipes/classpath/classpath-0.97.2/autotools.patch13
-rw-r--r--recipes/classpath/classpath-0.97.2/drawpolyline.patch26
-rw-r--r--recipes/classpath/classpath-0.97.2/gtk-fix.patch147
-rw-r--r--recipes/classpath/classpath-minimal_0.97.2.bb33
-rw-r--r--recipes/classpath/classpath-native_0.97.2.bb36
-rw-r--r--recipes/classpath/classpath_0.97.2.bb19
6 files changed, 0 insertions, 274 deletions
diff --git a/recipes/classpath/classpath-0.97.2/autotools.patch b/recipes/classpath/classpath-0.97.2/autotools.patch
deleted file mode 100644
index e36e143b5f..0000000000
--- a/recipes/classpath/classpath-0.97.2/autotools.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: classpath-0.97.2/configure.ac
-===================================================================
---- classpath-0.97.2.orig/configure.ac 2008-06-06 02:58:57.000000000 +0200
-+++ classpath-0.97.2/configure.ac 2008-08-02 00:58:16.537364104 +0200
-@@ -41,6 +41,8 @@
- AC_CONFIG_HEADERS([include/config.h])
- AC_PREFIX_DEFAULT(/usr/local/classpath)
-
-+AC_CONFIG_MACRO_DIR([m4])
-+
- dnl -----------------------------------------------------------
- dnl Enable collections.jar (disabled by default)
- dnl -----------------------------------------------------------
diff --git a/recipes/classpath/classpath-0.97.2/drawpolyline.patch b/recipes/classpath/classpath-0.97.2/drawpolyline.patch
deleted file mode 100644
index 407f991306..0000000000
--- a/recipes/classpath/classpath-0.97.2/drawpolyline.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-Index: gnu/java/awt/peer/gtk/CairoGraphics2D.java
-===================================================================
-RCS file: /sources/classpath/classpath/gnu/java/awt/peer/gtk/CairoGraphics2D.java,v
-retrieving revision 1.73
-diff -u -r1.73 CairoGraphics2D.java
---- gnu/java/awt/peer/gtk/CairoGraphics2D.java 8 Feb 2008 22:17:39 -0000 1.73
-+++ gnu/java/awt/peer/gtk/CairoGraphics2D.java 14 Oct 2008 06:50:57 -0000
-@@ -1246,7 +1246,10 @@
-
- public void drawPolyline(int[] xPoints, int[] yPoints, int nPoints)
- {
-- draw(new Polygon(xPoints, yPoints, nPoints));
-+ for (int i = 1; i < nPoints; i++)
-+ draw(new Line2D.Double(
-+ xPoints[i - 1], yPoints[i - 1],
-+ xPoints[i], yPoints[i]));
- }
-
- public void drawOval(int x, int y, int width, int height)
-@@ -2171,4 +2174,4 @@
-
- return new Rectangle2D.Double(minX, minY, (maxX - minX), (maxY - minY));
- }
--}
-\ No newline at end of file
-+}
diff --git a/recipes/classpath/classpath-0.97.2/gtk-fix.patch b/recipes/classpath/classpath-0.97.2/gtk-fix.patch
deleted file mode 100644
index 0addec87ac..0000000000
--- a/recipes/classpath/classpath-0.97.2/gtk-fix.patch
+++ /dev/null
@@ -1,147 +0,0 @@
-Index: gnu/java/awt/peer/gtk/FreetypeGlyphVector.java
-===================================================================
---- gnu/java/awt/peer/gtk/FreetypeGlyphVector.java.orig 2007-04-12 22:18:09.000000000 +0200
-+++ gnu/java/awt/peer/gtk/FreetypeGlyphVector.java 2008-11-28 18:29:50.000000000 +0100
-@@ -247,7 +247,8 @@
- /**
- * Returns the kerning of a glyph pair
- */
-- private native Point2D getKerning(int leftGlyph, int rightGlyph, long font);
-+ private native void getKerning(int leftGlyph, int rightGlyph, long font,
-+ float[] p);
-
- private native double[] getMetricsNative(int glyphCode, long font);
-
-@@ -301,6 +302,7 @@
- GlyphMetrics gm = null;
- float x = 0;
- float y = 0;
-+ float[] p = {0.0f, 0.0f};
- for(int i = 0; i < nGlyphs; i++)
- {
- gm = getGlyphMetrics( i );
-@@ -314,9 +316,9 @@
- // using the same font
- if (i != nGlyphs-1 && fontSet[i] == fontSet[i+1])
- {
-- Point2D p = getKerning(glyphCodes[i], glyphCodes[i + 1], fontSet[i]);
-- x += p.getX();
-- y += p.getY();
-+ getKerning(glyphCodes[i], glyphCodes[i + 1], fontSet[i], p);
-+ x += p[0];
-+ y += p[1];
- }
- }
- glyphPositions[nGlyphs * 2] = x;
-Index: include/gnu_java_awt_peer_gtk_FreetypeGlyphVector.h
-===================================================================
---- include/gnu_java_awt_peer_gtk_FreetypeGlyphVector.h.orig 2008-06-06 04:10:00.000000000 +0200
-+++ include/gnu_java_awt_peer_gtk_FreetypeGlyphVector.h 2008-11-28 18:29:50.000000000 +0100
-@@ -13,7 +13,7 @@
- JNIEXPORT void JNICALL Java_gnu_java_awt_peer_gtk_FreetypeGlyphVector_dispose (JNIEnv *env, jobject, jlongArray);
- JNIEXPORT jlong JNICALL Java_gnu_java_awt_peer_gtk_FreetypeGlyphVector_getNativeFontPointer (JNIEnv *env, jobject, jint);
- JNIEXPORT void JNICALL Java_gnu_java_awt_peer_gtk_FreetypeGlyphVector_getGlyphs (JNIEnv *env, jobject, jintArray, jintArray, jlongArray);
--JNIEXPORT jobject JNICALL Java_gnu_java_awt_peer_gtk_FreetypeGlyphVector_getKerning (JNIEnv *env, jobject, jint, jint, jlong);
-+JNIEXPORT void JNICALL Java_gnu_java_awt_peer_gtk_FreetypeGlyphVector_getKerning (JNIEnv *env, jobject, jint, jint, jlong, jfloatArray);
- JNIEXPORT jdoubleArray JNICALL Java_gnu_java_awt_peer_gtk_FreetypeGlyphVector_getMetricsNative (JNIEnv *env, jobject, jint, jlong);
- JNIEXPORT jobject JNICALL Java_gnu_java_awt_peer_gtk_FreetypeGlyphVector_getGlyphOutlineNative (JNIEnv *env, jobject, jint, jlong);
-
-Index: native/jni/gtk-peer/gnu_java_awt_peer_gtk_FreetypeGlyphVector.c
-===================================================================
---- native/jni/gtk-peer/gnu_java_awt_peer_gtk_FreetypeGlyphVector.c.orig 2007-04-25 16:53:03.000000000 +0200
-+++ native/jni/gtk-peer/gnu_java_awt_peer_gtk_FreetypeGlyphVector.c 2008-11-28 18:29:50.000000000 +0100
-@@ -169,15 +169,13 @@
- (*env)->ReleaseLongArrayElements (env, fonts, fontArray, 0);
- }
-
--JNIEXPORT jobject JNICALL
-+JNIEXPORT void JNICALL
- Java_gnu_java_awt_peer_gtk_FreetypeGlyphVector_getKerning
--(JNIEnv *env, jobject obj __attribute__((unused)), jint rightGlyph, jint leftGlyph, jlong fnt)
-+ (JNIEnv *env, jobject obj __attribute__((unused)), jint rightGlyph,
-+ jint leftGlyph, jlong fnt, jfloatArray p)
- {
- FT_Face ft_face;
- FT_Vector kern;
-- jclass cls;
-- jmethodID method;
-- jvalue values[2];
- PangoFcFont *font;
-
- font = JLONG_TO_PTR(PangoFcFont, fnt);
-@@ -187,12 +185,10 @@
-
- pango_fc_font_unlock_face( font );
-
-- values[0].d = (jdouble)kern.x/64.0;
-- values[1].d = (jdouble)kern.y/64.0;
--
-- cls = (*env)->FindClass (env, "java/awt/geom/Point2D$Double");
-- method = (*env)->GetMethodID (env, cls, "<init>", "(DD)V");
-- return (*env)->NewObjectA(env, cls, method, values);
-+ jfloat *pelements = (*env)->GetPrimitiveArrayCritical(env, p, NULL);
-+ pelements[0] = (jfloat)kern.x/64.0;
-+ pelements[1] = (jfloat)kern.y/64.0;
-+ (*env)->ReleasePrimitiveArrayCritical (env, p, pelements, 0);
- }
-
- JNIEXPORT jdoubleArray JNICALL
-Index: gnu/java/awt/peer/gtk/GtkFileDialogPeer.java
-===================================================================
---- gnu/java/awt/peer/gtk/GtkFileDialogPeer.java.orig 2008-12-01 07:51:00.000000000 +0100
-+++ gnu/java/awt/peer/gtk/GtkFileDialogPeer.java 2008-12-01 07:52:04.000000000 +0100
-@@ -67,7 +67,7 @@
-
- FileDialog fd = (FileDialog) awtComponent;
-
-- nativeSetDirectory(System.getProperty("user.dir"));
-+ nativeSetDirectory(System.getProperty("user.dir", "."));
- setDirectory(fd.getDirectory());
- setFile(fd.getFile());
-
-@@ -108,18 +108,26 @@
- if (fileName == null || fileName.equals (""))
- {
- currentFile = "";
-- nativeSetFile ("");
-+ nativeSetFile (new File("").getAbsolutePath());
- return;
- }
-
- // GtkFileChooser requires absolute filenames. If the given filename
- // is not absolute, let's construct it based on current directory.
- currentFile = fileName;
-- if (fileName.indexOf(FS) == 0)
-+ File f = new File(fileName);
-+ if (f.isAbsolute())
- nativeSetFile(fileName);
- else
-- nativeSetFile(nativeGetDirectory() + FS + fileName);
-- }
-+ {
-+ // Try with gtk API.
-+ String temp = nativeGetDirectory();
-+ if (temp != null)
-+ f = new File(temp, fileName);
-+
-+ nativeSetFile(f.getAbsolutePath());
-+ }
-+}
-
- public void setDirectory (String directory)
- {
-Index: native/jni/gtk-peer/gnu_java_awt_peer_gtk_GtkScrollPanePeer.c
-===================================================================
---- native/jni/gtk-peer/gnu_java_awt_peer_gtk_GtkScrollPanePeer.c.orig 2008-12-01 07:53:00.000000000 +0100
-+++ native/jni/gtk-peer/gnu_java_awt_peer_gtk_GtkScrollPanePeer.c 2008-12-01 07:53:17.000000000 +0100
-@@ -58,6 +58,10 @@
- gtkpeer_set_global_ref (env, obj);
-
- sw = gtk_scrolled_window_new (NULL, NULL);
-+
-+ /* Sanitize width and height. gtk+ does not accept anything below -1. */
-+ width = (width < -1 ? 0 : width);
-+ height = (height < -1 ? 0 : height);
- gtk_widget_set_size_request (sw, width, height);
- eventbox = gtk_event_box_new ();
- gtk_container_add (GTK_CONTAINER (eventbox), sw);
diff --git a/recipes/classpath/classpath-minimal_0.97.2.bb b/recipes/classpath/classpath-minimal_0.97.2.bb
deleted file mode 100644
index ce5eb20e64..0000000000
--- a/recipes/classpath/classpath-minimal_0.97.2.bb
+++ /dev/null
@@ -1,33 +0,0 @@
-require classpath.inc
-
-FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/${PBN}-${PV}"
-
-SRC_URI += "\
- file://netif_16.patch;striplevel=0 \
- file://SimpleName.diff;striplevel=0 \
- file://javanet-local.patch;striplevel=0 \
- file://ecj_java_dir.patch \
- file://autotools.patch \
- file://decimalformat.patch \
- file://cp-byte-loophelper.patch;striplevel=0 \
- "
-
-PR = "r3"
-
-PROVIDES = "${PN} classpath"
-
-EXTRA_OECONF += "\
- --enable-local-sockets \
- --disable-alsa \
- --disable-gconf-peer \
- --disable-gtk-peer \
- --disable-plugin \
- --disable-dssi \
- --disable-examples \
- "
-
-CPPACKAGES = "${PBN}-common ${PBN}-tools"
-
-
-SRC_URI[md5sum] = "6a35347901ace03c31cc49751b338f31"
-SRC_URI[sha256sum] = "001fee5ad3ddd043783d59593153510f09064b0d9b5aea82f535266f62f02db4"
diff --git a/recipes/classpath/classpath-native_0.97.2.bb b/recipes/classpath/classpath-native_0.97.2.bb
deleted file mode 100644
index 19c07a0578..0000000000
--- a/recipes/classpath/classpath-native_0.97.2.bb
+++ /dev/null
@@ -1,36 +0,0 @@
-require classpath-native.inc
-
-PR = "r7"
-
-# The code affected by the javanet-local patch
-# is usually not compiled. However if someone changes
-# to --enable-local-sockets it will.
-SRC_URI += "\
- file://netif_16.patch;striplevel=0 \
- file://SimpleName.diff;striplevel=0 \
- file://javanet-local.patch;striplevel=0 \
- file://sun-security-getproperty_0.96.1.patch;striplevel=0 \
- file://ecj_java_dir.patch \
- file://autotools.patch \
- file://decimalformat.patch \
- file://cp-byte-loophelper.patch;striplevel=0 \
- file://miscompilation.patch \
- file://toolwrapper-exithook.patch \
- "
-
-do_unpackpost() {
- # Kind of patch: Moves package "org.w3c.dom.html2" to "org.w3c.dom.html"
- mv external/w3c_dom/org/w3c/dom/html2 \
- external/w3c_dom/org/w3c/dom/html
-
- find examples/gnu/classpath/examples/html gnu/xml/dom/html2 external/w3c_dom/org/w3c/dom/html -name "*.java" \
- -exec sed -i -e"s|org.w3c.dom.html2|org.w3c.dom.html|" {} \;
-
- sed -i -e"s|org/w3c/dom/html2|org/w3c/dom/html|" external/w3c_dom/Makefile.am
-}
-
-addtask unpackpost after do_unpack before do_patch
-
-
-SRC_URI[md5sum] = "6a35347901ace03c31cc49751b338f31"
-SRC_URI[sha256sum] = "001fee5ad3ddd043783d59593153510f09064b0d9b5aea82f535266f62f02db4"
diff --git a/recipes/classpath/classpath_0.97.2.bb b/recipes/classpath/classpath_0.97.2.bb
deleted file mode 100644
index 406b38db88..0000000000
--- a/recipes/classpath/classpath_0.97.2.bb
+++ /dev/null
@@ -1,19 +0,0 @@
-require classpath.inc
-
-SRC_URI += "\
- file://netif_16.patch;striplevel=0 \
- file://SimpleName.diff;striplevel=0 \
- file://javanet-local.patch;striplevel=0 \
- file://ecj_java_dir.patch \
- file://autotools.patch \
- file://decimalformat.patch \
- file://cp-byte-loophelper.patch;striplevel=0 \
- file://drawpolyline.patch;striplevel=0 \
- file://gtk-fix.patch;striplevel=0 \
- file://toolwrapper-exithook.patch \
- "
-
-PR = "r11"
-
-SRC_URI[md5sum] = "6a35347901ace03c31cc49751b338f31"
-SRC_URI[sha256sum] = "001fee5ad3ddd043783d59593153510f09064b0d9b5aea82f535266f62f02db4"