summaryrefslogtreecommitdiffstats
path: root/recipes/classpathx
diff options
context:
space:
mode:
authorRobert Schuster <robertschuster@fsfe.org>2009-09-18 14:07:14 +0200
committerRobert Schuster <robertschuster@fsfe.org>2009-09-18 14:07:14 +0200
commit9360aebebce14938c89e5f7f9c411573f541d899 (patch)
tree726cf287bdce6a68fb9bd802a24f55e5fab2bbac /recipes/classpathx
parente90cec1338a3a60cbabaff3590c503edd0e10033 (diff)
downloadopenembedded-9360aebebce14938c89e5f7f9c411573f541d899.tar.gz
gnujaf 1.1.1: New recipe (from Jalimo SVN).
gnujaf-native 1.1.1: Dito. gnumail 1.1.2: Dito. gnumail-native 1.1.2: Dito.
Diffstat (limited to 'recipes/classpathx')
-rw-r--r--recipes/classpathx/gnujaf-1.1.1/datadir_java.patch23
-rw-r--r--recipes/classpathx/gnujaf-native_1.1.1.bb3
-rw-r--r--recipes/classpathx/gnujaf_1.1.1.bb35
-rw-r--r--recipes/classpathx/gnumail-1.1.2/datadir_java.patch25
-rw-r--r--recipes/classpathx/gnumail-native_1.1.2.bb5
-rw-r--r--recipes/classpathx/gnumail_1.1.2.bb42
6 files changed, 133 insertions, 0 deletions
diff --git a/recipes/classpathx/gnujaf-1.1.1/datadir_java.patch b/recipes/classpathx/gnujaf-1.1.1/datadir_java.patch
new file mode 100644
index 0000000000..807a1cbf6d
--- /dev/null
+++ b/recipes/classpathx/gnujaf-1.1.1/datadir_java.patch
@@ -0,0 +1,23 @@
+Index: activation-1.1.1/Makefile.am
+===================================================================
+--- activation-1.1.1.orig/Makefile.am 2008-03-01 10:30:06.000000000 +0100
++++ activation-1.1.1/Makefile.am 2008-03-01 10:31:04.000000000 +0100
+@@ -7,6 +7,8 @@
+ JAVADOC = @JAVADOC@
+ JAVADOCFLAGS = @JAVADOCFLAGS@
+
++JARDIR = $(datadir)/java
++
+ src = @srcdir@/source
+ dst = classes
+ doc = @srcdir@/docs
+@@ -92,7 +94,7 @@
+ $(RM) config.log config.status
+
+ install-data-local:
+- @srcdir@/mkinstalldirs $(DESTDIR)/$(datadir)/java
+- $(INSTALL_DATA) $(activation_jar) $(DESTDIR)/$(datadir)/java
++ @srcdir@/mkinstalldirs $(DESTDIR)/$(JARDIR)
++ $(INSTALL_DATA) $(activation_jar) $(DESTDIR)/$(JARDIR)
+
+ # End of Makefile.am
diff --git a/recipes/classpathx/gnujaf-native_1.1.1.bb b/recipes/classpathx/gnujaf-native_1.1.1.bb
new file mode 100644
index 0000000000..0e3e485c92
--- /dev/null
+++ b/recipes/classpathx/gnujaf-native_1.1.1.bb
@@ -0,0 +1,3 @@
+require gnujaf_${PV}.bb
+
+inherit java-native
diff --git a/recipes/classpathx/gnujaf_1.1.1.bb b/recipes/classpathx/gnujaf_1.1.1.bb
new file mode 100644
index 0000000000..1ae47172e7
--- /dev/null
+++ b/recipes/classpathx/gnujaf_1.1.1.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "Provides a mean to type data and locate components suitable for performing various kinds of action on it."
+LICENSE = "GPL + library exception"
+AUTHOR = "GNU ClasspathX"
+
+SRC_URI = "\
+ http://ftp.gnu.org/gnu/classpathx/activation-${PV}.tar.gz \
+ file://datadir_java.patch;patch=1 \
+ "
+
+# java-library must be last (it defines do_stage)
+inherit autotools java-library
+
+S = "${WORKDIR}/activation-${PV}"
+
+DEPENDS = "fastjar-native"
+
+export JAVAC = "javac"
+
+# Fake javadoc
+export JAVADOC = "true"
+
+JARFILENAME = "activation-${PV}.jar"
+ALTJARFILENAMES = "activation.jar gnujaf.jar"
+
+do_compile() {
+ mkdir -p build
+
+ javac -sourcepath source -d build `find source -name "*.java"`
+
+ fastjar -C build -c -f ${JARFILENAME} .
+}
+
+do_install() {
+ java_install
+}
diff --git a/recipes/classpathx/gnumail-1.1.2/datadir_java.patch b/recipes/classpathx/gnumail-1.1.2/datadir_java.patch
new file mode 100644
index 0000000000..50e908d232
--- /dev/null
+++ b/recipes/classpathx/gnumail-1.1.2/datadir_java.patch
@@ -0,0 +1,25 @@
+Index: mail-1.1.2/Makefile.am
+===================================================================
+--- mail-1.1.2.orig/Makefile.am 2008-03-01 11:13:36.000000000 +0100
++++ mail-1.1.2/Makefile.am 2008-03-01 11:17:49.000000000 +0100
+@@ -7,6 +7,8 @@
+ JAVADOC = @JAVADOC@
+ JAVADOCFLAGS = @JAVADOCFLAGS@
+
++JARDIR = $(datadir)/java
++
+ src = @srcdir@/source
+ dst = classes
+ doc = @srcdir@/docs
+@@ -433,8 +435,8 @@
+ rm -rf $(gnumail_jar) $(providers_jar) META-INF $(dst) $(doc)
+
+ install-data-local:
+- @srcdir@/mkinstalldirs $(DESTDIR)/$(datadir)/java
+- $(INSTALL_DATA) $(gnumail_jar) $(DESTDIR)/$(datadir)/java
+- $(INSTALL_DATA) $(providers_jar) $(DESTDIR)/$(datadir)/java
++ @srcdir@/mkinstalldirs $(DESTDIR)/$(JARDIR)
++ $(INSTALL_DATA) $(gnumail_jar) $(DESTDIR)/$(JARDIR)
++ $(INSTALL_DATA) $(providers_jar) $(DESTDIR)/$(JARDIR)
+
+ # End of Makefile.am
diff --git a/recipes/classpathx/gnumail-native_1.1.2.bb b/recipes/classpathx/gnumail-native_1.1.2.bb
new file mode 100644
index 0000000000..486645213c
--- /dev/null
+++ b/recipes/classpathx/gnumail-native_1.1.2.bb
@@ -0,0 +1,5 @@
+require gnumail_${PV}.bb
+
+inherit native
+
+DEPENDS = "fastjar-native gnujaf-native inetlib-native"
diff --git a/recipes/classpathx/gnumail_1.1.2.bb b/recipes/classpathx/gnumail_1.1.2.bb
new file mode 100644
index 0000000000..adcb1e8c1f
--- /dev/null
+++ b/recipes/classpathx/gnumail_1.1.2.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "GNU's free implementation of the JavaMail API specification"
+LICENSE = "GPL + library exception"
+AUTHOR = "GNU ClasspathX"
+
+SRC_URI = "\
+ http://ftp.gnu.org/gnu/classpathx/mail-${PV}.tar.gz \
+ file://datadir_java.patch;patch=1 \
+ "
+
+inherit java-library autotools
+
+S = "${WORKDIR}/mail-${PV}"
+
+DEPENDS = "fastjar-native gnujaf inetlib"
+
+export JAVAC = "javac"
+export JAVA = "java"
+
+# Fake javadoc
+export JAVADOC = "true"
+
+EXTRA_OECONF = "\
+ --with-inetlib-jar=${STAGING_DATADIR_JAVA} \
+ --with-activation-jar=${STAGING_DATADIR_JAVA} \
+ "
+
+do_compile() {
+ oe_runmake \
+ JARDIR=${datadir_java} \
+ gnumail_jar=${JARFILENAME} \
+ providers_jar=${P}-providers.jar
+}
+
+do_install() {
+ java_install
+ oe_jarinstall ${P}-providers.jar ${PN}-providers.jar
+}
+
+do_stage() {
+ java_stage
+ oe_jarinstall -s ${P}-providers.jar ${PN}-providers.jar
+}