aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/cnc
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/cnc
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/cnc')
-rw-r--r--recipes/cnc/openredalert/gcc43-fix.patch13
-rwxr-xr-xrecipes/cnc/openredalert/openredalert-launcher3
-rw-r--r--recipes/cnc/openredalert_r438.bb31
-rw-r--r--recipes/cnc/redalert-demo-gamedata.bb15
4 files changed, 62 insertions, 0 deletions
diff --git a/recipes/cnc/openredalert/gcc43-fix.patch b/recipes/cnc/openredalert/gcc43-fix.patch
new file mode 100644
index 0000000000..aa99d991b7
--- /dev/null
+++ b/recipes/cnc/openredalert/gcc43-fix.patch
@@ -0,0 +1,13 @@
+Index: openredalert-0.0+svnr438-r0/src/misc/Compression.h
+===================================================================
+--- openredalert-0.0+svnr438-r0.orig/src/misc/Compression.h 2008-09-21 15:20:33.000000000 +0200
++++ openredalert-0.0+svnr438-r0/src/misc/Compression.h 2008-09-21 15:21:10.000000000 +0200
+@@ -20,6 +20,8 @@
+
+ #include "SDL/SDL_types.h"
+
++#include <cstring>
++
+ /**
+ * Various decompression routines for format80, format40, and
+ * format20 type graphics
diff --git a/recipes/cnc/openredalert/openredalert-launcher b/recipes/cnc/openredalert/openredalert-launcher
new file mode 100755
index 0000000000..4e5dad4bb6
--- /dev/null
+++ b/recipes/cnc/openredalert/openredalert-launcher
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+( cd /usr/share/games/redalert && ./openredalert )
diff --git a/recipes/cnc/openredalert_r438.bb b/recipes/cnc/openredalert_r438.bb
new file mode 100644
index 0000000000..098f293b2e
--- /dev/null
+++ b/recipes/cnc/openredalert_r438.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Game engine to run Red Alert 1"
+LICENSE = "GPLv2"
+
+DEPENDS = "virtual/libsdl libsdl-mixer"
+
+SRC_URI = "http://openredalert.googlecode.com/files/openredalert-${PV}-src.tar.gz \
+ file://gcc43-fix.patch;patch=1 \
+ file://openredalert-launcher"
+
+PR = "r1"
+
+S = "${WORKDIR}"
+
+CFLAGS_append = " -I. -I${STAGING_INCDIR}"
+
+do_compile() {
+ cd ${S}/src ; cp ${S}/makefile .
+ oe_runmake -e
+}
+
+do_install() {
+ install -d ${D}/${datadir}/games/redalert/
+ cp -pPr ${S}/data ${D}/${datadir}/games/redalert/
+ install -m 0755 ${S}/src/openredalert ${D}/${datadir}/games/redalert/
+
+ install -d ${D}/${bindir}
+ install -m 0755 ${S}/openredalert-launcher ${D}/${bindir}
+}
+
+FILES_${PN} += "${datadir}/games/redalert/"
+FILES_${PN}-dbg += "${datadir}/games/redalert/.debug"
diff --git a/recipes/cnc/redalert-demo-gamedata.bb b/recipes/cnc/redalert-demo-gamedata.bb
new file mode 100644
index 0000000000..1aa5722647
--- /dev/null
+++ b/recipes/cnc/redalert-demo-gamedata.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Red Alert Demo game data"
+LICENSE = "shareware"
+
+SRC_URI = "ftp://ftp.westwood.com/pub/redalert/previews/demo/ra95demo.zip"
+
+do_install() {
+ install -d ${D}/${datadir}/games/redalert/data/mix
+ cp ${WORKDIR}/ra95demo/INSTALL/MAIN.MIX ${D}/${datadir}/games/redalert/data/mix/main.mix
+ cp ${WORKDIR}/ra95demo/INSTALL/REDALERT.MIX ${D}/${datadir}/games/redalert/data/mix/redalert.mix
+}
+
+
+PACKAGE_ARCH = "all"
+FILES_${PN} += "${datadir}/games/redalert/"
+