summaryrefslogtreecommitdiffstats
path: root/recipes/compcache
diff options
context:
space:
mode:
authorMing Chow 周明 <chow.ming@linuxbj.com>2009-08-22 07:38:49 +0000
committerKhem Raj <raj.khem@gmail.com>2009-08-31 15:55:57 -0700
commitccd18852f3dcba528bdfdf557ba9967f64625c11 (patch)
treee92399c97ab9c3966d08879a2b78814028cfa7f0 /recipes/compcache
parent5e51870a3ebcba57fb47fd221b7d79594e9d3b73 (diff)
downloadopenembedded-ccd18852f3dcba528bdfdf557ba9967f64625c11.tar.gz
compcache: Add version 0.5+0.6pre3 and version 0.6
* compcache creates RAM based block device (named ramzswap) which acts as swap disk. Pages swapped to this disk are compressed and stored in memory itself. * Compressing pages and keeping them in RAM virtually increases its capacity. This allows more applications to fit in given amount of memory. * added modules_install target in top Makefile to fit the automatically modules build process * added KERNELDIR variable to make 2.6 style KBUILD system work * modified the Makefile for rzscontrol tool to use cross toolchain instead of local gcc Signed-off-by: Ming Zhou <chow.ming@linuxbj.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/compcache')
-rw-r--r--recipes/compcache/compcache/000-compcache-KERNELDIR.patch34
-rw-r--r--recipes/compcache/compcache/001-compcache-rzscontrol-cross-compile.patch9
-rw-r--r--recipes/compcache/compcache/002-compcache-modules-install.patch13
-rw-r--r--recipes/compcache/compcache/003-compcache-0.6-KERNELDIR.patch31
-rw-r--r--recipes/compcache/compcache_0.5+0.6pre3.bb29
-rw-r--r--recipes/compcache/compcache_0.6.bb27
6 files changed, 143 insertions, 0 deletions
diff --git a/recipes/compcache/compcache/000-compcache-KERNELDIR.patch b/recipes/compcache/compcache/000-compcache-KERNELDIR.patch
new file mode 100644
index 0000000000..e80f75b077
--- /dev/null
+++ b/recipes/compcache/compcache/000-compcache-KERNELDIR.patch
@@ -0,0 +1,34 @@
+--- compcache-0.6pre3/Makefile.orig 2009-08-14 00:25:45.904934007 +0800
++++ compcache-0.6pre3/Makefile 2009-08-14 00:25:58.404938574 +0800
+@@ -1,17 +1,17 @@
+ EXTRA_CFLAGS := -DCONFIG_BLK_DEV_RAMZSWAP_STATS \
+ -g -Wall
+
+-ifndef $(KERNEL_BUILD_PATH)
+- KERNEL_BUILD_PATH="/lib/modules/$(shell uname -r)/build"
++ifndef $(KERNELDIR)
++ KERNELDIR="/lib/modules/$(shell uname -r)/build"
+ endif
+
+ obj-m += sub-projects/allocators/xvmalloc-kmod/xvmalloc.o \
+ ramzswap.o
+
+ all:
+- make -C $(KERNEL_BUILD_PATH) \
++ make -C $(KERNELDIR) \
+ M=$(PWD)/sub-projects/allocators/xvmalloc-kmod modules
+- make -C $(KERNEL_BUILD_PATH) M=$(PWD) modules
++ make -C $(KERNELDIR) M=$(PWD) modules
+ make -C sub-projects/rzscontrol
+ @ln -sf sub-projects/allocators/xvmalloc-kmod/xvmalloc.ko
+
+@@ -19,7 +19,7 @@
+ make -C sub-projects/rzscontrol doc
+
+ clean:
+- make -C $(KERNEL_BUILD_PATH) M=$(PWD) clean
+- make -C $(KERNEL_BUILD_PATH) M=$(PWD)/sub-projects/allocators/xvmalloc-kmod clean
++ make -C $(KERNELDIR) M=$(PWD) clean
++ make -C $(KERNELDIR) M=$(PWD)/sub-projects/allocators/xvmalloc-kmod clean
+ make -C sub-projects/rzscontrol clean
+ @rm -rf *.ko
diff --git a/recipes/compcache/compcache/001-compcache-rzscontrol-cross-compile.patch b/recipes/compcache/compcache/001-compcache-rzscontrol-cross-compile.patch
new file mode 100644
index 0000000000..8dbb5909eb
--- /dev/null
+++ b/recipes/compcache/compcache/001-compcache-rzscontrol-cross-compile.patch
@@ -0,0 +1,9 @@
+--- compcache-0.6pre3.orig/sub-projects/rzscontrol/Makefile 2009-08-06 23:27:40.000000000 +0800
++++ compcache-0.6pre3/sub-projects/rzscontrol/Makefile 2009-08-14 00:19:38.374938229 +0800
+@@ -1,5 +1,5 @@
+ all:
+- @gcc -g -Wall -D_GNU_SOURCE rzscontrol.c -o rzscontrol -I ../include -I../..
++ ${CCLD} -g -Wall -D_GNU_SOURCE rzscontrol.c -o rzscontrol -I ../include -I../..
+
+ doc:
+ @xmllint --noout --valid man/rzscontrol.xml
diff --git a/recipes/compcache/compcache/002-compcache-modules-install.patch b/recipes/compcache/compcache/002-compcache-modules-install.patch
new file mode 100644
index 0000000000..cf9b9b12e2
--- /dev/null
+++ b/recipes/compcache/compcache/002-compcache-modules-install.patch
@@ -0,0 +1,13 @@
+--- compcache-0.6pre3/Makefile.orig 2009-08-14 02:33:45.169249060 +0800
++++ compcache-0.6pre3/Makefile 2009-08-14 02:34:15.594938335 +0800
+@@ -13,7 +13,9 @@
+ M=$(PWD)/sub-projects/allocators/xvmalloc-kmod modules
+ make -C $(KERNELDIR) M=$(PWD) modules
+ make -C sub-projects/rzscontrol
+- @ln -sf sub-projects/allocators/xvmalloc-kmod/xvmalloc.ko
++
++modules_install:
++ make -C $(KERNELDIR) M=$(PWD) modules_install
+
+ doc:
+ make -C sub-projects/rzscontrol doc
diff --git a/recipes/compcache/compcache/003-compcache-0.6-KERNELDIR.patch b/recipes/compcache/compcache/003-compcache-0.6-KERNELDIR.patch
new file mode 100644
index 0000000000..98d7e68a5d
--- /dev/null
+++ b/recipes/compcache/compcache/003-compcache-0.6-KERNELDIR.patch
@@ -0,0 +1,31 @@
+--- compcache-0.6/Makefile.orig 2009-08-21 03:15:29.775353453 +0800
++++ compcache-0.6/Makefile 2009-08-21 03:15:49.965346252 +0800
+@@ -1,15 +1,15 @@
+ EXTRA_CFLAGS := -DCONFIG_BLK_DEV_RAMZSWAP_STATS \
+ -g -Wall
+
+-KERNEL_BUILD_PATH ?= "/lib/modules/$(shell uname -r)/build"
++KERNELDIR ?= "/lib/modules/$(shell uname -r)/build"
+
+ obj-m += sub-projects/allocators/xvmalloc-kmod/xvmalloc.o \
+ ramzswap.o
+
+ all:
+- make -C $(KERNEL_BUILD_PATH) \
++ make -C $(KERNELDIR) \
+ M=$(PWD)/sub-projects/allocators/xvmalloc-kmod modules
+- make -C $(KERNEL_BUILD_PATH) M=$(PWD) modules
++ make -C $(KERNELDIR) M=$(PWD) modules
+ make -C sub-projects/rzscontrol
+ @ln -sf sub-projects/allocators/xvmalloc-kmod/xvmalloc.ko
+
+@@ -17,7 +17,7 @@
+ make -C sub-projects/rzscontrol doc
+
+ clean:
+- make -C $(KERNEL_BUILD_PATH) M=$(PWD) clean
+- make -C $(KERNEL_BUILD_PATH) M=$(PWD)/sub-projects/allocators/xvmalloc-kmod clean
++ make -C $(KERNELDIR) M=$(PWD) clean
++ make -C $(KERNELDIR) M=$(PWD)/sub-projects/allocators/xvmalloc-kmod clean
+ make -C sub-projects/rzscontrol clean
+ @rm -rf *.ko
diff --git a/recipes/compcache/compcache_0.5+0.6pre3.bb b/recipes/compcache/compcache_0.5+0.6pre3.bb
new file mode 100644
index 0000000000..7cd29978ff
--- /dev/null
+++ b/recipes/compcache/compcache_0.5+0.6pre3.bb
@@ -0,0 +1,29 @@
+HOMEPAGE = "http://code.google.com/p/compcache"
+DESCRIPTION = "Kernel drivers version 0.6x and related tool for the compcache (compressed in-memory swap device for linux)"
+LICENSE = "GPLv2"
+
+inherit module
+
+SRC_URI = "http://compcache.googlecode.com/files/${PN}-0.6pre3.tar.gz \
+ file://000-compcache-KERNELDIR.patch;patch=1 \
+ file://001-compcache-rzscontrol-cross-compile.patch;patch=1 \
+ file://002-compcache-modules-install.patch;patch=1 \
+ "
+S = "${WORKDIR}/${PN}-0.6pre3"
+
+TARGET_CC_ARCH += "${LDFLAGS}"
+
+PACKAGES = "kernel-module-compcache compcache-utils compcache-utils-dbg compcache-utils-doc"
+
+FILES_kernel-module-compcache = ${FILES_compcache}
+FILES_compcache-utils = "${bindir}/rzscontrol"
+FILES_compcache-utils-dbg = "${bindir}/.debug/rzscontrol"
+FILES_compcache-utils-doc = "${mandir}/man1/rzscontrol.1"
+
+do_install_prepend() {
+ mkdir -p ${D}${bindir}
+ mkdir -p ${D}${mandir}/man1
+ install -m 0755 ${S}/sub-projects/rzscontrol/rzscontrol ${D}${bindir}
+ install -m 0644 ${S}/sub-projects/rzscontrol/man/rzscontrol.1 ${D}${mandir}/man1
+}
+
diff --git a/recipes/compcache/compcache_0.6.bb b/recipes/compcache/compcache_0.6.bb
new file mode 100644
index 0000000000..a24574c703
--- /dev/null
+++ b/recipes/compcache/compcache_0.6.bb
@@ -0,0 +1,27 @@
+HOMEPAGE = "http://code.google.com/p/compcache"
+DESCRIPTION = "Kernel drivers version 0.6x and related tool for the compcache (compressed in-memory swap device for linux)"
+LICENSE = "GPLv2"
+
+inherit module
+
+SRC_URI = "http://compcache.googlecode.com/files/${PN}-${PV}.tar.gz \
+ file://003-compcache-0.6-KERNELDIR.patch;patch=1 \
+ file://001-compcache-rzscontrol-cross-compile.patch;patch=1 \
+ file://002-compcache-modules-install.patch;patch=1 \
+ "
+TARGET_CC_ARCH += "${LDFLAGS}"
+
+PACKAGES = "kernel-module-compcache compcache-utils compcache-utils-dbg compcache-utils-doc"
+
+FILES_kernel-module-compcache = ${FILES_compcache}
+FILES_compcache-utils = "${bindir}/rzscontrol"
+FILES_compcache-utils-dbg = "${bindir}/.debug/rzscontrol"
+FILES_compcache-utils-doc = "${mandir}/man1/rzscontrol.1"
+
+do_install_prepend() {
+ mkdir -p ${D}${bindir}
+ mkdir -p ${D}${mandir}/man1
+ install -m 0755 ${S}/sub-projects/rzscontrol/rzscontrol ${D}${bindir}
+ install -m 0644 ${S}/sub-projects/rzscontrol/man/rzscontrol.1 ${D}${mandir}/man1
+}
+