aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/connman/connman-gnome_0.4.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/connman/connman-gnome_0.4.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/connman/connman-gnome_0.4.bb')
-rw-r--r--recipes/connman/connman-gnome_0.4.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/connman/connman-gnome_0.4.bb b/recipes/connman/connman-gnome_0.4.bb
new file mode 100644
index 0000000000..4f8d6e61f2
--- /dev/null
+++ b/recipes/connman/connman-gnome_0.4.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "gtk frontend for connman"
+HOMEPAGE = "http://www.moblin.org/projects/projects_connman.php"
+SECTION = "libs/network"
+LICENSE = "GPL"
+DEPENDS = "gtk+ dbus"
+PR = "r7"
+
+RRECOMMENDS_${PN} = "connman connman-plugin-ethernet connman-plugin-loopback connman-plugin-udhcp connman-plugin-wifi"
+
+SRC_URI = "http://www.kernel.org/pub/linux/network/connman/connman-gnome-${PV}.tar.gz \
+ file://phrase-lenght.diff;patch=1 \
+ file://connman-applet.desktop"
+
+inherit autotools gtk-icon-cache
+
+do_install_append() {
+ install -d ${D}${datadir}/applications/
+ install ${WORKDIR}/connman-applet.desktop ${D}${datadir}/applications/
+}
+