summaryrefslogtreecommitdiffstats
path: root/recipes/connman
diff options
context:
space:
mode:
authorThomas Zimmermann <zimmermann@vdm-design.de>2009-10-27 13:57:49 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2010-01-07 11:55:39 +0100
commitee6762f166a4769c8326d552ca59f431b705e86e (patch)
treeee5c72173d3466b5a729f7d3a20d5429e5db074e /recipes/connman
parent611662a49470299f3851db2823d76d4827700ff9 (diff)
downloadopenembedded-ee6762f166a4769c8326d552ca59f431b705e86e.tar.gz
connman: move test utils to separate package, shr config do not disable usb0 on startup
Signed-off-by: Klaus Kurzmann <mok@fluxnetz.de>
Diffstat (limited to 'recipes/connman')
-rw-r--r--recipes/connman/connman.inc4
-rw-r--r--recipes/connman/connman_git.bb4
-rwxr-xr-xrecipes/connman/files/shr/connman42
3 files changed, 48 insertions, 2 deletions
diff --git a/recipes/connman/connman.inc b/recipes/connman/connman.inc
index eb7aa1ab52..5b2f0cc409 100644
--- a/recipes/connman/connman.inc
+++ b/recipes/connman/connman.inc
@@ -54,7 +54,7 @@ python populate_packages_prepend() {
PACKAGES_DYNAMIC = "${PN}-plugin-*"
-PACKAGES += "${PN}-scripts"
+PACKAGES += "${PN}-scripts ${PN}-test-utils"
FILES_${PN} = "${bindir}/* ${sbindir}/* ${libexecdir}/* ${libdir}/lib*.so.* \
${sysconfdir} ${sharedstatedir} ${localstatedir} \
@@ -64,6 +64,8 @@ FILES_${PN} = "${bindir}/* ${sbindir}/* ${libexecdir}/* ${libdir}/lib*.so.* \
${libdir}/bonobo/servers \
${datadir}/dbus-1/system-services/*"
+FILES_${PN}-test-utils += "${libdir}/connman/test/*"
+
FILES_${PN}-scripts += "${libdir}/connman/scripts"
FILES_${PN}-dbg += "${libdir}/connman/*/.debug"
FILES_${PN}-dev += "${libdir}/connman/*/*.la"
diff --git a/recipes/connman/connman_git.bb b/recipes/connman/connman_git.bb
index 523d39ba2f..c0cb890e20 100644
--- a/recipes/connman/connman_git.bb
+++ b/recipes/connman/connman_git.bb
@@ -20,12 +20,14 @@ EXTRA_OECONF = " \
--enable-fake \
"
+EXTRA_OECONF_append_shr += "--disable-tools"
+
require connman.inc
SRCREV = "1a94db417ecaba20a609ff4b4431a3f67c5dcbc6"
PV = "0.42+git"
-PR = "r0"
+PR = "r2"
PR_append = ".gitr${SRCREV}"
DEFAULT_PREFERENCE = "-1"
diff --git a/recipes/connman/files/shr/connman b/recipes/connman/files/shr/connman
new file mode 100755
index 0000000000..708b1b4cd1
--- /dev/null
+++ b/recipes/connman/files/shr/connman
@@ -0,0 +1,42 @@
+#!/bin/sh
+
+DAEMON="/usr/sbin/connmand -I usb0"
+PIDFILE=/var/run/connmand.pid
+DESC="Connection Manager"
+
+if [ -f /etc/default/connman ] ; then
+ . /etc/default/connman
+fi
+
+set -e
+
+do_start() {
+ $DAEMON
+}
+
+do_stop() {
+ start-stop-daemon --stop --name connmand --quiet
+}
+
+case "$1" in
+ start)
+ echo "Starting $DESC"
+ do_start
+ ;;
+ stop)
+ echo "Stopping $DESC"
+ do_stop
+ ;;
+ restart|force-reload)
+ echo "Restarting $DESC"
+ do_stop
+ sleep 1
+ do_start
+ ;;
+ *)
+ echo "Usage: $0 {start|stop|restart|force-reload}" >&2
+ exit 1
+ ;;
+esac
+
+exit 0