aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/conntrack-tools
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2010-10-26 15:42:49 +0000
committerMichael Smith <msmith@cbnco.com>2010-11-14 18:36:52 -0500
commit09c21693bf33fe212046f2e1cbbe6a879d49b875 (patch)
tree0134d363da7a20fe9735eb704fc9de06052b5906 /recipes/conntrack-tools
parent50b90d1af7a0eff7dbbc9e6932d71d4ec97ccd81 (diff)
downloadopenembedded-09c21693bf33fe212046f2e1cbbe6a879d49b875.tar.gz
conntrack-tools: fix sh equality operator
Signed-off-by: Andreas Oberritter <obi@opendreambox.org> Signed-off-by: Michael Smith <msmith@cbnco.com>
Diffstat (limited to 'recipes/conntrack-tools')
-rw-r--r--recipes/conntrack-tools/conntrack-tools_0.9.14.bb2
-rw-r--r--recipes/conntrack-tools/files/init4
2 files changed, 3 insertions, 3 deletions
diff --git a/recipes/conntrack-tools/conntrack-tools_0.9.14.bb b/recipes/conntrack-tools/conntrack-tools_0.9.14.bb
index d5f1e4a2bf..5b1712c846 100644
--- a/recipes/conntrack-tools/conntrack-tools_0.9.14.bb
+++ b/recipes/conntrack-tools/conntrack-tools_0.9.14.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Connection tracking userspace tools for Linux"
LICENSE = "GPL"
DEPENDS = "libnfnetlink libnetfilter-conntrack"
-PR = "r1"
+PR = "r2"
SRC_URI = " \
http://www.netfilter.org/projects/conntrack-tools/files/conntrack-tools-${PV}.tar.bz2;name=tar \
diff --git a/recipes/conntrack-tools/files/init b/recipes/conntrack-tools/files/init
index cb7a7fb658..6cda750002 100644
--- a/recipes/conntrack-tools/files/init
+++ b/recipes/conntrack-tools/files/init
@@ -38,7 +38,7 @@ case "$1" in
done
start-stop-daemon --start --quiet --make-pidfile --pidfile "/var/run/${NAME}.pid" --background --exec "${DAEMON}"
RET=$?
- if [ "$?" == "0" ]; then
+ if [ "$?" = "0" ]; then
sleep 2
# Sync with other server
conntrackd -n
@@ -56,7 +56,7 @@ case "$1" in
echo -n "conntrackd "
start-stop-daemon -q -K -t -x $DAEMON
RET=$?
- if [ "$RET" == "0" ]; then
+ if [ "$RET" = "0" ]; then
PID=`cat $PIDFILE`
echo "($PID) is running"
else