aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/corosync/corosync_1.2.1.bb
diff options
context:
space:
mode:
authorRoman I Khimov <khimov@altell.ru>2010-04-23 17:39:12 +0400
committerRoman I Khimov <khimov@altell.ru>2010-04-23 22:49:09 +0400
commit4fc81a5cf4ae6c2b6a6187223874682eb2cfa1c4 (patch)
treebc6b0b563c93544aff5c3f83d8a2dd7db1ee7599 /recipes/corosync/corosync_1.2.1.bb
parentc36d284c99241e64d56ffcd6bab3e248d16fe058 (diff)
downloadopenembedded-4fc81a5cf4ae6c2b6a6187223874682eb2cfa1c4.tar.gz
corosync: update to version 1.2.1
Signed-off-by: Roman I Khimov <khimov@altell.ru>
Diffstat (limited to 'recipes/corosync/corosync_1.2.1.bb')
-rw-r--r--recipes/corosync/corosync_1.2.1.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes/corosync/corosync_1.2.1.bb b/recipes/corosync/corosync_1.2.1.bb
new file mode 100644
index 0000000000..5a86d87cf3
--- /dev/null
+++ b/recipes/corosync/corosync_1.2.1.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "OSI Certified implementation of a complete cluster engine"
+LICENSE = "BSD"
+
+PR = "r0"
+
+SRC_URI = " \
+ ftp://ftp@corosync.org/downloads/corosync-${PV}/corosync-${PV}.tar.gz;name=tar \
+ file://fix-lcrso-linkage.patch;patch=1 \
+ file://init \
+ file://corosync.conf \
+ file://volatiles \
+ "
+SRC_URI[tar.md5sum] = "cba5eb5da41630f53e54b90c449c056d"
+SRC_URI[tar.sha256sum] = "d919d9817c4cde9e3d38e6f79731d9e1cd53485c6160bd253d888fa58a87a43d"
+
+inherit autotools_stage update-rc.d
+
+INITSCRIPT_NAME = "corosync-daemon"
+
+EXTRA_OECONF = "--disable-nss"
+
+FILES_${PN}-dbg += "${libexecdir}/lcrso/.debug"
+
+do_install_append() {
+ install -d ${D}/${sysconfdir}/init.d
+ install -d ${D}${sysconfdir}/default/volatiles
+ install -m 0755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/corosync-daemon
+ install -m 0644 ${WORKDIR}/corosync.conf ${D}/${sysconfdir}/corosync/corosync.conf.example
+ install -m 0644 ${WORKDIR}/volatiles ${D}${sysconfdir}/default/volatiles/05_corosync
+}
+
+pkg_postinst_${PN} () {
+ set -e
+ grep haclient /etc/group || addgroup haclient
+ grep hacluster /etc/passwd || adduser --disabled-password --home=/var/lib/heartbeat --ingroup haclient -g "HA cluster" hacluster
+ /etc/init.d/populate-volatile.sh update
+}