aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/cppunit
diff options
context:
space:
mode:
authorLucian Ion <luciani@microsol.ie>2009-06-04 12:58:48 +0100
committerMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2009-06-04 16:32:18 +0200
commitfaf95470f515a158ff07c69f6693f95c448b605f (patch)
tree470f5750370be5818433d2e1bd44775f02801a6c /recipes/cppunit
parent996a8fc09d885d3a577ac5345966287f516b1f67 (diff)
downloadopenembedded-faf95470f515a158ff07c69f6693f95c448b605f.tar.gz
update cppunit version to 1.12.1
Diffstat (limited to 'recipes/cppunit')
-rw-r--r--recipes/cppunit/cppunit_1.12.1.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/cppunit/cppunit_1.12.1.bb b/recipes/cppunit/cppunit_1.12.1.bb
new file mode 100644
index 0000000000..e4c146eede
--- /dev/null
+++ b/recipes/cppunit/cppunit_1.12.1.bb
@@ -0,0 +1,20 @@
+# cppunit OE build file
+# Copyright (C) 2005, Koninklijke Philips Electronics NV. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION = "Unit Testing Library for C++"
+HOMEPAGE = "http://cppunit.sourceforge.net/"
+LICENSE = "LGPL"
+SECTION = "devel"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/cppunit/cppunit-${PV}.tar.gz"
+
+inherit autotools binconfig
+
+CXXFLAGS_powerpc += "-lstdc++"
+
+do_stage () {
+ autotools_stage_includes
+ cd ./src/cppunit/.libs/
+ oe_libinstall -a -so libcppunit ${STAGING_LIBDIR}
+}