aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/cpuburn/cpuburn_1.4.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/cpuburn/cpuburn_1.4.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/cpuburn/cpuburn_1.4.bb')
-rw-r--r--recipes/cpuburn/cpuburn_1.4.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/cpuburn/cpuburn_1.4.bb b/recipes/cpuburn/cpuburn_1.4.bb
new file mode 100644
index 0000000000..a3d1264212
--- /dev/null
+++ b/recipes/cpuburn/cpuburn_1.4.bb
@@ -0,0 +1,25 @@
+# cpuburn OE build file
+# Copyright (C) 2006, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION="CPU testing utilities in optimized assembler for maximum loading P6, K7, K6, P5 chips"
+HOMEPAGE="http://pages.sbcglobal.net/redelm/"
+LICENSE="GPL"
+
+SRC_URI="http://pages.sbcglobal.net/redelm/${PN}_1_4_tar.gz \
+ file://gcc_CC.patch;patch=1"
+
+python do_unpack () {
+ bb.build.exec_func('base_do_unpack', d)
+ bb.build.exec_func('cpuburn_do_unpack', d)
+}
+
+cpuburn_do_unpack () {
+ tar xvf ${PN}_1_4_tar
+}
+
+do_install () {
+ oe_runmake install DESTDIR=${D}
+}
+
+