aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/cramfs/cramfs-native_1.1.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/cramfs/cramfs-native_1.1.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/cramfs/cramfs-native_1.1.bb')
-rw-r--r--recipes/cramfs/cramfs-native_1.1.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/cramfs/cramfs-native_1.1.bb b/recipes/cramfs/cramfs-native_1.1.bb
new file mode 100644
index 0000000000..062a704ea5
--- /dev/null
+++ b/recipes/cramfs/cramfs-native_1.1.bb
@@ -0,0 +1,27 @@
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/cramfs"
+
+DESCRIPTION="Builds cramfs filesystems for embedded systems"
+SECTION = "base"
+LICENSE="GPL"
+
+PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/cramfs/cramfs-1.1.tar.gz \
+ file://makefile.patch;patch=1 \
+ file://cramfs-andersee.patch;patch=1"
+
+DEPENDS = "zlib-native"
+
+S = "${WORKDIR}/cramfs-${PV}"
+
+inherit native
+
+do_compile() {
+ oe_runmake all
+}
+
+do_stage() {
+ install -m 755 mkcramfs ${STAGING_BINDIR}
+ install -m 755 cramfsck ${STAGING_BINDIR}
+}
+