aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/cron/cron_3.0pl1.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/cron/cron_3.0pl1.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/cron/cron_3.0pl1.bb')
-rw-r--r--recipes/cron/cron_3.0pl1.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes/cron/cron_3.0pl1.bb b/recipes/cron/cron_3.0pl1.bb
new file mode 100644
index 0000000000..f7c2ccc6ba
--- /dev/null
+++ b/recipes/cron/cron_3.0pl1.bb
@@ -0,0 +1,34 @@
+SECTION = "base"
+DESCRIPTION = "Vixie cron."
+LICENSE = "cron"
+PR ="r8"
+DEPENDS += "install-native"
+
+SRC_URI = "http://ibiblio.org/pub/Linux/system/daemons/cron/cron${PV}.tar.gz \
+ file://nonrootinstall.patch;patch=1 \
+ file://time.patch;patch=1 \
+ file://init"
+S = "${WORKDIR}/cron${PV}"
+
+INITSCRIPT_NAME = "cron"
+INITSCRIPT_PARAMS = "defaults"
+inherit update-rc.d
+
+CFLAGS_append = " -I${S} -DSYS_TIME_H=0"
+do_install () {
+ install -d ${D}${sbindir} ${D}${bindir}
+ install -d ${D}${sysconfdir}/init.d/
+ install -d ${D}/var/cron/tabs
+ install -c -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/cron
+ oe_runmake 'DESTDIR=${D}' install
+ chmod ugo+rx ${D}${sbindir}/* ${D}${bindir}/*
+}
+pkg_postinst() {
+ update-rc.d cron defaults 65
+}
+
+pkg_postrm() {
+ update-rc.d cron remove
+}
+
+