aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/curl
diff options
context:
space:
mode:
authorMarc Olzheim <marc@iphion.nl>2009-08-10 11:14:06 +0200
committerHolger Hans Peter Freyther <zecke@selfish.org>2009-08-11 03:34:30 +0200
commit51221fe1ad416904f7db22f4cc80b712757e3681 (patch)
treeb48f70e2c4439ea5b5f113128a53c377cad11e55 /recipes/curl
parent16e1b32d6991d551c5f86c588669de4521dad4b9 (diff)
downloadopenembedded-51221fe1ad416904f7db22f4cc80b712757e3681.tar.gz
curl-7.19.5: Fix for curl artifact 2825989
Add curl-add_all_algorithms.patch to 7.19.5 recipe. Fixes curl artifact id 2825989 https://sourceforge.net/tracker/index.php?func=detail&aid=2825989&group_id=976&atid=100976 http://cool.haxx.se/cvs.cgi/curl/lib/ssluse.c#rev1.229 http://patchwork.openembedded.org/patch/928/ Signed-Off-By: Holger Hans Peter Freyther <zecke@selfish.org>
Diffstat (limited to 'recipes/curl')
-rw-r--r--recipes/curl/curl_7.19.5.bb5
-rw-r--r--recipes/curl/files/curl-add_all_algorithms.patch22
2 files changed, 25 insertions, 2 deletions
diff --git a/recipes/curl/curl_7.19.5.bb b/recipes/curl/curl_7.19.5.bb
index df83fe8c0a..b5b6182e8d 100644
--- a/recipes/curl/curl_7.19.5.bb
+++ b/recipes/curl/curl_7.19.5.bb
@@ -1,5 +1,6 @@
require curl-common.inc
require curl-target.inc
-SRC_URI += "file://off_t_abi_fix.patch;patch=1;pnum=0"
-PR = "r0"
+SRC_URI += "file://off_t_abi_fix.patch;patch=1;pnum=0 \
+ file://curl-add_all_algorithms.patch;patch=1"
+PR = "r1"
diff --git a/recipes/curl/files/curl-add_all_algorithms.patch b/recipes/curl/files/curl-add_all_algorithms.patch
new file mode 100644
index 0000000000..a55af12575
--- /dev/null
+++ b/recipes/curl/files/curl-add_all_algorithms.patch
@@ -0,0 +1,22 @@
+--- curl-7.19.5/lib/ssluse.c 2009-01-26 15:36:22.000000000 +0100
++++ curl-7.19.5/lib/ssluse.c 2009-07-23 15:44:12.000000000 +0200
+@@ -58,6 +58,7 @@
+ #ifdef USE_SSLEAY
+
+ #ifdef USE_OPENSSL
++#include <openssl/evp.h>
+ #include <openssl/rand.h>
+ #include <openssl/x509v3.h>
+ #else
+@@ -627,6 +628,11 @@
+ /* Lets get nice error messages */
+ SSL_load_error_strings();
+
++#ifdef USE_OPENSSL
++ /* Load all algorithms (including SHA2) */
++ OpenSSL_add_all_algorithms();
++#endif /* USE_OPENSSL */
++
+ /* Setup all the global SSL stuff */
+ if(!SSLeay_add_ssl_algorithms())
+ return 0;